フォーラムへの返信

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • 返信先: EmEditorとソフトウェアの通信 #19781

    yamatake
    参加者

    確かに
    aij83E7
    Updater Support Service
    \EmEditor\eeupdate.exe /runservice
    というサービスが登録されていました。UACに関与するようなこのようなサービスを
    ユーザーに知らせずに潜り込ませるのは非常に疑わしいとしかいいようがありません。

    そもそもエディタには通信という要素はまったく必要なく(FTPの機能などがあるものでもないので)
    このような要素はユーザーの不安と共に即刻取り除いてほしいものです。

    更新は自力で情報を入手します。バージョン情報からHPに飛べればそれで十分でしょう。
    以上、よろしくお願いします。

    追記
    私が訴えたいのはファイアウォールの設定がどうこうという問題に逃げるのではなく、
    エディタというソフトに根本的に必要性のない通信機能を盛り込むなということです。
    そのことが伝われば幸いです。

    返信先: EmEditorとソフトウェアの通信 #19779

    yamatake
    参加者

    EmEditorを起動する際にOutpost Firewallが外部への通信許可を求めてきます。
    バージョンから更新チェッカに手を加えたバージョンのことからと推測されます。
    怪しい挙動をするようにしたのであれば改善、もしくは元に戻してもらえるようお願いします。


    yamatake
    参加者

    日本語ヘルプでキーワードが文字化けしているのが確認できました。
    確認の上修復していただけるようお願いします。

    返信先: EmEditor Professional v11 Beta 2 (10.9.1) #10551

    yamatake
    参加者

    EmEditor Professional v11 Beta 2(32-bit)を試用しています。
    フォントサイズ12、80文字で折り返し、大きいアイコンを使用するという設定で
    使っているのですが、検索バーは無理なく配置できるのですが
    これを置換にすると画面端より右、画面外にバーが飛び出してしまいます。
    さらに検索に戻すには右端のボタンを押す必要があり、一回ウィンドウを
    広げなくてはならずたいへん不便です。
    フォントサイズ12のままで置換バー全体を表示しようとすると
    大きいアイコンでは文字数にして約110、小さいアイコンにしても約100必要で、
    普段からそれだけ横幅をとって作業をしている人は少ないのではないかと思います。
    検索/置換ツールバーの配置について横幅がメニューバーくらいに収まる
    配置の方法は取れないでしょうか。ご一考頂ければ幸いです。


    yamatake
    参加者

    ツールメニューの[カスタマイズ]の[高度] タブで、
    [一時ファイルを使う最小ファイルサイズ]に90Mの数値を割り当ててみましたが、
    ルーラーの処理がワンクッション入ることによる動作時間の影響の方が大きいです。
    (元々[一時ファイルを使う最小ファイルサイズ]には300Mの数字が割り当てられていましたが
    特に変化はありませんでした)
    テキストの大きさ自体による読み込み時間よりも、ルーラーの処理が多数の行の
    ファイルを想定していないと思われる挙動になっていることが原因ではないかと思います。
    従前の書き込みで比較対象として挙げた秀丸エディタ、MMエディタはこの動作が
    スムーズに行われているようで、その分速く読み込むというか、早く最初の動作に
    取りかかれるという次第です。

    引き続きそちらの方でも挙動を確かめ、改善できるところがあれば改善して頂けると
    助かります。たびたびお手数かけますがよろしくお願いします。


    yamatake
    参加者

    だいぶ遅れてしまいましたが、こちらの環境でも自己解決(?)しましたので
    その顛末を報告します。

    まず、https://search.thawte.com/support/ssl-digital-certificates/index?page=content&id=AR1406 にある手順で、
    Thawte ルート証明書と中間機関証明書をPCにインストールすればという方法を試してみまして、
    その結果、やはり「プログラムが壊れています。」のメッセージと共に起動しませんでした。
    (リンク先の内容はこちらも詳しく理解できませんでしたので、本当に正しくインストールできたかは自信は持てません)

    そこで、LANが切断された/LANが接続されたという文面から考え、
    こちらのネットワークの設定を全部削除して一から作り直したところ、
    ようやくエラーメッセージの表示もなく正常起動させることに成功できました。
    正確な原因は判明できませんでしたが、これでソフトのアップデートに追従することが
    できるようで一安心しております。
    このたびは誠にお手数かけました。ありがとうございます。

    ついでながら、このエラーが出る以前に指摘した
    http://jp.emeditor.com/modules/newbb/viewtopic.php?topic_id=1670&forum=4&post_id=7161#forumpost7161
    の問題ですが、v10.0.8においても改善されてはいませんでした。
    巨大ファイルに対応、軽くて、高速起動、動作も高速!を謳いながら、
    実際に巨大ファイル(以前の投稿で挙げたのは100万行、サイズにして100MBくらいです)を
    開けるときに動作がもたつく結果、実際には秀丸エディタ、MMエディタなどに
    起動速度で後れを取るようですとユーザーとしても釈然としないものがありますので、
    こちらの方も引き続き改善に向けて頂ければ幸いです。引き続きよろしくお願いします。


    yamatake
    参加者

    「ルート証明書の更新プログラムを適用」という言葉にピンときて
    WindowsUpdateを確認してみましたが、ルート証明書に関する更新はありませんでした。
    (今までも一応不定期ながら更新の確認はしています)

    いよいよこちらでできることも手詰まりになってきた感がありますので、
    何度もお手数書けますがそちら側の検証も引き続きお願いする次第です。

    また、v10.0.7 から署名に関して暗号方式が RSA 2048bitに変更された
    ということで間違いなければ、その旨を公開の変更点に明記することで
    同様のトラブルがユーザーレベルで回避できたりフォーラムのやりとりが
    無駄に繰り返されることも未然に防げるかと思います。
    バージョンアップに関する変更点として追加して記載頂ければ幸いです。


    yamatake
    参加者

    こちらから使用に影響を与えそうなアプリとして、まずご指摘のNOD32(4.2.52.0)と、
    使用しているファイアウォールであるOutpostFirewall(6.73.3063.11009)
    (XP付属のそれは無効にしてある)の保護を停止しましたが状況は改善されませんでした。

    また、「Windows タスクマネージャーのプロセス タブで、実行ファイルのパスが
    表示できる状態~」という方法が恥ずかしながら分かりませんものでしたので、
    同種のProcessExplorer(14.12)というアプリで調べましたが、エラーが出て消滅するまでの
    emeditor.exeの実行ファイルとその作業パスはインストールした箇所のそれであること、
    またそのバージョンはたしかに10.0.8であることまで確認できました。

    複数のセキュリティ環境でバージョンを上げた瞬間から同種の問題が発生するのが
    それぞれの環境が原因とはにわかには考えにくいですので、お手数ですが
    もう少しそちらの方でも調べて頂けると助かります。引き続きよろしくお願いします。

    追記
    hn2さんの投稿が直前に載りましたのでこちらでも同様に調べてみたところ、
    v10.0.6~v10.0.8の32/64bitインストーラについて、デジタル署名および
    その副署名について「署名にある証明書を検証できません」等の問題のあるメッセージは
    見られなかったことを追記します。(「このデジタル署名は問題ありません。」という表示でした)


    yamatake
    参加者

    ver.10.0.7のこの不具合情報を見て新バージョンの導入を保留し、
    問題を解決したとされるver.10.0.8を導入したのですが、hn2さんの先の報告と同じように
    「EmEditorを起動して数十秒経過すると‥」「シリアル番号未登録の状態だと数十秒後に
    シリアル番号の入力を促すダイアログが自動で表示される」タイミングで
    「プログラムが壊れています‥」のメッセージが表示され強制終了してしまいます。

    こちらの環境は
    ・実マシン(VMware上でない)WindowsXPSP3(32bit)
    ・起動させようとしたバージョンはver.10.0.8のポータブル版、また、インストーラ使用の
     32bit版でも同様の現象が起きることを確認
    ・アンチウイルスソフトはver.10.0.7の更新情報で記述のあるavast!ではなくNOD32
    ・インストールした場所はC:Program Files以下ではなく自分でオンラインソフト用に
     まとめた別のフォルダ
    ・ver.10.0.8のポータブル版および32bitインストーラファイルのSHA1ハッシュ値と
     バイト数もサイトにあるものと一致しているところまで確認
    以上です。

    今まではver.10.0.6ポータブル版を使っており、これ以上バージョンを上げなければ
    問題なく動作しております。引き続きこれ以降のバージョンで更新する際に
    なにか問題が起きなかったか、確認および改善して頂けるようよろしくお願いします。

    返信先: このサイトの構成について #9719

    yamatake
    参加者

    体験版ダウンロード先のリンク修正を確認しました。
    ありがとうございます。

    v11の開発に入ってらっしゃるようなので、
    正式版、もしくは同等の体験版がダウンロードできるようになるのに際し
    リンクを改めて最新のものに直していただいて、
    また、v11の新機能の内容や宣伝文句なども変わるかと思いますので
    それを機にサイトのレイアウトをわかりやすく一新するのが
    よいのではないかなと思います。
    (サポートのページなど表記がまだ9のままのところもありますので…)

    そういうわけで、引き続きよろしくお願いします。


    yamatake
    参加者

    本体でなく、v8のプラグインの中に存在しました。
    同時にv9、v10でも同じプラグインで
    問題なく機能していることも報告します。
    早合点でお手数とらせても申し訳ありませんでした。


    yamatake
    参加者

    これで検索バーの利便性が格段に向上すると思います。
    重ねて検討よろしくお願いします。

12件の投稿を表示中 - 1 - 12件目 (全12件中)