フォーラムの返信を作成しました。

1 件の投稿を表示中 (合計 35 個)
  • 作成者
    投稿
  • 返信先: 最上段の描画がおかしい #29043
    にしし
    参加者

    横から失礼します。

    この現象は、私の環境でもありました。(EmEditor v19.5.0 32bit版 on Win10 Pro 64bit版)
    先頭行の最上部の高さ1ピクセル分だけがずっと残り続けてしまう(しかしカーソルを1行目に戻すと解消する)というような感じの現象でした。
    気になっていたのでフォーラムで報告しようかなと思っていたのですが、最新の v19.5.95 では解消されていました。
    おそらく何らかの対策をお取り下さったのですね。(ありがとうございます!)

    というわけで、「うちでも同様の現象が(以前に)ありました」というだけの報告でした。

    返信先: CTRL+Fで選択文字列が検索欄に入らない #29042
    にしし
    参加者

    江村様

    早々のご返答をありがとうございます。
    そして、すみません。なんと、そこに設定の選択肢があったとは!
    いつの間にか何かの原因で選択が切り替わってしまっていたのですね。
    (自分では設定に触れた記憶がなかったので、てっきりデフォルトの動作が変更されたのかと思い込んでしまいました。)
    ご指摘頂いた通りに設定を変更したところ、完全に望み通りの動作に戻りました。

    お騒がせ致しました。m(_ _)m
    ありがとうございます。

    にしし
    参加者

    江村様

    早速、EmEditor v19.0.92(32bit版)をWindows10(64bit版)にインストールして動作を試しました。
    一連の問題の現象は、どれも発生しなくなっていることを確認できました!
    どうもありがとうございました。
    ご尽力に深く感謝致します。
    EmEditorは私の中で完全に手放せないテキストエディタになっており、日々の機能増強もたいへんありがたいです。どうもありがとうございます!

    にしし
    参加者

    上記の件ですが、Windows7 (32bit版) 上のEmEditor v19.0.91 (32bit版)でも試してみたところ、Win10上の場合と同様に、EmEditorが「応答なし」状態になりました。
    https://www.nishishi.com/work/EmEditor-CSS-Calc-NoRes-Win7.png
    前回(バージョンアップ前)は、問題イベント名が APPCRASH で障害モジュールが css-html-validator.dll と出ていましたが、今回は上図の通り AppHangB1 としか出ていませんでした。
    参考までにお知らせ致しました。

    にしし
    参加者

    江村様
    ご対応をどうもありがとうございます。

    早速、v19.0.91(32bit版)をダウンロードし、Win10(64bit版)上で動作を試してみました。([カスタマイズ] の [構文チェック] で、[自動的に最新の情報に更新] にチェックを入れた状態で。)
    ……しかし、
    たしかに前回のように、問答無用でEmEditorのウインドウが消滅してしまうことはありませんでしたが、下図のようにEmEditorが「応答なし」状態になってしまって編集を継続できなくなりました。何度か試しましたが、再現率は100%でした。
    https://www.nishishi.com/work/EmEditor-CSS-Calc-NoRespond.png

    念のため、Windows自体を再起動してからも試しましたが、やはり上図のように(丸カッコ内に)割り算の記号「/」を書いた時点で「応答なし」になってしまいました。

    にしし
    参加者

    江村様

    迅速なご対応をどうもありがとうございます。
    構文チェックの [自動的に最新の情報に更新] を無効に設定したところ、落ちる問題は発生しなくなりました。
    この設定で使わせて頂きます。

    にしし
    参加者

    上記の件ですが、Windows7 (32bit版) 上のEmEditor v19.0.0 (32bit版)でも試してみたところ、やはり同様の操作で落ちました。

    ただ、Windows10 (64bit版)上のEmEditor v19.0.0 (32bit版) の場合とは異なり、「EmEditorは動作を停止しました」というウインドウは出てきました。
    ( https://www.nishishi.com/work/EmEditor-CSS-Calc-Win7.png )
    構文チェッカーに現れたエラー文言は「Exception~」で同じような感じに見えました。(一言一句はチェックしていませんが)

    以上、参考までにお知らせ致しました。

    にしし
    参加者

    KawakamiTakahiroさん、コメントありがとうございます。
    2つ目の書き方をした際に、構文チェッカーにどう表示されるのかを、私の環境でも試してみました。
    https://www.nishishi.com/work/EmEditor-CSS-Calc.png (※キャプチャ画像です。)
    まったく同じ内容ですね。
    そして、私の環境では、このあと、先頭に「 { 」記号を1つ打つと、やはりEmEditor自体が落ちます。

    なお、上図の構文チェッカーに表示されたエラーをコピーしたものは以下の通りです。(同じですね)
    エラー 無題-9 2019070500: Exception: 2013092001: Exception: 2011041110: Exception: 20110411111: Exception: 20110411112: Exception: 20110411119: Exception: 2006112701: StrStoreExW::getStringWithLoc(): end not in string, start is calc( ( 100% – 300px ), string is width: calc( ( 100% – 300px ), stringlength is 29 Please contact us at support@htmlvalidator.com if you believe that you’ve found a bug or need assistance.

    ※1つ目の書き方をした場合は、構文チェッカーが表示されているか表示されていないかに関係なく、私の環境(EmEditor v19.0.0 32bit版 on Win10 64bit)では落ちました。
    なお、落ちる瞬間には、構文チェッカーの表示領域には何もメッセージは追加されずに落ちます。(上記にペーストしたようなExceptionエラーも一切表示されないまま、落ちました。)

    以上、参考までにお知らせ致します。
    (私の利用環境にはもう1つ、Windows7 32bit版の上で32bit版EmEditorが動作しているものがあるのですが、帰宅しないと使えないので現時点では試せていません。)

    にしし
    参加者

    江村様

    [ツール]→[すべてのコマンド]で、もっとたくさんの機能にアクセスできたんですね!(驚)
    初めて知りました。(^_^;)
    どうもありがとうございます。

    にしし
    参加者

    江村様

    お手数をおかけします。
    先の投稿で「折り返し方法を変更したら問題は解消した」と述べましたが、結局そのあとまた同様の現象が発生しまして、今度は「折り返し方法」を変更しても解消しないままでした。( v18.9.8 での話です。)
    PCを再起動しても解消しないので、「まあしばらく様子を見るか……」と考えていたところでした。


    > 最新版 (現在のところ v18.9.9 ) でも問題が再現しますでしょうか?

    更新チェッカーを実行したところ 18.9.10 が出てきましたのでそれを入れてみました。
    すると、問題は再現しなくなりました。

    ちゃんと最大化した状態で起動してくれますし、ワークスペースを開いた場合も最大化してくれます。
    ご対応を、どうもありがとうございます!

    ―――――――――
    ▼レジストリファイルについて
    ―――――――――
    ところで、[ツール]→[インポートとエクスポート]から、[すべての設定をレジストリファイルにエクスポート] を選択して出力された .reg ファイルの中身を(テキストファイルとして)EmEditorで開いてみると、読み込みファイル履歴などが明らかに古く、「今起動しているEmEditorの状況」とは異なります。
    例えば、 [HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3\Recent Workspace List] 項目にリストアップされているリストがかなり古いです。
    たぶん、1年~1年半くらい前の設定ではないかな? という気がします。(今、EmEditorを操作して見えるリストとは全然異なります。)
    今、EmEditorのメニューを操作して [ファイル]→[ワークスペース]→[(最近読んだファイルリスト群)] に見えているファイル名でこの .reg ファイル内を検索してみても、ヒットしませんでした。

    念のため、レジストリエディタを起動して『 コンピューター\HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3\Recent Workspace List 』を見てみたところ、出力された .reg ファイルと同じ内容であり、現在起動しているEmEditorで見えている内容とは異なります。(※「1項目だけが異なる」とかではなく、もうまるっきり全然違います。1年以上前に使うのをやめたファイル名などが見える一方で、最近頻繁に使っているファイル名は見えません。)

    これはもしかして、「現状のEmEditorの設定は、レジストリ上にはない」ということでしょうか?
    EmEditorって、設定をレジストリではなくINIファイルとかで維持するようなオプションがあるのでしたでしょうか?
    (ただ、「バージョン情報」ウインドウを開くと、「システム情報」枠内には「レジストリを使用」と表示されています。)

    もしかして、レジストリ内のパスが異なるのでしょうかね?
    ちなみに、レジストリエディタで『 コンピューター\HKEY_CURRENT_USER\Software\EmSoft 』を見ると、存在するサブディレクトリは『 EmEditor v3 』と『 EmEditorPlugIns 』の2つだけでした。
    (今、EmEditor上で最近読み込んだワークスペースファイル名に含まれている文字列を使って、レジストリエディタ内で検索を掛けてみましたが、EmEditorの設定と思われる部分は発見できませんでした。)

    うーむ、謎です。
    EmEditorの設定がレジストリ上に存在しないってことはあり得るのでしょうか?

    ただ、[HKEY_CURRENT_USER\Software\EmSoft\EmEditorPlugIns\Explorer] に見える Path1 などの項目は、たしかに最新の情報が記録されていました。
    なので、プラグインの設定は確かにレジストリに書き込まれているように見えます。

    とりあえず、EmEditor自体は動いていますし、設定も保存されていますから、困ることはないのですが。
    ちょっと気になったのでついでに書きました。(^_^;)

    にしし
    参加者

    追記です。連投すみません。
    解決方法が分かりました。

    ツールバーに、テキストの折り返しを指定するボタンがありますが、それをクリックして折り返し方法を変更すると、それ以降は「最大化が自動で解除されてしまう問題の現象」が発生しなくなりました。
    (ワークスペースの復元時でも、1ファイルだけの読み込み時でも、新規起動時でも、すべてで。)

    特定の値にしたら、というわけではなくて、とにかく1度別の設定に変更すれば、それ以降は問題なくなるっぽい感じがします。
    普段から、主には「折り返さない」設定で使っているのですが、時々「ウインドウの右端で折り返し」に変更して編集します。
    いま、「ウインドウの右端で折り返し」に変更してみたところ、問題が発生しなくなったことに気付きました。
    再度「折り返さない」に戻してみても、問題は発生しないままです。

    なので、問題の現象の「発生方法」はまだ分からないままですが、「解決方法」は分かりました。(^_^;;;

    ※もしかしたら、折り返し方法の変更に限らず、他の設定項目をいじる(設定を再保存する?)だけでも解決するのではないかな、とも思いますけども。(問題の発生方法が分からないので実験ができません。^^;)

    にしし
    参加者

    すみません。最初にこのスレッドで指摘した現象がまた再度発現するようになりました。
    EmEditor自体を再起動しても変わりませんし、Windows10そのものを再起動しても変わりません。複数のワークスペースで同じ現象が発生します。現時点では再現率100%です。

    動作は以下のような感じです。

    「最大化状態で保存されたワークスペース」を読み込む操作をすると…
    (1) ワークスペースに含まれるファイルが読み込まれた後、一瞬だけウインドウが最大化されたように見える。
    (2) その直後に、最大化が解除されて「元のサイズ」に戻る

    ただ、その「元のサイズ」というのは、ワークスペースごとに異なります。(ワークスペースに保存されている(最大化ではない状態の)ウインドウサイズが再現されます。)

    ――――――
    ▼備考:ワークスペースだけに限らない
    ――――――
    ワークスペースを開く場合以外でも最大化が維持されないことに気付きました。

    EmEditorを最大化した状態で閉じて、再度EmEditorを起動した場合、普通なら最大化された状態で起動しますよね。
    今は、最大化した状態で閉じても、次にEmEditorを起動したときには、最大化されない状態のウインドウサイズで起動します。(ただし、デフォルトサイズではなく、最後に自分でウインドウサイズを変更したときのサイズと位置が再現されます。)

    このとき、動作は以下のようになります。
    (1) EmEditorが一瞬だけ最大化して起動したように見える。
    (2) その次の瞬間には、ウインドウサイズが元に戻る。

    新規に起動した場合でも、TXTファイルをダブルクリックしてEmEditorを開いた場合でも、どちらも同じ動作をします。

    なお、[ツール]→[カスタマイズ]で「起動時、ウインドウサイズを復元」はON/OFFどちらに設定しても動作が同じです。
    それはたぶん、その下の「タブが有効時に現在のウインドウ位置とサイズを保存、復元」にチェックが入っているからだと思うんですが。(その設定をOFFにすると当然ウインドウサイズはデフォルトサイズで起動します。ONにするとウインドウサイズや位置の変更は記憶されますが、最大化はされません(正確には、一瞬だけ最大化されてすぐに最大化が解除されます)。)

    ――――――
    ▼質問
    ――――――
    どうやったら上記の現象が再現するようになるのかハッキリしないんですけども、この状況で何か江村さんに報告できる情報を調べる方法はありますでしょうか?(^_^;)

    ――――――
    ▼直前の動作
    ――――――
    なお、この現象が発現する直前にあったのは、以下の現象です。

    『新規ファイルに名前を付けて保存しようとしたところ、「名前を付けて保存」ダイアログが白紙ウインドウの状態でフリーズする』

    この現象は、Windows10上では時々起こります。
    その点は以前にもこのフォーラムで報告していて、そのときに「名前を付けて保存ダイアログが表示される直前に自動バックアップを1回行う」という仕様を追加して下さったために、データを失うことはなくなったので困ってはいません。
    ( https://jp.emeditor.com/forums/topic/%e3%80%8c%e5%90%8d%e5%89%8d%e3%82%92%e4%bb%98%e3%81%91%e3%81%a6%e4%bf%9d%e5%ad%98%e3%80%8d%e3%83%80%e3%82%a4%e3%82%a2%e3%83%ad%e3%82%b0%e3%81%8c%e5%bf%9c%e7%ad%94%e3%81%aa%e3%81%97%e3%81%ab%e3%81%aa/ )

    なぜ「名前を付けて保存」ダイアログが開かれずにフリーズしてしまうのか、Windows10の何が悪さをしているのかは分かりませんが……。
    フォルダの一覧を表示する直前でフリーズすることもあるように感じるので、ネットワーク関連の何かが問題なのかもしれないと思っては居るのですがハッキリはしません。
    (※なお、Windows7 32bit版でもEmEditorを使用させて頂いておりますが、そちらでは同様の問題は一度も起きていません。)

    以上、長文ですみません。
    何か解決方法があると良いのですが。(前回、何もせずにいつの間にか回復したので、何かをきっかけに元に戻れば良いのですけども。^^;)

    にしし
    参加者

    江村様
    ご返答をどうもありがとうございます。

    なんと! こんな便利なプラグインが公開されていたとは。気付いていませんでした。
    早速ダウンロードして、プラグインに加えました。
    このカウント画面は良いですね! まさしく、このような表示が欲しかったのでした。
    どうもありがとうございます。
    ますます便利になりました。

    にしし
    参加者

    江村様
    早々のご返答をありがとうございます。

    ここ数日間ほど問題の現象が100%の再現率で発生しておりましたので、(たまたまバージョンアップしたタイミングで変化があったような気がしたために)仕様が変更されたのかなと思っていました。
    が、なぜか昨日以降、同様の問題が発生しなくなりました。
    今では複数のワークスペースで数回試してみても問題はまったく発生せず、ウインドウの最大化状態も正しく復元されています。
    ……というわけで、原因は分かりませんが問題は解消しました。どうもお騒がせ致しました。

    なお、参考までに申し添えますと、
    解消できたタイミングがハッキリしないのですが、思い当たるのは以下の2点くらいです。
    ■(1) ここで報告する前に、念のためと思ってカスタマイズ画面から設定をいくつか変更したり戻したりしてみた。(最終的な設定状態は変わっていないのですが、いくつかON/OFFを試しました。)
    ■(2) 古いプラグインをうっかり実行してEmEditorが落ち(落ちるのは大変珍しいです)、「EmEditorは予期せずに異常終了しています」というウインドウが表示されて、RecoveryData.eeWorkspace が生成された。

    ただ、(1)の直後ではまだ同様の問題が発生していたので、直接の要因とは思いにくいですが。(その後、何度かEmEditorを終了したり起動したりした結果、問題が解消したのかなと思わなくもないですが。)
    (2)は「TextInformation.dll」というプラグインで、昔々にOSをWin10にアップグレードした際、OSが64bit版でありながらも「32bit版EmEditor」を使い続けていた理由だったのですが、OS側の仕様変更の問題もあったのか(いつの頃からか)使えなくなったものの、削除はせずに放置していたものです。たまたまうっかり触って起動させてしまったら、EmEditorが落ちました。(^_^;)
    ちなみに、今、再度そのプラグインを実行したところ、やはり同じ「異常終了しています」が出てきて落ちたので、100%落ちるのかもしれませんね。(^_^;;; 消しておこうと思います。
    (今では、標準の「単語数」プラグインで事足りるので、もはや不要なプラグインでしたし。)

    以上、ハッキリしませんが問題は解決しましたのでご報告申し上げます。
    どうもありがとうございました。

    にしし
    参加者

    江村様
    ご返答をありがとうございます。

    よく考えたら、ユーザーメニューにはショートカットキーを割り当てて、キー操作で開くことが可能ですね。
    ワークスペース関連のメニューを集めた「ユーザーメニュー(2)」を作成して、それをショートカットキーで開けるように設定すれば、あとはカーソルキーでメニュー項目を選択すれば良いので、すべてをキーで操作でき、より望ましいことに気付きました。(メインメニューの構造を弄らなくて済みますし)
    この場合、ポップアップ場所がカーソル位置になるのはむしろ見やすくて望ましい気もします。

    ※元々ワークスペース関連のメニュー項目をマウス操作で選択していたので、「キー操作の方が楽」という視点が抜け落ちていました。(^_^;)

    というわけで、マクロのソース例をご教示頂いたりいろいろお手間をおかけ致しましたが、結局かなりシンプルな(?)解決策に落ち着きました。
    いろいろアドバイスをどうもありがとうございました!

    にしし
    参加者

    江村様

    ご返答をどうもありがとうございます。
    やはりそうなのですね。しかし、望みの用途は実現できたので良かったです。

    ご返答を読み直していて気付いたのですが、

    > ポップアップ メニューの出現場所がマウス ポインターの位置になってしまいますが、
    > それを除けばご希望の動作に近いかと思います。

    私が試したところ、ポップアップメニューの出現場所は「マウスポインタの位置」ではなく「カーソルの位置」だったのですが、何らかの設定でマウスポインタの位置にすることも可能なのでしょうか?
    (ツールバー上のボタンを押したときに、マウスポインタの位置にPOPUPするなら、ほぼプルダウンメニューっぽく見えるので、ほとんど完全に望み通りと言えそうです。)
    ※質問ばかり連投ですみません。

    にしし
    参加者

    江村様

    ご教示ありがとうございます。
    なるほど、こんな方法があったのですね!
    editor.ExecuteCommandByID(4430); で「ユーザーメニュー(2)」が開けるわけですね。
    ユーザーメニュー(2)に、ワークスペースに関する望みのメニュー項目を入れることで、(ポップアップ出現場所の点を除けば)希望通りになりました。

    今回、上記を試す過程で初めて気付いたのですが、メインメニューも自由にカスタマイズ可能だったのですね。
    [ツール]→[メニューの変更]で、「メインメニュー」を直接カスタマイズして、「ワークスペース(&K)」という新規項目(と中身)を加えると、その場でプルダウン表示されるので、私好みの設定になりました。
    メインメニューだとキーで操作もしやすいですし。ツールバーにアイコンを加えるよりも便利な感じでした。(^_^;)
    http://www.nishishi.com/work/EmEditor-AddWorkspaceMainmenu.png

    もしかして、メインメニューをカスタマイズしていると、今後のアップグレード時に新機能がメニュー項目に追加されなくなる、といった制限などはあるのでしょうか?

    にしし
    参加者

    江村様、ご回答ありがとうございます。
    原因が判明して良かったです。たしかに「表示座標」から他の項目に変えてみると、問題なく行番号が表示されました。
    (.txtファイルの編集では、指定文字数で折り返す設定にした上で、表示行数を数えたいケースが多いので、「表示座標」に設定して使っていたのでした。)

    次のバージョンでは修正頂けるとのこと、どうもありがとうございます。

    にしし
    参加者

    江村様、ご回答ありがとうございます。
    早速、レジストリエディタで HKEY_CURRENT_USER\SOFTWARE\EmSoft をエクスポートしたデータをメールでお送り致しました。

    問題の「行番号が真っ白になってしまう」現象は、拡張子.txtのファイルを編集する場合だけで、それ以外のファイルを編集する場合は問題なく(設定した表示色で)行番号が表示できていることが分かりました。なので、何らかの設定に問題があるのかな……とは思うのですが。(ただ、v16.2.0にアップグレードするタイミングでは一切設定を変更していないのですが。アップグレード前のバージョンはたぶん16.1.0だったと思いますが、もしかしたら16.1.0のベータ版だったかも知れません。)

    上記で御案内頂いたように、「すべての設定をリセット」機能を使って設定をデフォルト状態に戻したところ、(拡張子txtの編集であっても)問題なく行番号が表示されることも分かりました。(……とすると、環境やプラグインの問題ではないということでしょうかね……?)

    さすがに1からすべてを設定し直すのはかなりの手間なので、現状の状態からなんとか行番号が表示できるようになると望ましいのですが。
    お手数ですが、何か分かりましたらよろしくお願い申し上げます。

    にしし
    参加者

    江村様

    v16.1.2での素早い実装をどうもありがとうございます。
    今、また「名前を付けて保存」ダイアログが応答なし状態になったのですが、自動保存処理のおかげで、1文字もデータを失わずに済みました!
    これで今後も安心して使えます。
    (なぜ「名前付けて保存」が応答なしになるのかはよく分かりませんが。)

    どうもありがとうございました!

    にしし
    参加者

    江村様
    素早い決定をどうもありがとうございます!
    これが実装されれば、安心して活用できます。
    よろしくお願い申し上げます!

    にしし
    参加者

    江村様
    ご返答ありがとうございました!
    まさに、これです!
    既にこのような機能が存在していたのですね……! 「フォントの設定」ダイアログ自体は何度も目にしていたハズなのに、なぜかこれらの設定項目の存在は完全にスルーしていました。
    どうもありがとうございます。問題は解決しました。

    にしし
    参加者

    qtvさん、情報をどうもありがとうございます。
    まさにその通りでした。

    プロパティの「スクロール」タブで、「カーソル位置の上下1行を常に表示する」項目をOFFにすると、問題は発生しなくなりました。
    また、この現象が発生していなかったPCでは、元々この項目がOFFでした。(そこをONにしてみると、同様の問題が発生しました。)

    問題の発生していた環境は古くから使い続けているPCで、問題の発生していなかった環境は最近セットアップした環境です。なので、昔々にはデフォルトでONになっていたりしたのでしょうかね……?
    (なお、問題の発生していた環境では、この項目は「ON」でも「OFF」でもない、「チェックボックスの中に『■』が入っている状態」でした。)
    いずれにしても、解決できて良かったです。どうもありがとうございます。

    にしし
    参加者

    江村様
    ご回答ありがとうございます。
    なるほど、なるほど。よく分かりました!
    設定で見るべき箇所を誤っていました。[ファイル]タブにそういう機能があったとは、見逃していました。

    そういえば、任意の拡張子だけを独立した別設定にするという手もあったのですね。失念していました。
    ご回答頂いた対処方法で、うまくいきそうです。
    ありがとうございます。

    にしし
    参加者

    江村様
    早々のご修正をどうもありがとうございました。
    v15.5.1で修正されているのを確認しました。

1 件の投稿を表示中 (合計 35 個)