7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #10573

    Yutaka Emura
    キーマスター

    EmEditor Professional v11 RC 1 (10.9.2) を公開しました。

    Beta 2 からの主な変更点は次のとおりです。
    – Unicode 異字体シーケンス (IVS) に対応しました。(対応フォントが必要です。)
    – UI 言語の翻訳 (ロシア語と繁体字中国語を除く)
    – その他、不具合の修正を行いました。

    v11 の新機能には、マーカー、HTML/XML 文字参照のツール チップ表示、検索ツール バー、連続置換などが含まれます。

    v11 の新機能について詳しくは、EmEditor Professional 11 の特長
    http://jp.emeditor.com/modules/feature1/rewrite/tc_15.html
    をご覧ください。

    【ダウンロード方法】

    http://www.emeditor.com/pub/emed32_10.9.2.exe (32-bit)
    http://www.emeditor.com/pub/emed64_10.9.2.exe (64-bit)

    このバージョンは、v10 の登録キーで動作します。

    サポート OS: Windows 7/Vista/XP/2000 SP4/Server 2008/Server 2003

    ポータブル版は、EmEditor インストーラを使ってインストールした後、ツール メニューのインポートとエクスポート ウィザードからも作成することができます。ただし動作速度はレジストリ使用時より遅くなります。

    EmEditor Professional v4 から v10 を 2011年10月31日までに購入し、エムソフト カスタマー センターに製品登録されていれば、今までとおり、v11 へのアップグレードは無料となります。詳しくは、 http://jp.emeditor.com/modules/news/article.php?storyid=152 をお読みください。

    ご要望や不具合の報告などがございましたら、ご遠慮なくこのフォーラムにご発言ください。
    よろしくお願い申し上げます。

    #10576

    naru
    参加者

    開発お疲れ様です。

    折り返しの設定についてお伺いしたいのですが、

    ・通常時の設定:ウインドウの右端で折り返し

    の状態でTSVモードに切り替えると、『折り返さない』状態となります。
    その後、通常モードに戻すと、『折り返さない』状態のままで、
    TSVモードにする前に設定していた『ウインドウの右端で折り返し』に戻りません。
    こちらは仕様でしょうか?

    #10577

    Yutaka Emura
    キーマスター

    naru 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ご指摘のように、TSV モードから通常モードに戻しても、『折り返さない』状態のままとなっているのは仕様です。

    他にもご質問がございましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #10581

    yosyua
    参加者

    β2での報告の追加です。RC1でも同じ症状が出ます。
    先の報告の内容は、

    > WindowsXP SP3 , EmEditor v11β2 , 32-bit
    >
    > 「一行下へスクロール」(一行上へスクロール)を使うと、
    > スクロール前の水平罫線が描画されたままになります。
    > ショートカットが
    >
    >  「一行下へスクロール」 Ctrl+↓
    >  「一行下へ」 ↓
    >
    > であるという前提で話を進めますが、
    >
    >  「Ctrl+↓」(一回だけ押下) 「↓」(一回だけ押下)
    >
    > と繰り返して行くと、一行おきに水平罫線が残ります。

    という内容でしたが、江村さんのアドバイスに従って設定をいじってみると、
    「スクロールでカーソルも移動」のチェックを外すと上記の症状は出なくなりました。
    逆に再びこの設定にチェックを入れると症状が再発します。

    ひょっとしたら他の設定も関係しているのかもしれませんが、
    まずは最初にこのことを報告させて頂きます。

    お手数かとは思いますが、お手元の環境で御確認して頂ければ幸いです。

    #10583

    Yutaka Emura
    キーマスター

    yosyua 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ご指摘のとおりで、こちらでも再現しまして、既に修正しています。
    ご報告いただき誠にありがとうございます。

    今後もどうぞよろしくお願い申し上げます。

    #10584

    yosyua
    参加者

    v11RCとv10では「外部ツール」の動作が異なっており、
    気になった点をつらつらと書かせて頂きます。

    (WindowsXP SP3 , EmEditor v11 RC1 , 32-bit)

    ———————————————————————-

    仮に「Ruby」という外部ツールを新規に作成し、中身を

     タイトル      Ruby
     コマンド      %WinDir%system32cmd.exe
     引数        /k ruby -KS $(Filename).rb
     初期ディレクトリ  $(Dir)

    とします。その上で「calc.rb」というテスト用のファイルを作り、中身を

     print(“テスト計算 ” , 1 + 2 + 3 , “n”)

    とし、「calc.rb」ファイルを開いて外部ツール「Ruby」を実行します。

    ———————————————————————-

    その結果は次のようになります。

     1.EmEditorウィンドウがアクティブで、アウトプットバーもアクティブになる。

     2.タスクバーにEmEditorのアイコンを持ったタスクボタンが出る(タイトル無し)。
       アウトプットバーが非アクティブになる。

     3.Escを押す。

     4.EmEditorウィンドウがアクティブで、アウトプットバーもアクティブになる。
       タスクバーのタスクボタンが消える。

     5.Escを押す。

     6.アウトプットバーが消える。EmEditorウィンドウはアクティブのままだが、
       キャレットが表示されず入力できない。(マウスでどこかをクリックすると通常に戻る)

     7.Escを押す。

     8.EmEditorが終了する。(「全て閉じる」が実行されている模様)

    これらの現象を踏まえて幾つかお願いがあります。

     ・v10まではタイトル無しのタスクボタンの出現は一瞬だけだったはずなので、
     以前の仕様に戻して頂きたいです。

     ・外部ツールの呼び出し直後のアウトブットバーをアクティブになるようにして下さい。
      (出現したタスクボタンが居すわっていなければアクティブのはずです)
      v11RC1だとアウトブットバーを消すのにEscを二度押す必要があるので
      v10までのように一度のEsc押下で通常の入力に戻れるようにして頂ければありがたいです。

     ・アウトブットバーを消してもキャレットが表示されず、
      通常入力も受け付けないのを何とかして頂きたいです。

     ・入力を受け付けない状態でEscを押すとウィンドウが閉じられてしまうのを何とかして欲しいです。
      (実はこの現象は以前のバージョンでもたまにありました)

    #10585

    Yutaka Emura
    キーマスター

    yosyua 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ご指摘の件、こちらでも同じ条件、手順で再現いたしました。修正いたします。
    ご報告いただき、誠にありがとうございます。

    今後もどうぞよろしくお願い申し上げます。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone