4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #8206

    pascal
    参加者

    EmEditor 9.01
    Windows XP SP3

    XMLのスニペットが機能しません。なぜかHTMLのスニペットが有効な状態になっています。そしてプロパティから適用するスニペットを選択しても変化せず、常にHTMLのスニペットが適用されます。スニペットのプラグインの各種設定は全てデフォルトのままです。

    CPPファイルではCPPのスニペットが適切に適用されるのは確認できましたので、XMLだけおかしいのだと思います。

    #8207

    Yutaka Emura
    キーマスター

    pascalさんは書きました:
    EmEditor 9.01
    Windows XP SP3

    XMLのスニペットが機能しません。なぜかHTMLのスニペットが有効な状態になっています。そしてプロパティから適用するスニペットを選択しても変化せず、常にHTMLのスニペットが適用されます。スニペットのプラグインの各種設定は全てデフォルトのままです。

    CPPファイルではCPPのスニペットが適切に適用されるのは確認できましたので、XMLだけおかしいのだと思います。

    EmEditor をご利用いただき、ありがとうございます。

    スニペットについてですが、スニペットのフォルダ毎に、どの設定に関連付けるかを変更できるようになっています。たとえば、スニペット カスタム バーの中のツリーの HTML のフォルダで右クリックしてから、プロパティを選択し、[設定] タブをクリックすると、どの設定に関連付けるかを指定することができます。

    既定では、HTML のスニペットは、HTML の設定に、XML のスニペットは XML の設定に関連付けられているはずですが、確認していただけると幸いです。また、 XML を開いている際、ステータス バーに XML と表示されているかも確認していただけると幸いです。

    #8208

    pascal
    参加者

    Yutakaさんは書きました:

    スニペットについてですが、スニペットのフォルダ毎に、どの設定に関連付けるかを変更できるようになっています。たとえば、スニペット カスタム バーの中のツリーの HTML のフォルダで右クリックしてから、プロパティを選択し、[設定] タブをクリックすると、どの設定に関連付けるかを指定することができます。

    既定では、HTML のスニペットは、HTML の設定に、XML のスニペットは XML の設定に関連付けられているはずですが、確認していただけると幸いです。また、 XML を開いている際、ステータス バーに XML と表示されているかも確認していただけると幸いです。

    設定は次のようになっています。

    XMLの設定

    HTMLの設定

    スニペットの動作とステータスバーの表示

    他に何か設定を忘れているのでしょうか? なおスニペットを使うのはこれが始めてのことであり、ツールバーをカスタマイズしている他は全てデフォルト設定のままです。

    #8209

    Yutaka Emura
    キーマスター

    申し訳ありません。こちらでも再現しました。

    これは、 XML の設定では、 HTML 特別構文に指定されているため、XML は HTML と判断されてしまっているためです。

    スニペット カスタム バーの中のツリーの XML のフォルダで右クリックしてから、プロパティを選択し、[設定] タブをクリックして、HTML にもチェックを入れて、ご使用ください。

    次のバージョンでは、XML は XML で指定できるように修正します。ご報告どうもありがとうございます。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。