9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #19200

    longlong
    Participant

    保存前のテキストは表示できるのですが、保存後のUTF-8エンコードファイルが表示できません。(日本語)
    例えば以下の文書
    =======================
    <html>
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″>
    </head>
    <body>

    最初にWindows7のインストールを行う。
    ■win7の設置
     LAN接続なし。
    =======================
    無題.txtでWebプレビューは可能でしたが、ディスクに保存し、Emeditorを再起動して読ませると
    HTMLタグもプレビューに表示してしまいます。
    このトピックには画像は添付できないのでしょうか。
    
    #19201

    Yutaka Emura
    Keymaster

    longlong 様

    文字セットを指定する部分ですが、

    meta charset=”UTF-8″

    (上の一文を実際には、タグで囲みます。)

    と指定していただければ問題はないですね。

    そのように指定していただけないでしょうか?

    どうぞよろしくお願い申し上げます。

    #19206

    longlong
    Participant

    改善されません。

    画像を参照してください。

    sannsyou

    ——————————————————–
    <html>
    <head>
    <meta charset=”UTF-8″>
    </head>
    <body>

    最初にWindows7のインストールを行う。
    
    
    ■win7の設置
     LAN接続なし。
    </body>
    </html>
    ------------------------------------------------
    #19208

    longlong
    Participant

    ちなみに、UTF-8は関係無く、HTMLタグが常に表示されます。
    新規作成でファイルに保存する前は消えているのですけど、、、一旦保存して、再表示させると
    HTMLタグがそのまま表示されます。
    ====================================
    <html>
    <head>
    </head>
    <body>
    日本語 SHIFT-JIS
    </body>
    </html>

    #19209

    longlong
    Participant

    画面のハードコピーを送る方法はないのでしょうか。
    言葉だけでは証明できません。実際に表示されているものを見ていただくのが一番ではないでしょうか。

    #19210

    longlong
    Participant

    それから、以下のようにしてあっても、charset=UTF-8は認識してくれます。保存前ならhtmlタグが消えて、日本語も正常に表示されます。保存後もプレビューで日本語は正常に表示されますが、htmlタグがそのまま表示されるようになります。
    トピックのタイトルとは異なってしまいました。UTF-8のせいだとばかり思い込んでいました。
    問題はHTMLタグが表示されるようになってしまうことです。エンコードではありませんでした。

    <html>
    <head>
    <meta charset=UTF-8″>
    </head>
    <body>

    最初にWindows7のインストールを行う。
    
    
    ■win7の設置
     LAN接続なし。
    </body>
    </html>
    
    #19211

    Yutaka Emura
    Keymaster

    longlong 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    確かに再現しましたが、これは、Internet Explorer の仕様が変わったためだと考えられます。
    拡張子を .txt でなく .htm に変更すれば問題はなります。
    お試しいただけると幸いです。

    よろしくお願い申し上げます。

    Yutaka

    #19212

    longlong
    Participant

    なるほど、それではWebプレビュープラグインは.htmファイルでなければならないという制限があるということですね。
    了解しました。
    ひjとつ疑問があります。保存前は正常に表示するので、ファイル読取り後もその状態でWebプレビューを呼び出せないのでしょうか。ファイル名をWebプレビューに渡さなければ正常に表示できるのではないかと思いました。
    今回の件、.htmを付けるとダブルクリックでファイルを開くとブラウザが開いてしまいます。これはこれで必要です。txtであればEmEditorが開きますので、装飾文書が簡単にできるなということで自分用のメモに利用しようと思って使ってみただけです。htmでしか実現できないのであれば、私にはemeditorに必要ありません。

    迅速なサポート、ありがとうございました。

    #19213

    Yutaka Emura
    Keymaster

    longlong 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ご指摘のように、ファイルに保存せずに、文書の内容を直接ウェブ ブラウザに送る、というように仕様を変更することも検討しますが、これを行うと、他の今まで問題が無かった方に問題が発生する可能性があるため、オプションにする必要がありそうです。将来的に検討させてください。

    それから、ファイルを開いた後でも、何か文字かスペースを入力して、変更された状態になっていれば、問題がなくなります。

    よろしくお願い申し上げます。

    Yutaka

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone