5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #4488

    yunoki
    メンバー

    OSをVistaにアップデートして使用したところ、XPで使っていたころには、背景色を黒にしていても問題なかったのですが、Vistaでは、キャレットも黒のままになってしまい、作業エリア内では見失ってしまいます。

    これを解決する方法はありますでしょうか?
    (もちろん背景を黒のままという前提です)

    #4492

    arere
    メンバー

    同じくVistaにて黑バックにしていますが、キャレットは表示されてます。
    (但しx64環境)

    キャレットが表示されないととても使いづらいですし、黑バックを好む人が明るい背景色というのも辛いでしょうね。

    取り敢えず原因が掴めるまでの間、設定プロパティのスクロールタブにある垂直罫線と水平罫線にチェックを入れてキャレット位置にクロス罫線を表示させてみるのは如何でしょうか。
    ちなみに私の常用設定です。

    #4494

    yunoki
    メンバー

    すみません。
    キャレットっていうと、カーソル位置で点滅しているものをさしてしまいますね。
    その部分は見えています。

    作業エリア内だとマウスカーソルが | のようになると思うんですが、それが黒いのです。

    Windowsでカーソルの設定を変更すればよいのかもしれませんが、EmEditorに関係ない部分においてもカーソルのデザインを変更してしまうことになるので困っています。

    現状は、黒より少し薄い色を設定して回避していますが、黒でマウスカーソルを見えるようになりませんでしょうか?

    画面をキャプチャしたものをお見せしたかったのですが、キャプチャソフト(Winshot)の仕様で、キャプチャ画像上ではちゃんと白く反転してカーソルが表示されてしまいました。

    #4495

    arere
    メンバー

    私の環境では文字に重なると字形と重なった部分だけ反転しますが
    文字のないところではマウスカーソルは真っ白です。

    恐らくですが、フリーのエディタなど、他のテキスト入力系アプリでも
    確認してみると、同様の症状が確認できるのではないかと思われま
    す。

    もし同様の症状なら、マウスカーソルのトラブルというと、昔からディス
    プレイドライバのバグというのがよくあるパターンなんですが、一度一
    通り確認されてみる事をお勧めします。

    #4496

    yunoki
    メンバー

    最近買ったばかりでしたが、念のためディスプレイドライバを入れなおしてみました。

    症状が改善されなかったので、グラフィックのドライバも入れなおしてみましたが、やはり同じでした。

    しかしながら、原因はEmEditorが起因ではないようですので、個人的な環境の問題として、スレッドは終了したいと思います。

    arere さまいろいろとアドバイスありがとうございました。
    大変お騒がせいたしました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone