5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #22726

    taka2710
    Participant

    江村様

    設定が下の時、

    EmEditor v16.0.0 beta 2において、ワークスペースの保存→EmEditor終了→EmEditorを起動したとき「ワークスペースの復元に失敗しました。」とダイアログが出てEmEditorが正常に起動しません。

    流れとしては、
    1)EmEditor.exeをクリック後、
    2)タスクマネージャーのメモリだけが段々と増えていき、1~2分後ぐらいしてから復元失敗のダイアログが次々に表示され、CPUも使い切り、マウスカーソルが動かないなど、PCがフリーズとなりEmEditorを起動することができません。(フリーズしたときは最終的にEmEditorがメモリを7GBほど使っていました。)

    また、1)と2)の間に、ダイアログ内のファイルはEmEditorでは開いていませんでしたが、
    下のようなダイアログが出てきました。

    動作のご確認をお願いいたします。

    EmEditor v16.0.0 beta 2
    Win7 SP1 64bit メモリ:32GB

    #22727

    Yutaka Emura
    Keymaster

    taka2710 様

    いつもお世話になっております。江村です。

    これは、こちらでも再現しましたが、beta 1 の不具合でした。beta 2 では修正されていますが、beta 1 でワークスペースの保存時に問題があるため、beta 2 でワークスペースを復元した時に症状が発生します。beta 2 でワークスペースを保存、復元した場合、または v15.9.0 で保存してから v16.0.0 beta 2 で復元した場合には問題は発生しませんでした。

    一度、ワークスペースを完全に削除してから、ワークスペースを保存していただければ、それ以降は問題は発生しないと思います。お手数をお掛けして申し訳ありませんでした。

    よろしくお願いします。

    #22728

    taka2710
    Participant

    江村様
    アドバイスありがとうございます。
    先の報告後、v15.9.0に戻しておりましたので早速確認してみましたが、こちらの環境では同様の現象が再現されました。

    1)
    v15.9.0 でワークスペース保存→v16.0.0 beta 2にアップデートし、ワークスペース復元で現象再現しました。
    2)
    一度、ワークスペースを完全に削除してからということでしたので、
    v16.0.0 beta 2にアップデート後、自動ワークスペースの設定を「なし」にしてEmEditorが終了、起動することを確認し、
    EmEditorで何もファイルを開いてない状態にし、
    園後、設定をトピックトップのものにし、ファイルをEmEditorの複数ウィンドウで開き、EmEditor終了、再度EmEditorを起動した場合に、
    現象再現しました。

    この現象が再現すると、EmEditorを起動すると現象が再現し、EmEditorが使用出来なくなってしまいますので、
    再度ご確認を頂けませんでしょうか。

    よろしくお願いいたします。

    #22729

    Yutaka Emura
    Keymaster

    taka2710 様

    いつもお世話になっております。江村です。

    確かに再現しました。ご迷惑をおかけして申し訳ありません。

    このようになった場合、

    emeditor.exe /clw

    として起動すると、ワークスペースを消去して EmEditor を起動することができます。

    これは修正いたします。

    よろしくお願いします。

    #22731

    taka2710
    Participant

    beta3で修正されましたことを確認しました。ありがとうございます。
    その他、ご報告しましたCSVの不具合なども修正されましたことを確認しました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone