5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #20552

    redakt55
    Participant

    「次を検索」機能が異常です。再現手順は以下の通りです。

    [1] 以下のようなテキストを用意。

    あああ[改行]

    [2] テキスト先頭に移動。
    [3] 「あ」を検索。
    →最初の「あ」が選択状態に。(正常)
    [4] 「次を検索」
    →2番目の「あ」が選択状態に。(正常)
    [5] 「次を検索」
    →選択が解除され,2番目と3番目の「あ」の間にカーソルが立つ。(異常)
    [6] 「次を検索」
    →2番目の「あ」が選択状態に。(異常)

    「あああ」のあとの改行が無かった場合はこの現象は起きません。
    「前を検索」の場合は類似の現象は見られませんでした。

    #20554

    Yutaka Emura
    Keymaster

    redakt55 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    お使いの EmEditor のバージョンはいくつでしょうか?

    もし標準以外のプラグインを使用されている場合には、それらのプラグインをすべて無効にしてお試しください。また、マクロをイベントに割り当てて使用されている場合にも、それらのマクロをすべて無効にしてお試しください。

    こちらでは、 v14.6.0 beta 10 で再現しないので、何か、特別な条件の下で発生している問題だと思います。

    大変お手数ですが、もしよろしければ、レジストリ エディタで、

    HKEY_CURRENT_USER\Software\EmSoft

    のキーをエクスポートして、zip に圧縮して tech@emurasoft.com 宛メールで送っていただければ、こちらで再現テストを行ってみます。

    その際、フォーラムの redakt55 様であることを書いておいてください。

    よろしくお願い申し上げます。

    #20557

    redakt55
    Participant

    プラグインは追加していませんが,念のため全部外してみました。
    マクロについてですが,「マクロ」→「カスタマイズ」の「マイマクロ」で,どのマクロを選んでも「イベントで実行」が OFF であれば,イベント割当ては行っていないと考えてよいのでしょうか? であれば,割り当てていません。
    バージョンは報告時 Version 14.6.0 beta 9 でしたが,beta 10 でもやってみました。
    結果は同じです。
    レジストリはあとでお送りします。

    #20558

    Yutaka Emura
    Keymaster

    redakt55 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    「マクロ」→「カスタマイズ」の「マイマクロ」で,どのマクロを選んでも「イベントで実行」が OFF であれば,イベント割当ては行っていないと考えていただいて正しいです。既定では、イベントは割り当てられていません。

    よろしくお願い申し上げます。

    #20620

    Yutaka Emura
    Keymaster

    redakt55 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ファイルを送っていただき、ありがとうございました。
    おかげさまで、こちらでも再現し、次のベータ版、beta 14 で修正しました。
    将来、同じ不具合が出ないよう、テスト用スクリプトにも追加しました。

    今後もよろしくお願い申し上げます。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone