6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #8529

    MixNuts
    メンバー

    いつもお世話になってます。
    このたび、下記の不具合が発生したのでご報告します。
    EmEditor バージョン 9.0.7
    CPU Core2Duo 2.9GHz
    OS Windows 7 Ultimate
    メモリ 4GB

    編集中のファイルを保持したまま何度か起動と終了を繰り返す。
    1、おかしくなる直前に拡張子のないファイル(hosts)をWindowsExplorerから右クリック、EmEditorをクリックして起動しようとしたところ、(ぐるぐる回る)ウェイティングアイコンが現れ、15分待ってもそのまま、かつ(反応なし)が表示されたままなのでAlt+F4で終了しました。hostsなおの拡張子のないファイルを開くとこうなるのですか?

    2、再起動。起動が著しく遅くなり、windowタイトルに(応答なし)のマーク
    3、メニュやツールバーなど一切制御が効かない状態ねなる
    4、Alt+F4で強制終了(機能キーは受け付けている模様)
    5、再度起動。状態変わらず
    6、OS再起動。起動。状態変わらず
    7、UsersUserNameAppDataLocalEmurasoftEmEditorWorkspaceLastData.binファイルを削除。
    起動。しばらくすると(反応なし)の表示は消えます。
    メニュやツールバーなどホバーしても反応せず。編集画面に文字は表示されません。
    タブをクリックするとタイトルバーの表示は変わりますが、フォーカスが切り替わりません。

    Windowのタイトル部分をドラッグすると画面の下半分とタイトル部分が透明になる。
    8、インストールプログラムから修復を選択、完了。起動。状態変わらず。
    再度起動するとwindowとタイトルバーのみの表示となり、タイトルバーのすぐ下にステータスバーの下半分と思しき文字('(日本語)シフト-JIS’ の下半分)が表示されています。タイトルバーでドラッグできるようになりました。

    テキストエディタはこれしか持っていません。
    どうしたらいいでしょうか?

    #8530

    MixNuts
    メンバー

    自己レスで申し訳ありません。

    LastData.binファイルを削除、
    Windows再起動
    EmEditorを起動
    を3度繰り返したところ、一旦は無事起動できるようになりました。
    LastData.binファイルを削除、EmEditorを起動しても駄目でWindowsを再起動しなければ動きませんでした。

    しかし、やはり、hostsファイルを開こうとするととたんに動作が遅くなり、やっと開けたかと思うと編集画面には何も表示されません。
    しかしステータスバーには サイズ 939バイトと表示されています。
    タブの切り替え、メニュ、ツールバーなどが効きません。Window右上の X ボタンで終了できます。
    EmEditorのエクスプローラpluginから開こうとしましたが、
    その際、Windowsフォルダをクリックしたところ、
    急に例のぐるぐるマークが現れ、かなり時間がたってからWindowsフォルダ以下がツリー表示されました。さらに、System32、drivers、etcも同様に、時間がかかります。
    EmEditorを管理者として起動しても同様です。
    hosts ファイルを 別のドライブにコピーし、これをドラッグ&ドロップでEmEditorに入れたところ、
    まったく問題なく開けました。
    しかしこれは、、、私にとってはかなり深刻なバグと思えるのですが如何でしょうか。

    #8531

    Yutaka Emura
    キーマスター

    MixNutsさんは書きました:
    自己レスで申し訳ありません。

    LastData.binファイルを削除、
    Windows再起動
    EmEditorを起動
    を3度繰り返したところ、一旦は無事起動できるようになりました。
    LastData.binファイルを削除、EmEditorを起動しても駄目でWindowsを再起動しなければ動きませんでした。

    しかし、やはり、hostsファイルを開こうとするととたんに動作が遅くなり、やっと開けたかと思うと編集画面には何も表示されません。
    しかしステータスバーには サイズ 939バイトと表示されています。
    タブの切り替え、メニュ、ツールバーなどが効きません。Window右上の X ボタンで終了できます。
    EmEditorのエクスプローラpluginから開こうとしましたが、
    その際、Windowsフォルダをクリックしたところ、
    急に例のぐるぐるマークが現れ、かなり時間がたってからWindowsフォルダ以下がツリー表示されました。さらに、System32、drivers、etcも同様に、時間がかかります。
    EmEditorを管理者として起動しても同様です。
    hosts ファイルを 別のドライブにコピーし、これをドラッグ&ドロップでEmEditorに入れたところ、
    まったく問題なく開けました。
    しかしこれは、、、私にとってはかなり深刻なバグと思えるのですが如何でしょうか。

    こちらでは再現しませんが、私の予想ですが、エクスプローラ プラグインでツリーの表示に時間がかかっているのではないかと思います。一度、エクスプローラ プラグインを閉じてから、もう一度試していただけますか? それで再現しなくなったら、エクスプローラ プラグインが、Windows フォルダの中の多数のファイルの表示に時間がかかっている可能性があります。何かアンチ ウィルス プログラムと衝突している可能性もあります。一時的にアンチ ウィルス プログラムを無効状態にしてから、再現するかどうかも試していただけると幸いです。また、原因がエクスプローラ プラグインでなかった場合は、すべてのプラグインを無効状態にしてから、試していただけると幸いです。よろしくお願いいたします。

    #8532

    MixNuts
    メンバー

    アンチウィルスソフト(avira personal)をアクティヴなまま
    EmEditorのエクスプローラpluninを外し、
    Windowsエクスプローラからフォルダを下り、
    1、ファイル hostsを右クリック-EmEditor をクリックで起動できました。
    2、また、起動中のEmEditorにドラッグ アンド ドロップでも起動できました。
    3、hostsファイルをデスクトップにコピーし、上記、1、2、を繰り返したところ起動できました。

    上記は現在使用中のアンチウィルスソフト(avira personal)の非アクティヴにしてもできました。

    アンチウィルスソフト(avira personal)を非アクティヴに設定
    EmEditorのエクスプローラpluninを起動し、一旦終了。
    Windowsエクスプローラからフォルダを下り、
    4、ファイル hostsを右クリック-EmEditor をクリックで最初の症状になりました。
    5、また、起動中のEmEditorにドラッグ アンド ドロップでも最初の症状になりました。
    6、エクスプローラpluginからhostsファイルをクリックしても最初の症状になりました。
    6、hostsファイルをデスクトップにコピーし、上記、4,5,6、を繰り返したところ問題なく起動できました。

    3、4、5、に関しては、エクスプローラpluginのカーソル(フォーカス)位置がhostsの場所にあります。
    また、管理者として起動しても結果は同様です。

    よって、(他のアンチウィルスソフトはともかく)少なくともAviraの問題ではなく、
    エクスプローラpluginに絡む、何らかの問題が潜在しているのではないかと考える次第です。

    Yutakaさんの環境では問題ありませんか?
    例えば、ツール-カスタマイズ-ウィンドウ-自動ワークスペースの設定に関わりはありませんか?
    あるいはシステムフォルダ以下のアクセス権に関わるとか、、、、

    また、現在、「保存、復元と元に戻す情報を保持し、ファイルの保存を促さない」にしているのですが、
    この設定とは関係ないかもしれませんが、なぜか、EmEditorを起動するたびに「無題」タブが増えていきます。
    元の「無題」タブの内容は全く変更していません。空白のままです。
    これは仕様ですか?<- カスタマイズをいじっているうちに回避できました。
    がhostsに関しては改善しません。

    #8536

    Yutaka Emura
    キーマスター

    MixNutsさんは書きました:
    アンチウィルスソフト(avira personal)をアクティヴなまま
    EmEditorのエクスプローラpluninを外し、
    Windowsエクスプローラからフォルダを下り、
    1、ファイル hostsを右クリック-EmEditor をクリックで起動できました。
    2、また、起動中のEmEditorにドラッグ アンド ドロップでも起動できました。
    3、hostsファイルをデスクトップにコピーし、上記、1、2、を繰り返したところ起動できました。

    上記は現在使用中のアンチウィルスソフト(avira personal)の非アクティヴにしてもできました。

    アンチウィルスソフト(avira personal)を非アクティヴに設定
    EmEditorのエクスプローラpluninを起動し、一旦終了。
    Windowsエクスプローラからフォルダを下り、
    4、ファイル hostsを右クリック-EmEditor をクリックで最初の症状になりました。
    5、また、起動中のEmEditorにドラッグ アンド ドロップでも最初の症状になりました。
    6、エクスプローラpluginからhostsファイルをクリックしても最初の症状になりました。
    6、hostsファイルをデスクトップにコピーし、上記、4,5,6、を繰り返したところ問題なく起動できました。

    3、4、5、に関しては、エクスプローラpluginのカーソル(フォーカス)位置がhostsの場所にあります。
    また、管理者として起動しても結果は同様です。

    よって、(他のアンチウィルスソフトはともかく)少なくともAviraの問題ではなく、
    エクスプローラpluginに絡む、何らかの問題が潜在しているのではないかと考える次第です。

    Yutakaさんの環境では問題ありませんか?
    例えば、ツール-カスタマイズ-ウィンドウ-自動ワークスペースの設定に関わりはありませんか?
    あるいはシステムフォルダ以下のアクセス権に関わるとか、、、、

    また、現在、「保存、復元と元に戻す情報を保持し、ファイルの保存を促さない」にしているのですが、
    この設定とは関係ないかもしれませんが、なぜか、EmEditorを起動するたびに「無題」タブが増えていきます。
    元の「無題」タブの内容は全く変更していません。空白のままです。
    これは仕様ですか?<- カスタマイズをいじっているうちに回避できました。
    がhostsに関しては改善しません。

    私の環境ではまったく問題ありません。やはり、Explorer プラグインと衝突している可能性はあります。単にファイルが多すぎて時間がかかっている可能性もありますし、アンチ ウィルス以外の何か常駐ソフトウェアと衝突している可能性もあります。今のところ Explorer プラグインを使用しないで運用していただけないでしょうか? 将来のバージョンでは、ファイルが非常に多くて時間がかかっている場合でもキャンセルできるような仕組みにしたいと思っています。

    無題タブができてしまうのは、ワークスペースに元に戻す情報も保持している場合にできてしまいますが、これは新しいバージョンの仕様となります。無題タブを作らずに EmEditor をアクティブにしたいときは、トレイアイコンから「新規作成」ではなく「アクティブにするか新規作成」を選択するようにしてください。

    どうぞよろしくお願いします。

    #8541

    MixNuts
    メンバー

    了解しました。

    とりあえず、system内のファイルを開くときは、エクスプローラpluginを外すようにします。

    迅速な対応に感謝します。
    ありがとうございました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone