7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #28297

    seea
    参加者

    EmEditor Professional (64-bit)
    Version 18.9.12

    テキストファイルを開いたまま何もしないと、
    「ファイルは他のプログラムによって変更されています。読み直しますか?」というメッセージが
    表示されます。(※開いているファイルは、他のプログラムによって変更されていません)
    ファイルを読み直しても、しばらくすると再び表示されます。

    過去のトピックを検索すると、以前のバージョンでも発生していた現象のようですが
    18.9.12(この投稿時点の最新版)で再発したのでしょうか…?

    18.9.12にバージョンアップする前は、18.6を使用していて、
    そのバージョンでは発生していませんでした。

    この現象が必ず発生するファイルと、決して発生しないファイルがあるようです。
    違いがよくわかりません。
    発生するときは、ファイルを開いてから30秒くらいで再現します。

    #28298

    Yutaka Emura
    キーマスター

    seea 様

    問題が発生するのは、ネットワーク上の比較的大きなファイルを編集して保存した場合ではないでしょうか?

    よろしくお願い申し上げます。

    #28614

    seea
    参加者

    お返事が遅くなり申し訳ありません。
    おっしゃる通りネットワーク上のファイルを開いたとき発生しますが、
    ファイルサイズが小さくても発生します。比較的大きなファイルのケースは未確認です。
    また、編集して保存の操作を行わずに、既存のファイルを開いただけでも発生します。

    ————— ここから —————
    test file

    テストファイル
    ————— ここまで —————

    上記の点線で囲われた内側の内容を
    テスト.txt というファイル名で保存し(4行、29 バイト、日本語(シフト JIS))、
    このファイルを開くと発生します。再現率は100%です。
    ※試していたら偶然再現したファイルです。

    Windows 10 Pro バージョン 1809 の「ネットワークドライブの割り当て」を用いて
    ネットワークドライブをマウントしたフォルダに、上記のファイルを置いたときに再現しています。
    逆に、他の場所(C:ドライブなどの、ネットワークドライブ以外の場所)では再現いたしません。

    【参考情報】
    ネットワークドライブの元となるファイルサーバーを提供しているのは
    Samba version 4.3.1、OSは CentOS 6.10 です。
    ディスクは全てSSDです。
    また、セキュリティソフトが動いているときに起きるかなと思ったのですが、いつ試しても起きるので
    あまり関係なさそうです。
    EmEditor 18.6 では一度も起きたことがない現象なので、そのあたりに手掛かりがあるかもしれません……。

    よろしくお願いいたします。

    #28615

    Yutaka Emura
    キーマスター

    seea 様

    最新版 (現在は v19.0.0) を使っていただき、[カスタマイズ] ダイアログ ボックスの [ファイル] ページに [大きなファイルを保存時、ファイル マッピングを有効にする] チェック ボックスのチェックを解除してお試しいただけますか?

    よろしくお願い申し上げます。

    #28634

    seea
    参加者

    お世話になっております。

    ・最新版 v19.0.0 に更新
    ・[大きなファイルを保存時、ファイル マッピングを有効にする] のチェックを解除
    を行い再度試しましたが、現象に変化はありませんでした(表題の現象が発生します)
    よろしくお願いいたします。

    #28641

    Yutaka Emura
    キーマスター

    seea 様

    お手数をお掛けして申し訳ありません。まもなく公開される v19.1 beta 1 (19.0.91) にて修正を試みてみました。
    修正されているかどうか、お試しいただけないでしょうか?
    これでもまだ修正されていない場合には、別の方法を考えます。

    よろしくお願い申し上げます。

    #28661

    seea
    参加者

    ・v19.1 beta 1 (19.0.91) に更新
    を行いましたが、現象に変化はありませんでした。
    また、Windows 10 Pro バージョン 1903 の環境で試してみましたが、同じ結果となりました。
    よろしくお願いいたします。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。