8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #10406

    yukoba
    メンバー

    EmEditor 10.0.8 を使っています。
    マシンは Windows XP (全てWindows Updateしてます)で
    Pentium-M 1.2GHz (Pentium 3相当)の遅いマシンですが、
    いつの頃からか忘れてしまったのですが、
    EmEditor のダイアログの表示が重くなりました。

    測ってみたところ、

    検索 > 置換:7秒
    検索 > 検索:5秒
    名前を変更して保存:6秒

    ただし、全部が重いわけでもなく、
    以下の物は大して重くありません。

    現在の設定のプロパティ:1秒
    カスタマイズ:0.5秒
    フォントの設定:2秒

    あと、ウィンドウを最小化した状態から、
    元の状態に復元するのに4秒かかります。

    最小化されていなくて、背後に回っている状態からの
    切替は2秒です。

    プラグインも標準・非標準含めて14個ほど入っており、
    これらが因果関係があるのか、
    何が原因で重くなっているのかよくわからないのですが、
    ある時から突然重くなりました。

    昔は1秒程度で検索ダイアログが出ていました。
    (Ver. 8か9の頃は速かったような気がします)

    こちらの環境に原因があるのか、原因がわからなく、
    あきらめて使っているのですが、速くなったら嬉しいです。

    #10408

    yukoba
    メンバー

    もう少し調査してみました。

    > 検索 -> 置換:7秒

    上記のマシンよりも2倍程度速い Pentium4 3.2GHz では
    3秒程度でしたので、CPUの処理速度に比例しているのだと思います。

    EmEditor 8.06 で試してみましたが、Pentium-M 1.2GHz でも、
    0.1秒とか0.2秒とか、そういう時間で表示されました。

    EmEditor 9 のダウンロード先がわからなかったので試していません。

    EmEditor 10 はあまりに重すぎるので、また昔のように、
    高速・軽量テキストエディタに戻ったら嬉しいです。

    とりあえず、8.06 に戻して使おうと思います。

    #10409

    Yutaka Emura
    キーマスター

    yukoba 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    [カスタマイズ] の [履歴] タブで、最近のファイル表示数が多いと、履歴をロードするのに時間がかかることがあります。まず、この [履歴] タブで、[履歴のクリア] を押して、履歴を完全に消してみて、動作時間が変わるかどうか試していただけると幸いです。また、 INI ファイルを使用する設定の場合には、レジストリを使用する設定にした方が速くなるかと思います。大変ご迷惑をお掛けして申し訳ありません。

    どうぞよろしくお願い申し上げます。

    #10413

    yukoba
    メンバー

    > [履歴] タブで、[履歴のクリア] を押して、履歴を完全に消してみて、動作時間が変わるかどうか試していただける

    これで、速くなりました!

    ただし、現象としては、

    1. Pentium 4 の方のマシンでは、履歴のクリアで速くなりました。最初からやってしまったので、履歴のクリアをしなくても2にある手法で速くなるのかどうか確認していません。

    2. Pentium-M のマシンでは、EmEditor 10.0.8 -> 8.06 -> 10.0.8 のインストールをして、「履歴のクリア」を行わなくても、履歴が残った状態のままでも速くなりました。
    (0.1~0.2秒程度で表示されます)

    不思議な現象になりました。
    EmEditor 10 で何かがおかしくなっていません?

    残っている履歴数は数え間違えていなければ32個です。

    > レジストリを使用する設定

    に関しては、バージョン情報で確認したところ、どちらも利用する設定になっています。

    #10414

    Yutaka Emura
    キーマスター

    yukoba 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    EmEditor v10 では、検索、置換のダイアログの部分を DLL として本体から完全に分けたため、DLL をロードする時間がかかっている可能性はあります。その分、本体のサイズを小さくして本体の起動を速くしていたつもりなのですが、検索を多く使う場合はかえって逆効果だったかもしれません。しかし、他のダイアログもすべて DLL として分かれているのに検索の場合だけ時間がかかるというのは、何か他にも原因があるように思います。

    検索ダイアログで、複数行を入力する設定になっていないでしょうか? もしそうだとすると、常に単一行で使用する設定にしていただければ、少し速くなるかと思います。

    もし、アンチ ウィルス ソフトウェアなどを併用している場合は、それらのソフトを一時的に無効にして試していただけると幸いです。

    もし、遅い状態が続くようでしたら、その状態のレジストリの HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common をエクスポートして zip に圧縮して tech@emurasoft.com あてに送っていただき、フォーラムのハンドルを添えて書いていただければ、調べてみたいと思います。

    どうぞよろしくお願い申し上げます。

    #10415

    yukoba
    メンバー

    もう一点気づいたのですが、Pentium 4のマシンは今確認したので間違いなく、かつ、Pentium-M でもそうだった記憶があるのですが、メニューの 表示(V) の一番下が「最近使ったフォント」とグレー表示になっています。

    10.0.8 → 8.06 → 10.0.8 をしたPentium-Mマシンでは、ここが元通り8個表示に復活しています。

    僕は EmEditor のフォント切り替えをよく使いますし、OSのフォント追加・削除も時々やっているので、EmEditor のフォント情報が壊れると、重くなるのではないかという気がします。

    試していなく仮説なんですが、新しいフォントを入れる→EmEditorでそのフォントを使ってみて履歴に残る→そのフォントを削除する という利用法で壊れるとかないでしょうか?

    #10416

    yukoba
    メンバー

    すいません。操作ミスで、「返信」ではなく、「編集」を押してしまい、一つ前の自分の投稿を消してしまいました。

    #10418

    Yutaka Emura
    キーマスター

    yukoba 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    履歴をクリアすると、最近使ったフォントの履歴もクリアされてしまいます。ですから、一度、EmEditor を再起動するか、フォントのサイズを変更して元に戻すという操作を行えば、最近使ったフォントに履歴が残るかと思います。お試しいただけると幸いです。

    フォントを削除する、というのは、コントロール パネルから特定のフォント ファイルを削除する、という意味でしょうか? そうすると、前回使用したフォントを削除してから EmEditor を起動すると、フォントが見つからないため、正しいフォントで表示できなくなります。でも、フォントを変更して、存在するフォントを選択しなおせば正しく表示できるはずです。ちなみに、どのフォントを削除したりしていますか? OS でよく使われ、最初からインストールされている「MS Pゴシック」、「MS UI Gothic」、「Tahoma」などのフォントは重要ですので、削除するべきではありません。また、これらのフォントは、他のフォントが使えない場合に呼び出されることがあるため、フォント削除すると、全体の速度が低下する可能性はあると思います。

    どうぞよろしくお願い申し上げます。

8件の投稿を表示中 - 1 - 8件目 (全8件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone