9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #9032

    匿名

    お世話になります。

    XP HOME SP3
    ver9.15を使用しています

    スペニットの使い方について質問があります。

    単語補完プラグインがONのときでもスペニットのツールチップが
    表示することができますでしょうか?

    御社のサイト
    http://jp.emeditor.com/modules/feature1/rewrite/tc_9.html
    にスペニットの説明がありますが、その中に「簡単なHTML作成」
    の項目に”doctype”と入力するとツールチップが表示されます
    とかいてありますが、単語補完プラグインがONになっていると
    表示されません。表示できるのであれば教えて頂きたいです。
    以上です。

    #9038

    Yutaka Emura
    キーマスター

    heppoko 様

    いつも EmEditor をお使いいただき、ありがとうございます。

    少し状況が違うかもしれませんが、単語補完とスニペットを併用することができますが、スニペットのプレイスホルダーの中では、単語補完が自動的には有効にならないことがあります。

    現在公開中の v10βでは、このような場合にも対応しておりますので、もしよろしければお試しください。

    他にも何かご質問がございましたら、ご遠慮なくご連絡ください。今後もよろしくお願い申し上げます。

    #9044

    匿名

    すみませんが質問がわるかったでしょうか?
    尋ねたかったのは

    スペニットプラグインを有効にして単語補完を
    無効にしている状態では
    doctypeと入力すると
    ツール チップで、「Press Tab to insert a Doctype declaration.」と表示されますが、

    スペニットプラグインを有効にして単語補完を
    有効にしている状態では
    doctypeと入力するとツールチップ「Press Tab to insert a Doctype declaration.」が表示されないのです。

    スペニットプラグインを有効にして単語補完を
    有効にしている状態で
    doctypeと入力するとツールチップ「Press Tab to insert a Doctype declaration.」が表示されるようにするには
    どのようにすればよいのでしょうか?
    以上です。

    #9047

    Yutaka Emura
    キーマスター

    heppoko 様

    いつもお世話になっております。ご質問の意味はわかります。前回は、正しく回答できていなくて大変申し訳ございませんでした。

    通常は、書いていただいたように doctype は、単語補完プラグインが動作中でも正しく動作するはずです。ツールチップは表示されるはずですが、設定によりツールチップが表示されなくても、Tab キーを押せば、doctype は展開されます。

    もしかしたら、Tab キーを単語補完プラグインの何かのコマンドを割り当てていないでしょうか? そうだとすると、単語補完プラグインのプロパティの [キーボード] タブで、Tab の割り当てを解除すれば、問題が解決するはずです。

    これでもまだ問題が再現するようでしたら、レジストリ エディタで、
    HKEY_CURRENT_USERSoftwareEmSoftEmEditorPlugIns
    のキーの中身をすべて削除して、設定を既定に戻してみることをおすすめします。

    他にも何かご質問がございましたら、どうぞご遠慮なくお問い合わせください。
    今後もよろしくお願い申し上げます。

    #9056

    匿名

    お世話になります。
    確かにtabキーを押すと展開しますが、ツールチップが
    表示されないと気づかないのでは、もしくはトリガー文字列
    をすべて覚えていないといけないので不便だと思いました。
    できればツールチップ表示されると有り難いです。

    以上です。

    #9058

    Yutaka Emura
    キーマスター

    heppoko 様

    いつも EmEditor をお使いいただき、誠にありがとうございます。

    ツールチップは表示されるはずなのですが、おかしいですね。

    スニペットのプラグインのプロパティの [ヒント] の [詳細情報] は、既定のとおり 4 になっていますね?

    もう少し調べたいと思います。何かわかりましたら、またご連絡差し上げます。

    どうぞよろしくお願い申し上げます。

    #9062

    匿名

    >スニペットのプラグインのプロパティの [ヒント] の [詳細情報] は、既定のとおり 4 になっていますね?

    設定をいじっていない状態で 5 になってました。
    4に変えても同じで単語補完プラグインがONになっていると
    ツールチップは表示されません。

    よろしくお願いします。

    #9066

    Yutaka Emura
    キーマスター

    heppoko 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    確認が遅くなり大変申し訳ありませんでした。確かに、v9.15 では、ご指摘のように、単語補完プラグインが有効の状態だと、doctype をタイプした後、スニペットのツールチップが表示されませんでした。しかし、現在公開している v10β9 では、この問題は修正されています。貴重なご意見誠にありがとうございました。

    他にもご質問がありましたら、どうぞご遠慮なくお問い合わせください。
    今後もよろしくお願い申し上げます。

    #9068

    匿名

    お忙しい中調査していただきありがとうございました。
    V10が楽しみです。

    また何かありましたらよろしくお願いします。

    以上です。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone