5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #9965

    Delフサ
    参加者

    こんにちは。

    以前から、WindowBlindsというソフトを使っています。

    このソフトとEmEditorは相性が悪いらしく
    ポップアップでもメインメニューでも、
    本体でもプラグインで展開するメニューでも問題が起きています。

    1段階のメニューは見えるのですが
    2段階目、黒い右向きの三角形から展開する
    子メニュー項目が表示されません。

    メニュー項目をマウスカーソルでなぞると
    1つのメニュー項目毎に
    マウスオーバーかUpdateイベントが走るのか、
    描画されるのですが

    マウスでなぞらないとわからないのはかなり不便です。

    他の手持ちのメニューのあるアプリケーションをすべてみても
    WindowBlindsとこの部分で相性が合わないソフトはEmEditorだけのようです。

    この部分、対応してもらえないでしょうか。

    メニュー描画が独自なのでしょうか?
    プラグインではAPIを使ってメニュー表示させているのに
    やはり、子メニューが非表示になってしまうので、
    動作がよくわからなくて不思議に思っています。

    WinXP
    EmEditor V10.0.1です

    よろしくおねがいします。

    #9966

    Yutaka Emura
    キーマスター

    fusa 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    EmEditor では、WTL のメニューを使用しているだけで、特に複雑なことを行っているわけではありません。標準のメニューではありませんが、ポップアップ メニューの組み合わせになっています。申し訳ありませんが、これは、やはり WindowsBlinds 側で対応していただくしかないかと思います。

    他にも何かご質問がございましたら、ご遠慮なくご連絡ください。
    今後もよろしくお願い申し上げます。

    #10167

    Delフサ
    参加者

    今更なのですが、解決しました。

    WindowBlindsの
    [詳細設定][拡張ユーザ設定]
    [メニューにスキンを適用する時、VistaUIガイドラインにWindowBlindsを使用する]

    のチェックボックスをOFFにすると改善されました。

    チェック項目が多すぎて気がつけませんでした。
    いま、やっと気がつきました。

    ご報告です。

    #10169

    Yutaka Emura
    キーマスター

    fusa 様

    解決されて良かったです。
    ご報告ありがとうございました。
    今後もよろしくお願い申し上げます。

    #10191

    Delフサ
    参加者

    こんにちは。

    間違っていたので訂正します。
    上記設定も関連するようですがもう少しよい設定は

    WindowBlindsの
    [基本設定][透明度&ぼかし]
    [メニューを変更する][透明度0%]に設定する

    こうすると、問題が解決しました。

    いろいろすいません。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone