4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #10180

    slowbirds
    メンバー

    javascriptモードで編集を行っていますが
    —-
    if(***){
    hoge;
    }else {
    fuga;
    }
    —-
    みたいな構文のファイルを何回もundoしたあと元に戻すためredoをすると上記の構文が何故か
    —-
    if(***){}
    hoge;
    }else {}
    fuga;
    }
    —-
    のようになる場合があります。(毎回ではない?様子です)
    function(hoge){}
    も発生しているようです。

    プラグインなどは特にいれておりません。

    お手数ですがご確認いただけますでしょうか。
    (他に報告している方がいらっしゃらないので設定などによる固有の問題の可能性もありますが・・・)

    #10181

    Yutaka Emura
    キーマスター

    slowbirds 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    このフォーラムでは、行頭の空白やTabなどが消えてしまうため、前後の違いがよくわかりません。大変お手数ですが、コードを [code] と [/code] (実際には、半角ですが、全角で書いています) で囲って書いていただけると、わかりやすく表示されます。または、 tech@emurasoft.com あてにメールでご連絡ください。

    どうぞよろしくお願い申し上げます。

    #10185

    slowbirds
    メンバー

    失礼いたしました。

    if(***){
    hoge;
    }else {
    fuga;
    }

    みたいな構文のファイルを何回もundoしたあと元に戻すためredoをすると上記の構文が何故か

    if(***){}
    hoge;
    }else {}
    fuga;
    }

    ifやelseの直後で閉じられてしまっています。

    #10186

    Yutaka Emura
    キーマスター

    slowbirds 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ご利用の EmEditor Professional のバージョンを教えていただけますか? もし、現在の最新の 10.0.5 でない場合には、最新版に更新して試していただけると幸いです。

    設定のプロパティの [強調(2)] タブの [括弧/引用符の自動補完] にはチェックが付いているでしょうか? 付いている場合はこのチェックを外して試していただけると幸いです。もちろん、チェックが付いていても正しく動作しないとおかしいいのですが、問題の切り分けのためです。

    どうぞよろしくお願い申し上げます。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone