4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #10939

    pinhead
    メンバー

    Pythonでマクロを動かそうとしていますが、うまくいきません。
    原因がおわかりの方がいらっしゃいましたらご教示願えないでしょうか。

    【環境】
    Windows : Windows7 64bit
    EmEditor : EmEditor Professional (64-bit) Version 11.0.5
    Python : CPython 2.7.2 + PyWin( pywin32-216.win32-py2.7 )

    【現象】
    Pythonで書かれたマクロを実行すると、以下のエラーダイアログが出ます。
    —————————
    EmEditor
    —————————
    クラスが登録されていません

    #languageのヘルプをみてレジストリを確認し、ProgID「Python.AXScript.2」を見つけましたが、この値でもダメでした。
    以下が色々試してみた結果です。

    #language = “Python.AXScript.2”
    クラスが登録されていません

    #language = “Python.AXScript”
    Python.AXScript
    指定された言語はシステムに登録されていません。

    #language = “Python”
    クラスが登録されていません

    #language = “hogehoge”
    hogehoge
    指定された言語はシステムに登録されていません。

    この感じからするとPythonそのものは認識されている風ですが、無いと言われているクラスがなんなのかがさっぱりです。
    お手数おかけしますがよろしくお願いいたします。

    #10940

    pinhead
    メンバー

    追加情報です。
    EmEditorを64bit版から32bit版に入れ直してみると、Pythonマクロが動くようになりました。
    64bit版では対応してないのでしょうか?
    できれば64bit版で使いたいのですが・・・

    #10941

    Yutaka Emura
    キーマスター

    pinhead 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    64-bit 版の EmEditor から 32-bit 版のスクリプトを動かすことは、プログラムの構造上、難しいかと思います。64-bit 版のスクリプトをインストールしていただくか、または 32-bit 版の EmEditor をインストールしてお使いください。

    どうぞよろしくお願い申し上げます。

    #10942

    pinhead
    メンバー

    江村様へ

    ご回答ありがとうございます。

    CPython,PyWin32,EmEditor全てを64bit版に合わせたところ、無事に動作しました。

    お騒がせしました。ありがとうございました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone