10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #10261

    qtv
    Participant

    EmEditor v10.0.6(32bit)を使用しています。
    最近になって急に、起動時に以下のダイアログが表示されるようになりました。

    The selected language pack is not for this version of Emditor.
    Select or install the correct version of language pack.

    インストールし直したり修復したりしてみましたが、変化ありません。
    今まで問題なく使えていたのですが、何となく4月のWindows Updateをしたあたりからなりだしたような気がします(はっきりしません)。
    トレイアイコンを表示させ、高速起動にし、更新チェックを有効にしていると発生しやすいような気がしています。
    プラグインは全部外しましたが、関係ありませんでした。

    毎回なるわけではないのですが、かなりの確率で出てきます。
    また、たまにタブが使えなくなることもあります。

    このような現象は発生していないでしょうか?

    Windows XP SP3 32bit

    #10262

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。
    ご迷惑をお掛けして申し訳ありません。

    複数の異なるバージョン の EmEditor がインストールされているということはないでしょうか? たとえば、体験版と正式版や v9 と v10 などという具合です。コントロール パネルのアプリケーションの追加と削除の一覧で、もし複数の EmEditor が存在する場合は、いったん、全部アンインストールし、Windows を再起動して、C:Program FilesEmEditor のフォルダに何も存在しないことを確認してから、最新の正式版だけをインストールすることをおすすめします。

    また、EmEditor の [ツール] メニューの [カスタマイズ] を選択し、[言語] タブで、[システム言語を使用] または [日本語] が選択されているかどうかも確認してください。また、この言語の設定を英語など他の言語に変更して同様の現象が発生するかも試していただけると幸いです。

    どうぞよろしくお願い申し上げます。

    #10263

    qtv
    Participant

    ご返答ありがとうございます。

    指摘された事項は問題ありませんでしたが、チェックしている間に「ウイルス対策ソフトをバージョンアップした」ということを思い出しました。
    EmEditorがインストールされているディレクトリに対してチェックをしないようにすると、現象は起こらなったようです。
    お騒がせしました。

    mui以下をチェックしないようにすると現象が出ないようです。
    推測なのですが、対策ソフトがEmEditorのリソース(dll)をチェックしている間にexeはリソースを読もうとして失敗しているのではないでしょうか。

    #10264

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ウィルス対策ソフトが原因だということがわかり良かったです。既に行われているように、EmEditor がインストールされているディレクトリに対してチェックをしないようにしてご利用ください。
    ご連絡をいただき、ありがとうございました。

    今後もどうぞよろしくお願い申し上げます。

    #10265

    qtv
    Participant

    チェックを外す処理は一時的な対策と考えています(企業ではできないところが多いでしょうし)。

    こういった場合、対策はEmEditorが次バージョンなどで行われるのでしょうか?
    あるいはウイルス対策ソフト(今回は「avast!6」です)に依頼するものなのでしょうか?

    #10266

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ウィルス対策ソフトとの衝突の場合、こちらでの原因の解明は難しいと考えています。今までは問題がなく、ウィルス対策ソフトのアップデートにより問題が発生した場合、ウィルス対策ソフト側で対応していただくのが合理的だと思われます。申し訳ありませんが、ウィルス対策ソフトの開発会社に対応を依頼していただけると幸いでございます。

    今後もどうぞよろしくお願い申し上げます。

    #10267

    qtv
    Participant

    了解しました。
    ありがとうございます。

    #10312

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    こちらでも Virtual PC 上で、avast! をインストールしたところ、同じ現象が再現しました。次のマイナー バージョンでは、language pack のメッセージが常に表示されないようにし、問題を回避します。

    どうぞよろしくお願い申し上げます。

    #10313

    qtv
    Participant

    確認していただき、ありがとうございます。
    よろしくお願いします。

    #10314

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    先ほど公開した 10.0.7 では、language pack のメッセージが出ないようにしました。また、タブも常に有効になるようになりましたが、タブの有効/無効の状態が保存できないなど、他の不具合が発生する可能性があります。申し訳ありませんが、EmEditor のパスを avast! の除外するパスに設定してご利用ください。技術的な話になりますが、avast! がインストールされていると、グローバル変数 (data_seg(“.shared”)) の処理に問題が発生しているようです。このあたりは、avast! 側で直していただく必要がありそうです。

    どうぞよろしくお願い申し上げます。

10件の投稿を表示中 - 1 - 10件目 (全10件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone