13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • 投稿者
    投稿
  • #4303

    Yutaka Emura
    キーマスター

    EmEditor Professional v6.00.4 RC 6 を公開しましたので、お試しください。

    http://www.emeditor.com/pub/emed6004rc6jpx.msi

    主な変更点は、以下の通りです。
    – ファイルから検索で、エンコード自動選択を選択して、定義されていないエンコードが検出されたときに、キャンセルするかどうかのメッセージが表示されてしまうことがある不具合を修正。
    – 大きなサイズのツール バー ボタンを持っていないプラグインが含まれていると、大きなツール バーが正しい順序で表示されないことがある不具合の修正。
    – [コメント挿入]、[インデント] コマンドで選択範囲の調節。
    – [コメント挿入] コマンドの後、マクロで選択テキストを取得すると異常終了することがある不具合の修正。
    – [ワークスペースを保存して全て保存して全て閉じる] コマンドで、無題の文書を保存してもワークスペースに含まれない問題を修正。
    – フォント サイズが 1 の状態で、[小さいフォント サイズ] コマンドを実行するとフォント サイズが 0 になってしまう不具合を修正。
    – セットアップで、エクスプローラのコンテキスト メニューが追加されないことがある不具合の修正。
    – セットアップでトレイアイコン表示のチェックの状態を覚えておくようにした。
    – Windows Vista でセットアップの時、UAC のメッセージの回数を減らした。
    – アウトライン プラグインで、Alt + Down/Up を続けて実行すると異常終了することがある不具合を修正。
    – 万一アウトライン プラグインのワーク スレッドで異常終了した場合に、EmEditor 自体が異常終了しないようにした。

    #4306

    Yutaka Emura
    キーマスター

    – セットアップでトレイアイコン表示のチェックの状態を覚えておくようにした。

    という変更点は、正式版では無くなりました。

    どうかご了承ください。

    #4308

    snow
    参加者

    この版か前の版かちょっと分からないのですが、アウトラインプラグインで行をクリックしても、メニューから移動を選んでも、移動しなくなってしまいました。
    選択もできないようです。

    #4311

    Yutaka Emura
    キーマスター

    申し訳ありません。アウトライン プラグインの1行にバグがありました。さきほど、正式版リリースを差し替えました。申し訳ありませんが、2007年3月30日午前0時30分より以前に EmEditor Professional 6.00.4 正式版 (32ビットまたは64ビット) をダウンロードされた方は、もう一度同じリンクからダウンロードしてインストールし直してください。初期のダウンロードでは、アウトライン プラグインでツリーの項目をダブルクリックしてもカーソル位置が移動しないことがあります。EmEditor Free、EmEditor Standard では関係ありません。通常は、こういう差し替えは行わないのですが、今回は緊急的な対応ということで、ご了承ください。

    #4312

    vanityduck
    メンバー

    差し替え前のEmEditorをインストールする時も出たのですが、
    『別のバージョンの製品が既にインストールされています。』というメッセージが出てしまします。
    バージョンアップのたびにアンイストールしなければいけないものなのでしょうか?

    #4317

    snow
    参加者

    無事移動しますね。対応ありがとうございました。

    #4318

    snow
    参加者

    以前私もお尋ねしたのですが、ベータ版をインストールした際に製品IDが変わるから、とのことだったと思います。
    できれば強制的に上書きも、させて欲しい気はしますが。

    #4319

    Yutaka Emura
    キーマスター

    差し替え前のEmEditorをインストールする時も出た、というのは、わからないのですが、バージョンアップのたびにアンインストールする必要はありません。通常は、プロダクト ID をバージョンアップのたびに変更しているため、このようなことはありません。今回の RC からのバージョンアップの場合だけ、プロダクト ID を変更するのを忘れてしまったのかもしれません。申し訳ありません。アンインストールの際に、設定を残しておくかどうかのメッセージが表示されます。そこで「はい」を選択していただければ、設定はすべて残ります。

    #4326

    匿名

    バージョンアップする時に、こちらではいつも「すでに同じ製品がインストールされてい
    ます。インストールする場合は、プログラムの変更と削除から、アンインストールしてか
    ら、インストールしなおしてください」というような趣旨のメーッセージがでるのですが、
    これはWindows2000だからですか?
    上書きでいつもやってますが、アンインストールしてくださいといわれてます。

    結局何が正しいのでしょう?
    設定だけ残して、アンインストールしてから、MSIを実行すればいいのか、インストール
    されたままでそのままMSIをインストールすれば、そのまま更新されるのでしょうか?

    今回は、差し替え版が出てから再更新してみましたが、何も変わってなくて、再度ダウン
    ロードして修正されているのを確認しました。
    (もしかすると、バージョンやサイズが変わってない?ので、途中経路でキャッシュされ
    たものを、ダウンロードしてしまったのかもしれませんが)
    今回は、バージョン名も同じだから、更新されたのかどうかも良く分かりませんでした。

    あと、不具合らしきものをついでに書いておきます。

    「マクロメニュー – 編集」で、一時マクロを開いた時の現在のフォルダについて
    「マクロメニュー – 編集」で、一時マクロを開いた時の既定の現在のフォルダはどこで
    すか?

    ステータスに表示してる現在のフォルダが過去に使ったマクロのフルパス名(いつも同じ
    で固定)になっていて変です。外部ツールなどの$(Dir)は、ドライブルートになってしま
    います。

    ヘルプのマクロリファレンスのチュートリアルになる、MSDNへのリンクは、現在アドレス
    変更になっているので、修正されると良いと思います。

    #4331

    Yutaka Emura
    キーマスター

    Windows 2000 だから、というのは関係ありません。設定だけ残して、アンインストールしてから、MSIを実行すれば問題ありません。今回、RC からのバージョンアップ、あるいは正式版差し替え前と後の際だけの問題だったと思います。ご迷惑をおかけして申し訳ありません。途中経路でキャッシュされている可能性はあると思います。ブラウザの一時ファイルをクリアしてから試すと大丈夫だった可能性があります。

    一時マクロを開いた時の既定の現在のフォルダは、[マクロ] メニューの [カスタマイズ] の [オプション] タブで設定できます。

    ステータスに表示してる現在のフォルダが過去に使ったマクロのフルパス名(いつも同じで固定)になっていて変です。外部ツールなどの$(Dir)は、ドライブルートになってしまいます。

    私の方で問題点を正しく理解していない可能性があるので、再現できる手順を詳しく書いていただけますか?

    MSDN へのリンクは修正します。どうもありがとうございます。

    #4333

    匿名

    一時マクロを開いた時の既定の現在のフォルダは、[マクロ] メニューの [カスタマイズ] の [オプション] タブで設定できます。

    その設定を確認したところ、フォルダパスではなく、マクロファイルのフルパスになってました。それが原因だったようです。ファイル名の部分を消したところ、ステータスの表示/外部ツールの動作とも、期待する正常どうさになりました。

    バージョンアップの話は、確かにRCだけだったかもしれません。
    上書きではなく、一旦アンインストールしてから、新しいバージョンでインスールということでしょうか。 アンインスールせずそのまま上書きって出来ないのでしょうか。

    それから、MSIだと右クリックメニューに、RunAsがでないのですが、
    RunAsでMSIを実行すると何かまずいのでしょうか?
    普段はパワーユーザーですので、インストール時に管理者権限
    に切り替えるのが面倒になったかなとちょっと思います。

    #4335

    Yutaka Emura
    キーマスター

    通常、アンインスールせずそのまま上書きで問題ありません。前にも書いたと思うのですが、今回だけアンインストールになってしまいました。RC 版、差し替え版ということもあり、ご了承ください。アンインストールのときに、設定を保存するようにすればまったく問題はありません。

    MSI のインストールでは、管理者でなくても問題はないはずです。ただし、インストール中に管理者のパスワードが要求されます。もう試してみましたか?

    #4340

    匿名

    よくわかりました。確かに上にも似たような質問ありますね^^;
    申し訳ありません。

    いままでは、管理者でログインしなおすか、RunAsでインストールしていたので、MSIになってからRunAsのメニューが出なくなって、不便に感じただけです。

    MSIの場合は、インストール途中で管理者にログインするのですね。
    次のバージョンがリリースされたら、試してます。

13件の投稿を表示中 - 1 - 13件目 (全13件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone