15件の投稿を表示中 - 1 - 15件目 (全17件中)
  • 投稿者
    投稿
  • #9352

    Yutaka Emura
    キーマスター

    EmEditor Professional v10 RC 14 (9.90.23) を公開しました。

    RC 13 からの主な変更点は、次の通りです。

    – 比較後にリセットするときや、タブをグループ間で移動する際にフリーズすることがある不具合の修正。
    – その他、不具合の修正。

    v10 ベータのその他の新機能について詳しくは、EmEditor Professional 10 の特長
    http://jp.emeditor.com/modules/feature1/rewrite/tc_12.html
    をご覧ください。

    【ダウンロード方法】

    http://www.emeditor.com/pub/updates/emed32_9.90.23.exe (32-bit、v10 用登録キーが必要です)
    http://www.emeditor.com/pub/updates/emed64_9.90.23.exe (64-bit、v10 用登録キーが必要です)
    http://www.emeditor.com/pub/updates/emed32_9.90.23_trial.exe (32-bit、体験版、登録キーは不要です)

    体験版を除き、RC 版を実行するには、v10 の登録キーが必要になります。v9 の登録ユーザーの方は、エムソフト カスタマー センター https://www.emurasoft.com/support/?lid=2 の [購入履歴] ページより、v10 の登録キーを要求していただけます。

    使用期限は、2010年6月30日になります。この期日までにその時の最新バージョンに更新するか、正式版を購入する必要があります。

    サポート OS: Windows 7/Vista/XP/2000 SP4/Server 2008/Server 2003

    64-bit 版をインストールする前に、既存の v9 以下のバージョンは、アンインストールしてください。v9 以下をアンインストールしないと、コントロール パネルのプログラムの追加と削除で、EmEditor Professional が 2 つ以上表示されます。32-bit 版をインストールする場合でも、念のため、既存の v9 以下をアンインストールしてから、v10 をインストールすることをおすすめします。

    ポータブル版は、EmEditor インストーラを使ってインストールした後、ツール メニューのインポートとエクスポート ウィザードからも作成することができます。ただし動作速度はレジストリ使用時より遅くなります。

    EmEditor Professional v4~9 の正規ライセンスを購入してお持ちのお客様は、v10 へのアップグレードは無料です。

    本バージョンは、RC 版です。不具合が残っている可能性が充分にありますのでご注意ください。

    ご要望や不具合の報告などがございましたら、ご遠慮なくこのフォーラムにご発言ください。
    よろしくお願い申し上げます。

    #9353

    snow
    参加者

    開発お疲れさまです。
    前RCもそうだったと思うのですが、インストール時に「デスクトップショートカット」をインストールしないようにしていても、ショートカットができてしまうように思います。
    ご確認お願いできますでしょうか。

    環境:WinXP sp3 32bit

    #9354

    Yutaka Emura
    キーマスター

    snow 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    インストール途中で、[カスタム] を選んで、[デスクトップショートカット] を × にしておけば、デスクトップにショートカットはできないはずです。こちらでも試してみましたが、問題はありませんでした。おかしいですね。

    前回のインストールでの選択が、今回のインストールで [カスタム] を選択していても、その中の [デスクトップショートカット] の×が記憶できていない、という意味でしょうか? そうだとすると、その可能性はあります。こちらでも確認してみます。

    大変お手数をお掛けして申しわけありません。
    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9355

    snow
    参加者

    [カスタム]を選んでいます。
    デスクトップショートカットが×になっているのを確認してインストールしているのですが、前回も今回も、ショートカットが作成されました。
    ×の状態は、保存されています。

    #9356

    gecca
    メンバー

    江村さん、お疲れ様です。

    グループ間でのタブ移動の件、修正を確認しました。
    直って良かったです!

    ちなみに、タブを全て閉じてからワークスペースの保存をしたときの動作は変更になったのでしょうか?
    個人の趣向によると思いますが、タブを全て閉じていた場合は、次に空白状態で開きたいです。

    以上、よろしくお願い致します。

    #9357

    qtv
    参加者

    開発お疲れ様です。

    ・ウィンドウを開いた後、しばらくすると少しだけ固まる件ですが、RC14では解消されていました。ありがとうございます。

    ・プロジェクトプラグインがある場合にウィンドウを開いてから使えるようになるまでに数秒かかる(ときどきすぐに使える)件ですが、これは変わりませんでした。

    よろしくお願いします。

    #9358

    Yutaka Emura
    キーマスター

    snow 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    次回インストールする前に、レジストリ エディタで、

    HKEY_LOCAL_MACHINESOFTWAREEmSoftEmEditor v3Common

    の中の

    DesktopShortcut

    という値が残っていたら、これを削除してから、試してみてください。

    通常、アップグレードする場合、この値が自動的に削除されるので問題ないと思うのですが、何らかの原因で、削除されずに残っているのだと思います。

    次のインストーラーでは、インストールと同時に、この値を削除するようにします。

    大変お手数をお掛けして申しわけありません。
    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9359

    Yutaka Emura
    キーマスター

    gecca 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    グループ間でのタブ移動の件は、直って良かったです。このたびは、大変お世話になりました。

    ワークスペースの保存については、元に戻す情報を含む設定になっていないと、ご指摘のような動作になっています。これは次の RC 版で、常に元の状態になるように修正しておきます。

    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9360

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ローカルのプロジェクト、ファイルでしたら問題はないのですね。プロジェクトに含まれているファイルはすべて存在しますでしょうか? もし存在しないファイルが含まれていると、そのファイルの情報を取得しようとする部分で遅くなっている可能性はあります。

    また、プロジェクト プラグインのプロパティで、[書き換え禁止アイコンを表示する] チェック ボックスのチェックを外してみていただけますでしょうか? そうすると、以前よりは速くなるのではと思います。

    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9361

    qtv
    参加者

    Yutakaさんは書きました:

    ローカルのプロジェクト、ファイルでしたら問題はないのですね。プロジェクトに含まれているファイルはすべて存在しますでしょうか?

    ローカルファイルでは、試していません(使うことがないため)。
    ファイルの存在は、後で確認してみます。
    気にしているのは、常に遅いのであればわかるのですが、ときどき速く動作するときがある、という点ですが、そういうことはありうるのでしょうか?

    また、プロジェクト プラグインのプロパティで、[書き換え禁止アイコンを表示する] チェック ボックスのチェックを外してみていただけますでしょうか?

    こちらは、チェックを外しています。

    #9362

    Yutaka Emura
    キーマスター

    qtv 様

    いつも EmEditor Professional をお使いいただき、誠にありがとうございます。

    ネットワークのファイルの存在していない場合、そのファイルの存在の有無がキャッシュされていると、1 回目は遅いけど、2 回目からの接続では、すぐに反応が返ってくる場合があります。そこで、時々速く動作することがあるわけです。

    大変ご迷惑をお掛けしていて申し訳ありません。
    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9365

    gecca
    メンバー

    江村さん、お疲れ様です。

    最近スニペットを使い始めて試行錯誤してます。これ凄いですね。
    v10の不具合ではないかも知れませんが、ここに報告します。

    ■マクロ
    editor.OpenFile()にeeOpenAllowNewWindowを指定しても、
    開いているファイルを閉じてから開いたり、
    編集中であれば「~を保存しますか?」というダイアログが出てしまいます。

    ■スニペット JSPへの適用
    スニペットのフォルダの設定をJSPに適用にしても、JSP定義の文書で有効になりません。
    具体的には、トリガーの文字列を入力してTABを押しても、何も起こりませんでした。
    Javaに適用して、Java定義の文書でやると、上手くいきました。

    ■スニペット トリガーが”.”の場合
    トリガーに”.”を指定してから、文頭で”.”を入力してTABを押せば問題なく動作しますが、
    文の途中で”.”を入力してTABを押しても動作しません。

    ■スニペット 最後に”}”がある場合
    内容を”${1:aaa}”のように最後に”}”を付けて、
    トリガーによってスニペットを起動した後にBackSpaceを押すと、
    選択範囲だけでなく隣の文字(や隣の改行)が消えてしまいます。

    ■スニペット 不安定
    比較のテストのときにキャレットが消えるという報告をしましたが、それは直ってました。
    ただ、スニペットバーを表示しているときや、
    スニペットの[編集]ボタンを押してエディタ上でマクロを編集しているときに、
    たまにキャレットが消えます。
    開いているjseeのファイルの色が、急に無くなって黒文字のみになったこともあります。
    さらに、これは今起こったのですが、Enterを押して改行したら全然関係ないところが改行されました。
    ちょっと信じられない現象です。CrLfで編集していたのに、そこだけLfの改行になっています。
    左側にスニペットの表示していると、急激に不安定になる気がします。
    詳しく調べる時間は無いのですが、一応報告しておきます。

    以上、よろしくお願い致します。

    P.S.
    スニペットを触っているときは、単語補完プラグイン動作中でした。⇒関係ないようです。

    #9366

    qtv
    参加者

    ネットワークのファイルの存在していない場合、そのファイルの存在の有無がキャッシュされていると、1 回目は遅いけど、2 回目からの接続では、すぐに反応が返ってくる場合があります。そこで、時々速く動作することがあるわけです。

    ということは、プロジェクトプラグインでは登録してあるファイルの有無を最初に確認している、ということでしょうか(tagsのため?)。
    プロジェクトファイルの確認は必要かと思いますが、実ファイルの確認までは不要ではないかな、と思いました(書き込み禁止アイコンを表示しない場合)。

    ———
    遅くなりましたが、ファイルの存在確認をしてみました。
    1つだけ存在していないファイルがありましたが、それはローカルファイルでした。
    それをプロジェクトから削除してみましたが、変化はありませんでした。

    そこでローカルファイルのみのソリューションおよびプロジェクトを作成してみましたが、現象が発生しました。
    ネットワークファイルだけではないようです。

    江村様の環境では発生しないでしょうか?
    個人環境のせいなのかどうかの切り分けができません(あまり余所のデバッグに割く時間はありませんし。。。)。
    環境の問題であればこちらでも調べますし、そうでなければ調査をお願いします。

    #9367

    Yutaka Emura
    キーマスター

    qtv 様

    いつも大変お世話になっております。

    おそらく、ctag.exe の実行で遅くなる現象だと思われますので、この優先度をアイドルのみ実行するように低くしてみます。また、こちらでもさらに再現テストを行い調べたいと思います。

    もしお時間がありましたら、現在のソリューション テンプレートのプロパティの [シンボル] タブで、[すべてのシンボル一覧を自動更新する] のチェックを外してみていただけますでしょうか?

    大変お手数をお掛けして申し訳ありません。
    他にも何かご質問がありましたら、ご遠慮なくご連絡ください。
    今後もどうぞよろしくお願い申し上げます。

    #9368

    qtv
    参加者

    現在のソリューション テンプレートのプロパティの [シンボル] タブで、[すべてのシンボル一覧を自動更新する] のチェックを外してみていただけますでしょうか?

    チェックを外すと、すぐに使えるようになりました。
    (このオプションには気付いていませんでした・・・。)
    当面はチェックを外して使用します。

    —-
    今気付いたのですが、シンボル一覧を表示している状態で関数を入力してパラメータ情報が表示されたところで、ツールバーの「パラメータ情報」をクリックすると、パラメータ情報が増えていきます。
    (例:(1/2)→(1/4)→(1/6)・・・)

    また、パラメータ情報が欠けずに表示されるとありがたいです。

15件の投稿を表示中 - 1 - 15件目 (全17件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone