9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #5582

    Yutaka Emura
    キーマスター

    EmEditor Professional 7.00.1 RC 4 を 公開します。主な変更点は、次の通りです。

    – 半角/全角変換の後の表示の不具合を修正。

    http://www.emeditor.com/pub/emed7001rc4jpx.msi (32ビット)

    ポータブル版は、EmEditor インストーラを使ってインストールした後、ツール メニューのインポートとエクスポート ウィザードからも作成することができます。ただし動作速度はレジストリ使用時より遅くなります。

    新機能についての詳細は、 http://jp.emeditor.com/modules/feature1/ 、およびインストールした後、ヘルプの履歴のページをご覧ください。

    試された場合には、不具合の報告やフィードバックをこのフォーラムに投稿してくださいますよう、お願いいたします。ご協力ありがとうございます。

    ※マイナー アップデートでは、不具合修正のみを行い、新しい機能の追加は行わない予定です。

    インストール方法についての詳細は、 http://jp.emeditor.com/modules/xoopsfaq/index.php?cat_id=1#q1 をお読みください。ただし、ダウンロードは、このメッセージの上のリンクからダウンロードしてください。

    #5584

    kakinoha
    メンバー

    Windows 2003 SP2
    EmEditor Pro 7.00.1 RC 4

    「ファイルから検索」で、”積載重量” という文字がヒットしてくれません。

    1)”積載重量” とだけ書いたテキストファイル(シフトJIS)を用意。
    2)「ファイルから検索」で、検索する文字列:積載重量 で検索。
        ※検索オプションのチェックはすべて未チェック。
        ※エンコード:設定されたエンコード。
    3)何もヒットしない。

    検索オプションの「大文字と小文字を~」や「正規表現を~」にチェックするとヒットします。
    また、”積” “載” “重” “量” をそれぞれ1文字ずつ検索すると、”重” だけはヒットしました。

    #5585

    Yutaka Emura
    キーマスター

    kakinohaさんは書きました:
    Windows 2003 SP2
    EmEditor Pro 7.00.1 RC 4

    「ファイルから検索」で、”積載重量” という文字がヒットしてくれません。

    1)”積載重量” とだけ書いたテキストファイル(シフトJIS)を用意。
    2)「ファイルから検索」で、検索する文字列:積載重量 で検索。
        ※検索オプションのチェックはすべて未チェック。
        ※エンコード:設定されたエンコード。
    3)何もヒットしない。

    検索オプションの「大文字と小文字を~」や「正規表現を~」にチェックするとヒットします。
    また、”積” “載” “重” “量” をそれぞれ1文字ずつ検索すると、”重” だけはヒットしました。

    これは、7.00.1 RC1~RC4 の問題でした。早速こちらでは修正しておきました。
    どうもありがとうございます。

    #5586

    naya
    参加者

    不具合というほどのものではないですが、
    HTMLファイル編集時のHTMLバーの表示/非表示の挙動について。

    (1) EmEditorのタブ有効にして、EmEditorを一旦閉じる。
    (2) デスクトップに、1.html、2.html、3.js、4.txtという4ファイルを作成
    (3) 4ファイルを選択し、コンテキストメニューのEmEditorを選択
    (4) 4ファイルが開き、4.txtがアクティブになる
    (5) 3.js、2.html、1.html、の順にタブをアクティブにする

    こうすると、HTMLバーが有効になったり、無効になったり
    HTMLバーがあったスペースが詰められたり、空白のバーができたり、
    ちゃかちゃかしてどうも動作に統一性がないように見受けます。
    不具合というほどではないですが、統一感があったほうが落ち着くと思います。

    以上、感想まで。

    #5590

    Yutaka Emura
    キーマスター

    nayaさんは書きました:
    不具合というほどのものではないですが、
    HTMLファイル編集時のHTMLバーの表示/非表示の挙動について。

    (1) EmEditorのタブ有効にして、EmEditorを一旦閉じる。
    (2) デスクトップに、1.html、2.html、3.js、4.txtという4ファイルを作成
    (3) 4ファイルを選択し、コンテキストメニューのEmEditorを選択
    (4) 4ファイルが開き、4.txtがアクティブになる
    (5) 3.js、2.html、1.html、の順にタブをアクティブにする

    こうすると、HTMLバーが有効になったり、無効になったり
    HTMLバーがあったスペースが詰められたり、空白のバーができたり、
    ちゃかちゃかしてどうも動作に統一性がないように見受けます。
    不具合というほどではないですが、統一感があったほうが落ち着くと思います。

    以上、感想まで。

    空白のバーというのがあるとすると、それは不具合の可能性があるので、スクリーンショットをメールで送っていただけると幸いです。ファイルの種類によって HTML を表示/非表示の切り替えをやめたい場合は、HTML バーのプラグインのプロパティで設定できます。

    #5594

    naya
    参加者

    下記のスクリーンショットは開いた4ファイルのタブを
    「4.txt、1.html、2.html、3.js」の順序でアクティブにしたものです。

    指摘させていただいた問題点は、
    (1) 1枚目の画像でHTMLバーが出ていないこと(HTML バーのプラグインのプロパティで自動表示の対象としているにもかかわらず)
    (2) 4枚目の「空白のバー」が現れることです。

    わたしの認識が誤っていたらすみません。


     

     

     

    #5595

    Yutaka Emura
    キーマスター

    タイトル

    nayaさんは書きました:
    下記のスクリーンショットは開いた4ファイルのタブを
    「4.txt、1.html、2.html、3.js」の順序でアクティブにしたものです。

    指摘させていただいた問題点は、
    (1) 1枚目の画像でHTMLバーが出ていないこと(HTML バーのプラグインのプロパティで自動表示の対象としているにもかかわらず)
    (2) 4枚目の「空白のバー」が現れることです。

    わたしの認識が誤っていたらすみません。

    画面図ありがとうございます。ツールバーのタイトルを表示してみるといかがでしょうか?
    4.txt の画面図で、右側に隠れているツールバーは何でしょうか? HTML バーということはないでしょうか?
    また、 3.js の画面図は、これは確かに不具合の可能性がありますが、右に隠れているツールバーは何でしょうか?

    #5596

    naya
    参加者

    右側に隠れているのはマクロツールバーです。
    ツールバーのタイトルを表示させて再度スクリーンショットを取りました。
    今まで気がつきませんでしたが、マクロツールバーの表示位置が変な動きをしていますね(2、3枚目画像)。

    手がかりになれば幸いです。


     

     

     

    おまけ:サンプルの4ファイル
    http://hp.vector.co.jp/authors/VA039250/emeditor/sample.zip

    #5604

    kakinoha
    メンバー

    RC5で修正されているのを確認しました。

    Yutakaさんは書きました:

    kakinohaさんは書きました:
    Windows 2003 SP2
    EmEditor Pro 7.00.1 RC 4

    「ファイルから検索」で、”積載重量” という文字がヒットしてくれません。

    1)”積載重量” とだけ書いたテキストファイル(シフトJIS)を用意。
    2)「ファイルから検索」で、検索する文字列:積載重量 で検索。
        ※検索オプションのチェックはすべて未チェック。
        ※エンコード:設定されたエンコード。
    3)何もヒットしない。

    検索オプションの「大文字と小文字を~」や「正規表現を~」にチェックするとヒットします。
    また、”積” “載” “重” “量” をそれぞれ1文字ずつ検索すると、”重” だけはヒットしました。

    これは、7.00.1 RC1~RC4 の問題でした。早速こちらでは修正しておきました。
    どうもありがとうございます。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone