15件の投稿を表示中 - 1 - 15件目 (全19件中)
  • 投稿者
    投稿
  • #5672

    Yutaka Emura
    キーマスター

    EmEditor Professional 7.00.1 RC 10 を 公開します。主な変更点は、次の通りです。

    – 上書モードで行った文字入力をUNDOすると正常にUNDOされないことがある不具合などを修正。

    http://www.emeditor.com/pub/emed7001rc10jpx.msi (32ビット)

    ポータブル版は、EmEditor インストーラを使ってインストールした後、ツール メニューのインポートとエクスポート ウィザードからも作成することができます。ただし動作速度はレジストリ使用時より遅くなります。

    新機能についての詳細は、 http://jp.emeditor.com/modules/feature1/ 、およびインストールした後、ヘルプの履歴のページをご覧ください。

    試された場合には、不具合の報告やフィードバックをこのフォーラムに投稿してくださいますよう、お願いいたします。ご協力ありがとうございます。

    ※マイナー アップデートでは、不具合修正のみを行い、新しい機能の追加は行わない予定です。

    インストール方法についての詳細は、 http://jp.emeditor.com/modules/xoopsfaq/index.php?cat_id=1#q1 をお読みください。ただし、ダウンロードは、このメッセージの上のリンクからダウンロードしてください。

    #5678

    yuki
    参加者

    いつも開発ご苦労さまです。

    質問も含めて2件あります。


    RC 7で修正していただきましたアウトラインで縮小表示されたままので不具合の件ですが、拡張子の違うファイルにおいて、同様の問題が発生してしまいます。
    例えば”.cpp” と”.txt”の組み合わせでも起きました。


    マクロファイル(*.jsee)を開くときに、たまにEmEditorのインストーラが起動することがあるのですが、これは、一体何がインストールされるのでしょうか?
    おそらくなのですが、デフォルトのマクロフォルダ以外の場所(例えば、My Macros)のファイルでよくインストーラが動作する気がします。
    OSの再起動も要求されます。

    マクロを頻繁に利用しているわけではないので、初歩的な質問であればすみません。

    よろしく、お願い致します。

    #5680

    Yutaka Emura
    キーマスター

    yukiさんは書きました:
    いつも開発ご苦労さまです。

    質問も含めて2件あります。


    RC 7で修正していただきましたアウトラインで縮小表示されたままので不具合の件ですが、拡張子の違うファイルにおいて、同様の問題が発生してしまいます。
    例えば”.cpp” と”.txt”の組み合わせでも起きました。


    マクロファイル(*.jsee)を開くときに、たまにEmEditorのインストーラが起動することがあるのですが、これは、一体何がインストールされるのでしょうか?
    おそらくなのですが、デフォルトのマクロフォルダ以外の場所(例えば、My Macros)のファイルでよくインストーラが動作する気がします。
    OSの再起動も要求されます。

    マクロを頻繁に利用しているわけではないので、初歩的な質問であればすみません。

    よろしく、お願い致します。

    (1) 7.00.1 正式版は、すでに FIX しましたので、その次のバージョンで直します。ご報告ありがとうございます。

    (2) これはおかしいですね。.jsee のファイルは、編集アクションが EmEditor に関連付けられているためですが、これはインストーラ (msiexec) を通して行われています。そのためではないかと思いますが、もし再現できる条件がわかりましたらご連絡ください。よろしくお願いします。

    #5682

    yuki
    参加者

    お忙しいところ、回答ありがとうございます。
    ①の件、了解いたしました。

    また、②の件ですがたしかに、ダブルクリックや右クリックのポップアップメニューの”編集”や”プログラムから開く”でインストーラになるようです。
    “EmEditor” や “送る”では通常に本体が立ち上がりました。
    また、My Macrosフォルダでもインストーラが起動していました。
    あとは、イベントログのアプリケーションのところに下記の警告がありましたので、確認してみました。

    製品 ‘{…}’、機能 ‘DefaultFeature’、コンポーネント ‘{…}’ の検索に失敗しました。リソース ‘HKEY_CLASSES_ROOT.htmOpenWithListEmEditorshelleditcommand’ がありません。

    EmEditorインストーラが勝手に起動する時に実際のレジストリ.htm階層をたどっていくとキーがなくなっていました。
    インストール完了後は復活していました。

    ちなみにブラウザはIE6を使っていますので、IE6が勝手に削除してしまうかと予想されます。

    よろしく、お願いいたします。

    #5684

    yuki
    参加者

    いつも開発ご苦労さまです。
    度々ですみませんが、1件追記させて頂きます。


    RC10で修正して頂いた不具合に近いのですが、指定エンコードの違うファイルや、Null文字の入ったファイルを複数選択し、最初のファイルだけを警告メッセージボックスでキャンセルすると”無題”のファイルができます。

    よろしく、お願い致します。

    #5685

    vanityduck
    メンバー

    私も時々発生したので、イタズラがてら色々試してみました。

    インストールフォルダ内のテンプレートファイル(template.cpp 等)を削除して、マイマクロフォルダ内に保存してある jsee ファイルを、エクスプローラからダブルクリックで起動すると、セットアップが起動されてしまいます。
    ただし、jsee や vbee のファイルを起動した場合のみで、手動で関連付けているファイルは正常に開けます。

    テンプレートファイル(template.cpp 等)も、必須モジュールとして認識されているようですが、そういうものなのでしょうか?

    ちなみに、インストール直後は、HKEY_CLASSES_ROOTjseefilesshelleditcommand に command という REG_MULTI_SZ の項目が存在しています。
    この状態だと、上記の現象が出ます。
    エクスプローラから[ツール]→[フォルダ オプション]→[ファイルの種類]で、拡張子 jsee の詳細設定(V)→編集(E)を開き、OK ボタンを2回クリックすると、上記レジストリの項目が削除されました。
    この状態で jsee ファイルを開くと、上記現象は発生しませんでした。

    #5691

    naya
    参加者

    正式版の7.00.1 がリリースされたようですが・・・

    下記の件、直っていないようです。念のためご報告まで。http://jp.emeditor.com/modules/newbb/viewtopic.php?forum=12&post_id=2135&topic_id=443#forumpost2135

    #5693

    yuki
    参加者

    いつも開発ご苦労さまです。
    また、1件追記させて頂きます。


    エクスプローラ プラグインですが、表示ファイルに連動してツリーが展開して選択状態になるのが通常だと思いますが、ネットワークPC上のファイルを開いたとき、選択状態にならない場合があります。
    おそらく、”コンピュータの説明”(Windowsエクスプローラでいうところのコメント)が入ったPCが関係しているのではと思いました。

    よろしく、お願い致します。

    #5694

    snow
    参加者

    一応、私の環境では再現しません。
    アンインストール→インストールしてみてはいかがでしょう?

    #5695

    snow
    参加者

    今更なのですが、HTMLツールバーを全然見ていなかったもので、見てみました。

    を挿入するボタンですが、「インデント」というのはどうかと思います。「引用」では。
    個人的にはそれから、プルダウンに

    ともあると良いのかなと思いました。
    #5696

    yunoki
    メンバー

    検索でのちょっとした不具合です。

    複数のファイルを開いた状態で、検索窓を出して、”開いているすべての~”と、”正規表現~”にそれぞれチェックを入れた状態で、検索文字列として間違った正規表現を記述して検索を開始すると、エラーのメッセージが、開いているファイルの数だけ繰り返し表示されてしまいます。

    1回だけエラーメッセージがでるようにしてもらいたいです。

    #5699

    hiro
    メンバー

    スクリプトの色は治ってましたが
    スクリプトの下にコメントアウトタグを入れてる場合、
    開始タグの色が変です:-P

    =660000] ← 緑

    #5703

    Yutaka Emura
    キーマスター

    snowさんは書きました:
    今更なのですが、HTMLツールバーを全然見ていなかったもので、見てみました。

    を挿入するボタンですが、「インデント」というのはどうかと思います。「引用」では。
    個人的にはそれから、プルダウンに

    ともあると良いのかなと思いました。

    将来的に機能を追加も検討します。HTMLバーは、ソースコードも公開しているので、それを修正、ビルドすることも可能です。

    #5704

    Yutaka Emura
    キーマスター

    hiroさんは書きました:
    スクリプトの色は治ってましたが
    スクリプトの下にコメントアウトタグを入れてる場合、
    開始タグの色が変です:-P

    =660000] ← 緑

    この茶色の部分は、すでに、javascript スクリプトの中なので、EmEditor では、// はコメントになりますが <!– はコメントにならないとして扱っています。もし <!– をコメントとして表示させたい場合は、JavaScript の設定のプロパティで、 <!– をコメントとして設定すれば期待通りに表示されます。

    ところで、HTML のファイルの中でもスクリプトの と の間では、 は javascript のコメントにならない、と思っていましたが、私の理解が間違っていたのでしょうか?

    #5707

    hiro
    メンバー

    HTMLでは=006600]ですがJavaScriptでは=006600]です。

    JavaScriptでのコメント化スクリプト
    JavaScriptエンジンは、SCRIPT要素の始めに文字列「」をJavaScriptパーサから隠すために必要とされる。

    <!– to hide script contents from old browsers
    function square(i) {
    document.write("The call passed ", i ," to the function.","
    “)
    return i * i
    }
    document.write(“The function returned “,square(5),”.”)
    // end hiding contents from old browsers –>

    とW3Cの勧告はなってます。

15件の投稿を表示中 - 1 - 15件目 (全19件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone