6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #7424

    kshi
    参加者

    EmEditorでは他のアプリケーションから切り替えた直後や
    ダイアログを閉じた直後に Altキーの反応が鈍いことが
    多い気がしています。

    EmEditor(に限らず)の編集画面で単独のAltキーを押すと、
    通常はメインメニューの[ファイル]が浮き出ますよね。

    Alt→Fで[ファイル]メニューを出すつもりだったのに、
    実は Alt が利いておらず、
    編集画面にFを入力してしまうことがよくあります。

    これはEmEditorに限ったことではなく、
    他のソフトでも同じようなことがあります。
    ソフトによってWaitのかかり方がちがうのかな、
    と想像しています。

    EmEditorで反応を鋭くするような設定はできないでしょうか。

    #7425

    Yutaka Emura
    キーマスター

    kshiさんは書きました:
    EmEditorでは他のアプリケーションから切り替えた直後や
    ダイアログを閉じた直後に Altキーの反応が鈍いことが
    多い気がしています。

    EmEditor(に限らず)の編集画面で単独のAltキーを押すと、
    通常はメインメニューの[ファイル]が浮き出ますよね。

    Alt→Fで[ファイル]メニューを出すつもりだったのに、
    実は Alt が利いておらず、
    編集画面にFを入力してしまうことがよくあります。

    これはEmEditorに限ったことではなく、
    他のソフトでも同じようなことがあります。
    ソフトによってWaitのかかり方がちがうのかな、
    と想像しています。

    EmEditorで反応を鋭くするような設定はできないでしょうか。

    どのようにして、他のアプリケーションから切り替えているでしょうか? キーボードの ALT + TAB でしょうか? あるいは、マウスでウィンドウをクリックでそうか? また、ダイアログはどのように閉じているでしょうか? OS は、Windows XP でしょうか?

    #7426

    kshi
    参加者

    江村さん、御返事ありがとうございます。

    状況説明が足りなくて申し訳ありません。
    Windows XP SP3 と Vista Home Premium SP 1
    の両方です。
    EmEditorのバージョンは8.04です。

    ダイアログに関してはすみません、他のキー操作との
    連鎖的なタッチミスだったようです。

    アプリケーションの切り替えについては、
    Alt+Tabでもタスクバーをマウスクリックして切り替えても、
    一発目のAltが効かないことが多いです。

    XPとVistaで若干挙動がちがうところがあります。

    ■ EmEditorのなかに居続けた場合、
    メインメニューの表示は、
    【Vistaの場合】
    ・Alt押し下げでアクセラレータキーに下線がつく。
    ・Altを離したとき周囲が浮き出る。
    となり、問題なく動作します。
    【XPの場合】
    ・常時、アクセラレータキーに下線が付いている。
    ・Altを離したとき周囲が浮き出る。
    となり、問題なく動作します。

    ■ 他のアプリケーションから切り替えると、
    【Vistaの場合】
    ・Alt押し下げ&離す、でアクセラレータキーに下線がつく。(周囲は浮き出ない)
    となります。続いて押した英字が編集画面に入力されます。
    【XPの場合】
    ・Alt押し下げ&離す、で見た目には何も起こらない。
    (VIstaと同じ結果のようだが、下線で見分けられない)
    となります。続いて押した英字が編集画面に入力されます。

    念を押しますと、自分の手元では EmEditor だけで
    起こるのではなく、他のソフトでも起こります。
    しかも下線のON/OFFのタイミングがちがったり
    します。そういうものなのだと思い込んでいました。
    よく使うEmEditorだけでも回避する方法は
    ないだろうかと考えた次第です。

    #7427

    Yutaka Emura
    キーマスター

    kshiさんは書きました:
    江村さん、御返事ありがとうございます。

    状況説明が足りなくて申し訳ありません。
    Windows XP SP3 と Vista Home Premium SP 1
    の両方です。
    EmEditorのバージョンは8.04です。

    ダイアログに関してはすみません、他のキー操作との
    連鎖的なタッチミスだったようです。

    アプリケーションの切り替えについては、
    Alt+Tabでもタスクバーをマウスクリックして切り替えても、
    一発目のAltが効かないことが多いです。

    XPとVistaで若干挙動がちがうところがあります。

    ■ EmEditorのなかに居続けた場合、
    メインメニューの表示は、
    【Vistaの場合】
    ・Alt押し下げでアクセラレータキーに下線がつく。
    ・Altを離したとき周囲が浮き出る。
    となり、問題なく動作します。
    【XPの場合】
    ・常時、アクセラレータキーに下線が付いている。
    ・Altを離したとき周囲が浮き出る。
    となり、問題なく動作します。

    ■ 他のアプリケーションから切り替えると、
    【Vistaの場合】
    ・Alt押し下げ&離す、でアクセラレータキーに下線がつく。(周囲は浮き出ない)
    となります。続いて押した英字が編集画面に入力されます。
    【XPの場合】
    ・Alt押し下げ&離す、で見た目には何も起こらない。
    (VIstaと同じ結果のようだが、下線で見分けられない)
    となります。続いて押した英字が編集画面に入力されます。

    念を押しますと、自分の手元では EmEditor だけで
    起こるのではなく、他のソフトでも起こります。
    しかも下線のON/OFFのタイミングがちがったり
    します。そういうものなのだと思い込んでいました。
    よく使うEmEditorだけでも回避する方法は
    ないだろうかと考えた次第です。

    アクセラレータキーに下線を表示するかどうかですが、Windows のコントロール パネルで設定ができます。これは、ただ見た目の問題で、今回の問題の本質とは関係はありません。

    アプリケーションの切り替え後、Alt をいったん離してから、EmEditor がアクティブになった後に Alt + F を押せば問題はないと思います。私の予想ですが、アプリケーションの切り替えが完全に終わる前に Alt を押して、次に F を押す前に実際に切り替えが起こっているため、EmEditor には F だけしか入力されないのではないか、と思います。いかがでしょうか?

    #7428

    kshi
    参加者

    江村さん、お疲れ様です。

    自分の書いた文章に誤字がないか見返しているあいだに
    またご返事をいただきました。(汗)

    タクスバーをマウスクリックして、
    EmEditorに完全に切り替わり、
    数秒たってからAltを押しても発生します。

    どうも EmEditorに切り替えた直後にうまく
    いかないというよりは、
    EmEditorから他のアプリにAlt+Tabで切り替えて、
    再びEmEditorに戻ったときに一発目のAltが
    効かないようです。キーバッファの関係でしょうか。

    #7429

    Yutaka Emura
    キーマスター

    kshiさんは書きました:
    江村さん、お疲れ様です。

    自分の書いた文章に誤字がないか見返しているあいだに
    またご返事をいただきました。(汗)

    タクスバーをマウスクリックして、
    EmEditorに完全に切り替わり、
    数秒たってからAltを押しても発生します。

    どうも EmEditorに切り替えた直後にうまく
    いかないというよりは、
    EmEditorから他のアプリにAlt+Tabで切り替えて、
    再びEmEditorに戻ったときに一発目のAltが
    効かないようです。キーバッファの関係でしょうか。

    状況がわかりました。

    1. EmEditorから他のアプリにAlt+Tabで切り替えて
    2. タスクバーの EmEditor のアイコンをクリックして EmEditor に戻る
    3. Alt のみを押す
    4. F を押したときに メニューが表示されずにエディタに f と入力されてしまう。

    ということですね。ALT を押しながら F を同時に押せば問題はありませんでした。Alt を押して、いったん離してから F を押せば、問題が再現します。

    これは、EmEditor でなくメモ帳でも同様の現象が発生します。メモ帳はシンプルなアプリケーションで、これでも問題が再現するので、Windows の設計上の仕様または問題ということになると思います。ALT + TAB のときに Alt を押して メニューがアクティブになり、その状態で戻ってくるため、戻ってきたときに Alt が押された状態になっています。でも不思議なのは、このあと Alt を押さずに F だけを押してもメニューが反応せず、やはり f がエディタに入力されてしまいますね。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone