10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #24109

    douki
    参加者

    EmEditor Professional (64-bit)
    Version 17.0.0 beta 1
    から
    EmEditor Professional (64-bit)
    Version 17.1.2
    にバージョンアップしたところ、
    下記のコードの実行で「強調(1)」や「強調(2)」などの設定が初期化されてしまいます。
    document.Config.Save();

    元々の問題として、上記のバージョンアップをしたところマクロに対するキーボード割り当ての設定が変わってしまい、
    マクロに対するキーボード割り当てを行うマクロを作成していたのでこれを実行したところ、実行したマクロの上記のコードで設定の初期化が起こりました。

    この現象はVersion 17.1.1へのバージョンアップでも起こりました。

    #24112

    Yutaka Emura
    キーマスター

    douki 様

    いつもお世話になっております。江村です。

    document.Config.Save();

    の1行だけのマクロで試してみましたが、問題は再現できませんでした。
    これ以外の部分のマクロが関係しているのではないでしょうか?

    よろしくお願い申し上げます。

    #24114

    douki
    参加者

    江村様
    検証頂きありがとうございます。

    当方の環境では
    document.Config.Save();
    の1行だけのマクロを実行しても同様の問題が発生します。
    他に検証すべき点があればご教示頂けるでしょうか。
    なおOSはWindows 10 Homeです。

    #24115

    Yutaka Emura
    キーマスター

    douki 様

    いつもお世話になっております。江村です。

    もしよろしければ、お手数ですが、EmEditor の [ツール] メニューの [インポートとエクスポート] から、[すべての設定をレジストリ ファイルにエクスポートする] を選択し、できた.regファイルと AppData サブ フォルダも含めて、すべてを zip に圧縮して添付ファイルで tech @ emurasoft.com 宛のメールでお送りいただけると幸いです。

    よろしくお願い申し上げます。

    #24117

    douki
    参加者

    江村様
    メールにてご教示いただいた
    「EmEditor を起動する前に、eeConfig.ini の中のすべての RegVersion=19 を RegVersion=21 に変更」
    で、キーボード割り当てを行うマクロを実行しても強調表示の初期化が発生しませんでした。
    ありがとうございました。

    一点質問させていただきたいのですが、
    ポータブル版のバージョンアップでは上記のようなINIファイルの書き換えが必要になる場合があるということでしょうか。

    #24118

    Yutaka Emura
    キーマスター

    douki 様

    いつもお世話になっております。江村です。

    うまくいってよかったです。ポータブル版の場合でも、更新の手順を間違えなければ、問題はないはずです。更新する際には、前のバージョンの存在するフォルダに、新しいバージョンの EmEditor のファイルをコピーすれば、問題はないはずです。しかし、反対に、新しいバージョンの存在するフォルダに設定をコピーする際には、INI ファイルだけでなく、AppData フォルダとその中のファイルもすべてコピーする必要があります。また、古いバージョンの時の INI ファイルを、更新後のフォルダにコピーすると、正しく動作しないことになります。

    よろしくお願い申し上げます。

    #24119

    douki
    参加者

    江村様
    更新の手順に気をつけてみます。
    どうもありがとうございました。

    #24154

    douki
    参加者

    江村様
    ポータブル版の更新の手順について確認させてください。
    2017/2/23の時点のEmEditorフォルダ(Professional (32-bit)Version 16.3.0 beta 5 INIファイルを使用)のバックアップがあったため、これを最新版(EmEditor Professional (64-bit)Version 17.1.2)に更新しようと思っています。

    【手順1】
    ①16.3.0のEmEditorフォルダに対して「emed64_17.1.4_portable.zip」の内容を全て上書きコピー。
    ②上書きコピーしたEmEditor.exeを起動。
    ③強調やアウトラインの設定が維持されていることを確認。
    ④「document.Config.Save();」のみのマクロを実行。
    →③で確認したアウトラインの設定が消失しました。③で確認した強調の設定は維持されています。
    ただしアウトラインの設定が消失したのは「現在の設定」のみであり、他の設定では消失していませんでした。

    【手順2】
    ①16.3.0のEmEditorフォルダに対して「emed64_17.1.4_portable.zip」の内容を全て上書きコピー。
    ②eeConfig.ini の中のすべての RegVersion=19 を RegVersion=21 に変更
    ③上書きコピーしたEmEditor.exeを起動。
    →「現在の設定」に限らず各設定における「強調」、「アウトライン」、「表示」の設定が消失しました(他の項目は未確認)。
    なお「表示」の設定は手順1では消失しませんでした。
    また②においてeeConfig.iniだけでなくeeCommon.iniの RegVersion=19 を RegVersion=21 に変更しても同じ結果でした。

    今後の更新のことも考え、設定を消失させずに更新したい(また上記のマクロも使用したい)のですが、どのような手順で更新すればよいでしょうか。

    上記の2017/2/23の時点EmEditorフォルダ(Professional (32-bit)Version 16.3.0 beta 5 INIファイルを使用)
    の各INIファイルとAppDataフォルダを添付したメールを送信させて頂きましたので
    お手数ですが確認をお願いします。

    #24156

    Yutaka Emura
    キーマスター

    douki 様

    いつもお世話になっております。江村です。

    メールで資料を送っていただき、ありがとうございました。「手順1」でいいのですが、「document.Config.Save();」のみのマクロを実行するとアウトラインの設定が既定にリセットされてしまう不具合がありました。これは、まもなく公開する v17.2.0 beta 1 で修正しました。

    この度はご迷惑をお掛けして申し訳ありませんでした。

    今後もよろしくお願い申し上げます。

    #24160

    douki
    参加者

    江村様
    v17.2.0 beta 1にて問題が解消していることを確認しました。
    ご検証・ご確認頂きありがとうございました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone