8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #23952

    Delフサ
    参加者

    32bit版、ポータブルを使っています。
    v16.9.3から、
    v17.0.0にバージョンアップした際に、
    プラグインの登録設定が消えました。
    デフォルトのプラグインしか登録されてない状態でした。

    追加登録を複数で行えるので回復は手間かからないのですが
    念のため、ご報告しておきます。

    #23954

    Yutaka Emura
    キーマスター

    Delフサ 様

    いつもお世話になっております。江村です。

    こちらでは、特に問題は再現できませんでした。v14.9 より、[プラグインの設定] ダイアログに [追加] と [削除] ボタンが追加され、プラグインが PlugIns フォルダにあるというだけでは、自動的にはプラグインの一覧には追加されなくなりましたが、その前からあったプラグインで、その後、プラグインの設定を変更されなかったのでしょうか? 念のため、こちらでも v14.8 の状態から更新してみましたが、特に問題は再現できませんでした。

    もし何かお気付きの点がございましたらご連絡ください。また、v17.0.0 に更新前のレジストリの情報がありましたら、zip に圧縮して私宛にメールしていただければ、こちらでも再現テストを行います。

    よろしくお願い申し上げます。

    #23957

    Delフサ
    参加者

    了解しました。
    ありがとうございます。
    何か環境に依存するかもしれないです。
    調べてご報告します。

    #23959

    Delフサ
    参加者

    ポータブル版なのですが、Iniファイルのどのキーに、Pluginの情報が入っているか、など、
    記載可能でしょうか?
    あるいは、GUIで確認できますでしょうか?

    ver16.9.3では、
    プラグインの設定 の画面に、プラグインが一覧で出ていますが
    ver 17.0.0 にあげると、登録が消えてしまうようです。

    「プラグインの設定を変更」というのは、
    個別に設定変更という意味でしょうか?
    自作のプラグインなどは、EmEditorのGUIからの設定は行わず、
    たいてい、設定ファイルを直接編集するものだったりするので
    昔からの登録がない状態だったけど、フォルダにあったから読み込まれていた
    という状態になったのかもしれないです。

    EmEditor標準搭載のPluginだけは
    ver17.0.0で表示されますが、
    自作や、他の方が作られたPluginは全て消えるようですね。

    まあ、登録しなおせばすむ話なのですが。

    Download DelFusaFloor
    http://delfusa.main.jp/delfusafloor/download/download.html

    #23962

    Yutaka Emura
    キーマスター

    Delフサ 様

    いつもお世話になっております。江村です。

    プラグインの情報は、ポータブル版の場合、v16.9.3 以下では、eeCommon.ini ファイルの [PlugIns] というセクションに入っていました。v17 では、(EmEditor.exeのあるフォルダ)\AppData\Common\PlugIns.bin に入っています。

    「プラグインの設定を変更」の意味は、EmEditor の [ツール] メニューの [プラグインの設定] を選択してダイアログでプラグインを追加したり順番を入れ替えたりして、[OK] クリックするという意味です。

    もし可能ならば、EmEditor.exe の存在するフォルダにある INI ファイルすべてと .\AppData\Common\PlugIns.bin を zip に圧縮して、添付ファイルとして tech @ emurasoft.com 宛に送っていただけると幸いです。

    よろしくお願い申し上げます。

    #23974

    Delフサ
    参加者

    すでにメールで頂いておりましたが、v17.0.1 の修正内容で
    上記の件は
    v16.9.3から、v17.0.1にあげて、問題ないこと、修正されたことを確認できました。

    また、関連するのですが、なぜか
    拡張子 *.vba の設定が初期化されているようです。
    強調文字の色分け設定が変になっておりました。
    どの設定が引き継ぎOKでどの設定がNGなのかは、不明ですが
    送付しております自分の環境ではvbaファイル(VB系設定)はだめでした。

    ご確認いただけたら、と思います。

    #23975

    Delフサ
    参加者

    少しわかりました。
    v16.9.3で、
    設定名を
    [VB.NET/VBScript]とか
    [Delphi/Pascal]とか
    してたものが、誤動作しているみたいです。

    v17.0.1では、
    [VB.NET/VBScript][Delphi/Pascal]
    に加えて
    [VB.NET_VBScript][Delphi_Pascal]
    という設定名が増えていました。
    が、そちらが正常に引き継がれている、ということもないです。

    設定名に、スラッシュ、が使われていないと
    正常みたいです。

    よろしくおねがいします。

    #23976

    Yutaka Emura
    キーマスター

    Delフサ 様

    いつもお世話になっております。江村です。

    情報をメールで送っていただき、ありがとうございました。送っていただいた設定名に / が含まれていたため、v17.0.1 からは、 / などのファイル名に使用できない不正な文字を _ に変換するようにしました。既に、不正な文字が使用されている場合は、設定名に不正文字が含まれないように変更してから、使用していただくことをおすすめします。このあたりについて、さらに調査いたします。

    よろしくお願い申し上げます。

8件の投稿を表示中 - 1 - 8件目 (全8件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone