1 件の投稿を表示中 (合計 14 個)
  • 作成者
    投稿
  • #29777
    snow
    参加者

    お疲れ様です。

    20.5か20.6かあたりからだと思うのですが、突然クライアントエリアが描画されなくなることがあります。
    気づくのがタブをクリックしてもそこにフォーカスが移らない時なので、そのタイミングかも知れません。
    ウィンドウのコントロールは効き、閉じることもできます。閉じて再度起動すれば正常に戻ります。
    その状態で使い続けていると、また突然描画されなくなります。

    他に色々とアプリを起動していますが、現象はEmEditorのみで発生しています。
    修復インストールは効果がありませんでした。

    #29778
    snow
    参加者

    追記です。
    入力中のテキストがある場合、本来はクローズ時に確認が表示されるところですが、この状態のときにクローズするとそれが表示されずにウィンドウが閉じます。
    そのため入力中の内容が失われます。
    先程は他のアプリからフォーカスを戻した際に発生しました。
    ですのでタブクリック時ではなさそうです。

    #29824
    snow
    参加者

    お疲れ様です。
    20.7で挙動が変わったようです。
    入力中のテキストがある場合に現象発生、クローズしようとすると、即クローズではなくエディタと同じサイズの中身のないウィンドウがあがるようになりました。
    右上の閉じるボタンを押すとエディタに戻りますので、描画がおかしいだけで確認が機能するようになったのでしょうか。
    未保存の文書をctrl+A→ctrl+Xと切り取って空にし、再度エディタをクローズすると閉じられました。

    何かハードの問題かとも思っていたのですが、今月新規に組んだPCでも同一でした。
    CPUが新旧ともAMDであることが、関係あるかどうか…。

    以下観察していて気づいたことです。
    ・単に文書を編集しているだけでも発生する模様。
    ・編集領域の描画が止まると同時に(?)タブバーの表示もおかしくなり、さらに続けているとタブバーが消えて編集領域がせり上がったような状態になる。
    ・スタイルは「タブ」でも「ボタン」でも発生。
    ・タブバーは普段から結構表示がちらつき、とくに * が付くとき消えるときが目立つ。編集中の文書とその右だけでなく、全タブが再描画?
    ・別の問題か、正常時に一番右から順に閉じていくと、×が無反応になることがある。他の文書をクリックすると復活する(これは結構前から出ていた気がします)。

    #29826
    Yutaka Emura
    キーマスター

    snow 様

    いつもお世話になっております。

    クローズしようとすると、即クローズではなくエディタと同じサイズの中身のないウィンドウがあがるようになりました。

    という現象は、Windows の機能で、ウィンドウがフリーズした時に発生する現象だと思います。

    DirectWrite はオンにして使われているのでしょうか?

    また、OS は、Windows 10 でしょうか? Windows の更新は最新になっていますでしょうか?
    Windows 10 の最新版の場合、IME の問題の可能性もあるため、以下をご参考にして、以前のバージョンの IME に戻すこともお試しください。

    https://support.microsoft.com/ja-jp/office/%E4%BB%A5%E5%89%8D%E3%81%AE%E3%83%90%E3%83%BC%E3%82%B8%E3%83%A7%E3%83%B3%E3%81%AE-ime-%E5%85%A5%E5%8A%9B%E6%96%B9%E5%BC%8F%E3%82%A8%E3%83%87%E3%82%A3%E3%82%BF%E3%83%BC-%E3%81%AB%E6%88%BB%E3%81%99-adcc9caa-17cb-44d8-b46e-f5b473b4dd77

    よろしくお願い申し上げます。

    #29840
    snow
    参加者

    ご返信ありがとうございます。
    たしかに少し前にWindowsを10-2004にアップしました。そちらの機能だったのですね。

    DirectWriteはオンです。オフにして様子を見ようと思います。
    IMEはGoogle IMEを使用しており、MS-IMEの問題には該当しないと思われます。
    よろしくお願いいたします。

    #29841
    snow
    参加者

    お疲れ様です。
    残念ながら、DirectWriteオフでも発生しました。
    以上ご報告まで。

    #29844
    Yutaka Emura
    キーマスター

    snow 様

    いつもお世話になっております。

    Google IME の問題の可能性も考えられるため、Windows 10 に標準で付いてくる Microsoft IME に変更してお試しいただけないでしょうか?

    よろしくお願い致します。

    #29879
    snow
    参加者

    ありがとうございます。
    今回もご報告のみになりますが、MS-IMEでも再現いたしました。

    #29880
    Yutaka Emura
    キーマスター

    snow 様

    いつもお世話になっております。

    これは既存のファイルを開いている時に発生するのでしょうか? 新規作成直後には発生しないのですね?
    また、特定の種類のファイルで発生するのでしょうか? 1行が非常に長い場合に発生するのでしょうか?

    まず、プラグインをすべて無効にして、イベントで実行されるマクロがあれば、それらのマクロの「イベントで実行」もすべて無効にしてお試しください。

    それでもまだ問題が再現する場合には、大変お手数ですが、次のような手順を行っていただけると幸いです。

    1. [ツール] メニューの [インポートとエクスポート] を選択し、[すべての設定をレジストリ ファイルにエクスポート] を選択してください (ただし、ポータブル版の場合は、[すべての設定を INI ファイルにエクスポート] を選択してください)。

    2. [ツール] メニューの [すべてのコマンド] – [ツール] – [すべての設定をリセット] を選択します。もし、これで設定がリセットされない場合には、一度、EmEditor をアンインストールし、アンインストールの最中、設定を保存するかどうかの質問には「いいえ」を選択します。そして、再度インストールします。

    3. これで問題が解決した場合には、エクスポートしたファイルのすべて (サブ フォルダ AppData を含む) を zip に圧縮して、私宛 (tech @ emurasoft.com) に送っていただければ幸いです。

    4. [ツール] メニューの [インポートとエクスポート] を選択し、エクスポートしたファイルをインポートしていただければ、元の設定に戻ります。

    また、特定のファイルで発生する場合には、それらんファイルを zip にしてお送りいただけると幸いです。ファイルが大きくて送れない場合には、まず簡単なメッセージをお送りいただければ、アップロード先をお知らせいたします。

    よろしくお願い致します。

    #29882
    snow
    参加者

    ご返信ありがとうございます。

    プラグインは標準のプロジェクトのみ使用しています。
    マクロは自前のものを含めいくつか登録し、ショートカットキーで使用しています。

    編集する頻度の多い10程度のhtmlファイルを常時開いてタブ表示しています。
    このうち1つは22,000行超、1.6MBほどありますが、基本的に通常テキスト文書にタグを付けるスタイルのため、1行が数千文字あったりはしません。
    日々の作業では、それに加えてその他のhtmlファイルやjs、cssファイルを確認したり編集したりしています。
    総数は1,000超、プロジェクトで階層分けして開きやすくしています。
    多量のため、特定の情報について確認する際は「ファイルから検索」も多用しています。

    上記1.6MBのファイルで発生することが多い印象ですが、単に一番編集頻度が多いためとも言えます。
    クローズ確認について記載したとおり新規ファイルの入力中に発生することもあり、特定のファイルということはなさそうです。

    今回設定を初期化して気づいたのですが、上記はhtmlといっても、タグや属性について自前で拡張したものになっています。
    (onloadイベントで処理し、標準のタグに展開するようにしています)
    構文チェッカーは非表示にしていますが、働いていれば常にエラーが記録されていることになります。
    上記1.6MBのファイルですとわずか374行目でTerminating validation due to too many errors〜となっています。
    何かしら影響することはあり得ますでしょうか。

    今朝がた初期化して、まだほとんど編集していないため事象は発生していませんが、まずは気づいたことを報告させていただきました。

    #29883
    Yutaka Emura
    キーマスター

    snow 様

    いつもお世話になっております。

    [カスタマイズ] ダイアログ ボックスの [構文チェック] タブで、[HTML/CSS/JSON用構文チェック エンジン] ドロップダウン リスト ボックスから、「(無し)」を選択してお試しください。

    よろしくお願い致します。

    #29886
    snow
    参加者

    ご返信ありがとうございます。

    設定のリセット後、今朝の時点で、事象はまだ一度も発生していません。
    このため構文チェックは関係がないと考えています。
    昨夜、頻繁に使用していたマクロをひとつ登録して様子見しています。
    以前の設定をインポートしないで、1日いくつかずつ手動で復元して行くつもりでいます(ほぼ1日に1回以上は発生していましたので)。
    これでもし何かを復元した後に再現したら、お知らせしようと思っています。

    よろしくお願いいたします。

    #29899
    snow
    参加者

    夕方に発生しましたので報告させていただきます。
    今のところ一番可能性が高いのはツール→カスタマイズ→表示→「非常に暗い(ベータ)」です。
    タブ設定や文字色/背景色、フォント、ワークスペース等々を順次復元している間は一度も発生しませんでした。
    今はいったんオフにしてあり、その後は発生していません。
    このまましばらく様子を見て、発生しないようなら再びオンにしてみようと思います。

    #29920
    snow
    参加者

    お疲れさまです。
    機能をオフにしてから5日間、一度も発生しませんので、当事象は「非常に暗い(ベータ)」が原因と考えてまず間違いなさそうです。
    先ほど改めてオンにしてみました。

1 件の投稿を表示中 (合計 14 個)
  • このトピックに返信するにはログインしてください。