8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #3763

    shizuto
    メンバー

    EmEditor Professional 6.00.2を使わせていただいています。

    USB接続のカードリーダーにカードを「入れない」状態で接続して、
    そこでEmEditorを起動すると
    「Windows – ディスクがありません
    ドライブにディスクがありません。ディスクをドライブに挿入してください。」
    というエラーメッセージが出ます。キャンセルか続行を選べばちゃんと起動しますが、
    毎回エラーメッセージが出るのは不具合と呼ぶべきことでしょう。

    予想では標準プラグインの何かがドライブをチェックしに
    行くときに「USB大容量記憶装置デバイス」扱いのリーダーに
    カードが入っていない状態が想定されていないという
    状況だと思います。

    ぜひ調査と修正をお願いします。

    OSはWIndows XP Professional SP2です。

    #3764

    Yutaka Emura
    キーマスター

    こちらではそのような問題は発生しないのですが、おそらく環境の違いによって発生するのだと思います。エクスプローラ プラグインを表示しない状態で試していただけますか? それでも再現する場合は、すべてのプラグインを一度無効にして、再現するかどうかお試しください。よろしくお願いします。

    #3775

    shizuto
    メンバー

    もともとエクスプローラ プラグインは表示していませんし、
    すべてのプラグインを無効にした状態でも発生しました。

    いろいろやってみたところ、パソコンを起動して最初にカードなしの状態でカードリーダーを繋いでEmEditorを起動したときは発生せず、そこからカードを抜いてEmEditorを起動するとエラー表示が発生しました。
    ただ、その後で(「ハードウェアの安全な取り外し」を使って)カードリーダーそのものをはずし、再度カードなしの状態で接続してからEmEditorを起動するとエラー表示が出ました。

    念のため書いておくと、カードリーダーは
    BUFFALO(メルコ)のMCR-SM2-LTというスマートメディア用のものです。

    #3776

    takuya
    参加者

    EmEditorのテンプレートや、バックアップフォルダがカードリーダー内に設定されている可能性とかないですかね。

    #3779

    shizuto
    メンバー

    テンプレートはいじっていないのでたぶん問題ないですし、
    バックアップは「ごみ箱」に、という設定にしています。

    そもそもカードリーダーを刺していなければエラーも出ないです。

    #3780

    qtv
    参加者

    Windows2000SP4で試してみましたが,発生しませんでした.
    タブモードです.

    [手順1]タスクトレイのEmEditorを終了
    1. メディアなしでカードリーダを挿す
    2. HDD内のテキストファイルをEmEditorで開く(OK)
    3. EmEditorを終了させる
    4. メディアをカードリーダに挿す
    5. メディア内のテキストファイルをEmEditorで開く(OK)
    6. カードリーダをWindowsから抜く
    7. HDD内のテキストファイルをEmEditorで開く(OK)

    [手順2]タスクトレイのEmEditorを終了
    1. メディアなしでカードリーダを挿す
    2. HDD内のテキストファイルをEmEditorで開く(OK)
    3. EmEditorを閉じずに,メディアをカードリーダに挿す
    4. メディア内のテキストファイルをEmEditorで開く(OK)
    5. 4で開いたファイルだけを閉じる
    5. メディアをExplorerの「取り出し」で抜いた後,物理的に取り外す
    6. HDD内のテキストファイルをEmEditorで開く(OK)

    バックアップフォルダは,HDD内にしています.
    ごみ箱フォルダは,各ドライブごとに作られると思うので,何かしらまずい気がします.
    「設定のプロパティ」の「バックアップフォルダ」でファイルダイアログを出すと,同じようなメッセージが出ました.
    ひとまず,バックアップや自動保存のフォルダをHDD内にするといいのかもしれません.

    あまり役に立たないかもしれませんが,情報まで.

    #3833

    shizuto
    メンバー

    blog用の写真をデジカメから取り出すのにカードリーダーを使っていて、また再現したので報告を。
    バックアップフォルダをHDD内にしてもバックアップをしない設定にしても再現しました。

    上の書き込み、メディアをExplorerの「取り出し」で抜いた後、とあるので普段メディアは(アクセスしていないのを確認した上で)「取り出し」をせずに抜いてるなあと思って、「取り出し」を選択したら、アクセスしているので取り出しできません、とエラーを出されました。
    ディスクに自動でアクセスするようなソフトは、ウイルスバスターしか思い浮かばなくてリアルタイム検索を外しても同じ状況。
    このあたりに原因がありそうですが、どうしてエラーがでるのかは分かりません。物理的にメディアを外して他のメディアを差せば普通に読めます。ただ、EmEditor以外のソフトでは今のところ変なエラーはでないので…。

    #3838

    takuya
    参加者

    他に、パスを保存している箇所がありそうな設定でマクロの履歴、外部ツール、エキスプローラープラグインについて調べてみました。それぞれリムーバブルディスクを指定して実行した後、リムーバブルディスクを取り外して実行してみました。特にエラーメッセージは表示されませんでした。

8件の投稿を表示中 - 1 - 8件目 (全8件中)

このトピックに返信するにはログインが必要です。

友達に知らせる... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone