FAQ

インストール

新しいバージョンの EmEditor をインストールするにはどうしたらいいでしょうか?

EmEditor ホーム ページから EmEditor 最新版をダウンロードしてインストールします。次の手順で行ってください。

1. トレイ アイコンが実行されている場合は、トレイ アイコンを終了します。これを行うには、タスクバー上に表示されているトレイ アイコンを右クリックし、表示されるメニューで [トレイ アイコンを閉じる] コマンドを選択します。

2. コントロール パネルから、以前のバージョンの EmEditor を選択してアンインストールします。

3. アンインストールの最中、「アンインストール時に EmEditor の設定を保持しますか?」というメッセージが表示されることがあります。以前の設定を保持したい場合は「はい」を選択します。以前の設定を保持する必要がない場合は「いいえ」を選択することを推奨します。

4. 次の EmEditor の種類と OS のバージョンから選択してダウンロードしたいリンクをクリックします。

ダウンロード

5. ダウンロードするリンクをクリックすると、以下のような [ファイルのダウンロード - セキュリティの警告] ダイアログ ボックスが表示されます。

6. [実行] ボタンをクリックすると、ダウンロードが開始し、ダウンロードが完了後、以下のような [Internet Explorer - セキュリティの警告] ダイアログ ボックスが表示されます。

7. ここで、「発行元: Emurasoft, Inc.」の部分をクリックします。

8. [デジタル署名の詳細] ダイアログが表示されます。ここで、「このデジタル署名は問題ありません」と表示されていることを必ず確認します。もし表示されない場合は、ダウンロードされたファイルが壊れている可能性があり、このまま継続しても正しくインストールされません。この場合は、一度、ブラウザの一時ファイルをクリアしてから、再度ダウンロードすることをおすすめします。

9. [Internet Explorer - セキュリティの警告] ダイアログ ボックスに戻り、[実行] をクリックし、画面の指示にしたがってセットアップを進めて行きます。

EmEditor 最新版をインストールしたいのですが、以前のバージョンの EmEditor をアンインストールせずに、そのままインストールしていいのでしょうか?

現在の EmEditor のバージョンが v3.00 以上で、現在の設定内容を引き継ぎたい場合、以前のバージョンをアンインストールせず、そのまま最新版のセットアップを実行して、セットアップ先のフォルダを、以前と同じフォルダにして構いません。ただし、新しいバージョンをインストールする前に、現在実行中の EmEditor ウィンドウやトレイ アイコンはすべて閉じます。もしインストール中に Windows の再起動を促された場合には、Windows を再起動します。

現在の EmEditor のバージョンが v3.00 未満の場合、または、現在の EmEditor の設定内容を引き継ぐ必要がない場合、以前の EmEditor をアンインストールして、コンピュータを再起動してから、新しいバージョンの EmEditor をインストールすることをおすすめします。その場合の手順は次の通りです。

1. Windows スタート メニュー – [コントロール パネル] – [プログラムの追加と削除] から、EmEditor (または EmEditor v3) を選択して [削除] ボタンをクリックします。

2. アンインストールが完了したら、Windows を再起動します。

3. 新しいバージョンをインストールします。

古いバージョンの EmEditor と新しいバージョンの EmEditor を共存させることはできますか?

いいえ、古いバージョンの EmEditor と新しいバージョンの EmEditor を共存させることはできません。

EmEditor の起動時、または編集時に、EmEditor が異常終了されたらどうしたらよいでしょうか?

1. もしプラグインがインストールされている場合、プラグイン フォルダからプラグインを全てアンインストールし、その後 EmEditor を再起動してください。

2. もし異常が続くようでしたら、コントロールパネル内のアプリケーションの追加と削除で EmEditor をアンインストールしてください。その後、コンピュータを再起動し、EmEditor を再インストールしてください。

3. もし、UTF-8 ファイルまたは、Unicode ファイルを開く時のみ EmEditor が異常終了される場合は、[表示] メニューの [フォントの設定] の [フォント分類] で [標準] を選択し、表示フォントの横にある [変更] ボタンをクリックし、適切なフォントが選択されているか確認してください

EmEditor のトレイ アイコンを表示しないようにしたいけど、どのようにしたら、トレイ アイコンを表示しないようになりますか?

Version 6.00 以上の場合、[ツール] メニューの [カスタマイズ] コマンドを選択し、[カスタマイズ] ダイアログの [ショートカット] タブを表示します。そして、[トレイ アイコンを表示] チェック ボックスのチェックを外します。もし、既にチェックが外れている場合は、いったんチェックして、[OK] をクリックしてダイアログを閉じ、再びこのダイアログを表示して、チェックを外します。

Version 6.00 未満の場合、再度セットアップを行い、セットアップ時に、[タスクバー上にトレイアイコンを追加] チェックボックスをオフにします。セットアップの前にアンインストールする必要はありません。この方法でうまくいかない場合は、Windows のスタート メニューから、[検索] を選択し、「何を検索しますか?」と表示されたら、「ファイルとフォルダすべて」をクリックし、「emeditor.lnk」および「emeditor v3.lnk」を検索します。「スタート アップ」というフォルダの中に「emeditor.lnk」または「emeditor v3.lnk」を見つけたら、そのファイルを削除します。

ダイアログ ボックスを表示せずに EmEditor のインストールを行うには?

通常のインストールでは、ダイアログ ボックスが表示され、ユーザーが [次へ] ボタンをクリックしたり、オプションを設定する必要があります。しかし、企業や団体などで複数のコンピュータにインストールする場合、インストールの作業をバッチ ファイルやスクリプトで行い、ダイアログ ボックスを表示したくない場合があります。EmEditor は、インストーラに Windows Installer を使用しているため、次のようにして、無人インストールを行うことができます。

たとえば、EmEditor のセットアップ用のファイルが emed32_13.0.0.exe の場合、

emed32_13.0.0 /exenoui /q

を実行すると、一切のダイアログ ボックスが表示されず、既定の設定でインストールを行うことができます。既定の設定を変更したい場合、次のオプションを使用することができます。

NOCHECKUPDATES=1 EmEditor の新しいバージョンをインターネットで定期的にチェックします。

NOCONTEXTMENU=1 エクスプローラのコンテキスト メニューにショートカットを追加することを無効にします。

NODESKTOP=1 デスクトップにショートカットを追加することを無効にします。

NOIEEDITOR=1 Internet Explorer のHTMLエディタの一覧に EmEditor を追加しません。

NOIEVIEW=1 Internet Explorer でソース表示に EmEditor を使用しません。

NOPATH=1 EmEditor へのパスを PATH 環境変数に追加することを無効にします。

NOSHORTCUT=1 プログラム メニューにショートカットを追加することを無効にします。

NOTRAYICON=1 タスクバーにトレイ アイコンを追加することを無効にします。

NOTXT=1 テキスト ファイルの関連付けを無効にします。

REGNAME=name 登録ユーザーの名前を入力します。

REGKEY=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx 登録キーを入力します。

/q ダイアログ ボックスを表示せずに EmEditor をインストールします。

/exenoui 最初の言語選択ダイアログ ボックスを表示せずにインストールします。

たとえば、登録キーを設定して、セットアップを実行したい場合は、

emed32_13.0.0 /exenoui /q REGKEY=xxxxx REGNAME=name

と実行します。

他にも、Windows Installer にはさまざまなオプションが存在します。詳しくは、コマンド プロンプトで、

emed64_13.0.0.exe /?

および

msiexec /?

を実行すると、コマンドの一覧が表示されます。

インストール先フォルダを変更するには?

既定では、インストール先フォルダは、以前のバージョンが既にインストールされている場合はそのフォルダになり、新しいインストールの場合は \Program Files\EmEditor になります。コマンドプロンプトを開いて、インストーラを TARGETDIR オプションを付けて実行することにより、インストール先フォルダを変更することが可能です。

たとえば、EmEditor のセットアップ用のファイルが emed700jpx.msi で、C:\path にインストールしたい場合、

emed700jpx.msi TARGETDIR=”C:\path\”

を実行します。フォルダ名の最後には、バックスラッシュ を追加してください。

異なるバージョンの EmEditor を同時にインストールすることはできません。以前のバージョンの EmEditor が既にインストールされている場合は、以前のバージョンをアンインストールしてから新しいバージョンをインストールするか、以前のバージョンがインストールされているフォルダ上に上書きインストールしてください。

構文ファイルのインストール方法

1. [ツール] メニューの [設定の選択] をクリックします。

2. メニューの一番下にある [設定の定義] をクリックします。

3. [新規作成] ボタンをクリックし、[既定の設定を使用] を選択し [OK] をクリックします。

4. 名前を入力して、Enter を押します。

5. [プロパティ] ボタンをクリックし、[強調(1)] ページを選択します。

6. [インポート] ボタンをクリックし、追加する構文ファイルを選択して開きます。

7. [OK] をクリックしてプロパティを閉じ、[閉じる] をクリックしてダイアログ ボックスを閉じます。

さらに拡張子の関連付けを有効にするためには、次のようにしてください。

8. [ツール] メニューの [設定の選択] で正しい設定が選択されていることを確認します。

9. [ツール] メニューの [現在の設定のプロパティ] を選択します。

10. [関連付け] ページを選択し、[ここで設定する関連付けを有効にする] をチェックします。

11. [追加] ボタンをクリックし、適切な拡張子を入力します。

現在 EmEditor の新しいバージョン (またはβ版) を使っています。古いバージョンをインストールしたいのですが、現在使用している EmEditor をアンインストールせずに、そのままインストールしていいのでしょうか?

いいえ。古いバージョンの EmEditor をインストールする前に、現在使用している EmEditor をアンインストールする必要があります。これを行わないと、新しい DLL ファイルがインストール ディレクトリに残ってしまい、古いバージョンの EmEditor と互換性の問題が発生することがあります。新しいバージョンをアンインストールする前に、現在実行中の EmEditor ウィンドウやトレイ アイコンはすべて閉じます。新しいバージョンをアンインストールする際に、すべての設定を保持するかどうかを選択するメッセージが表示されます。[はい] を選択すると、すべての設定を保持して、古いバージョンでもその設定を使用できる可能性があります。インストール中に Windows の再起動を促された場合には、Windows を再起動します。

EmEditor Professional の最新版をインストールすると、関連付けしたテキスト (.txt) ファイルに EmEditor 特有のアイコンが表示されません。

EmEditor Professional 7 からは、インストールしてもテキスト ファイルのアイコンを Windows 標準のアイコンから変更しないようになりました。従来のアイコンで表示するには、EmEditor の [ツール] メニューの [カスタマイズ] を選択し、[ファイル] タブを選択し、[EmEditor と関連付け] ボタンをクリックし、表示されるアイコンの一覧から txt を選択して、[プロパティ] ボタンをクリックします。[アイコン抽出先ファイル名] テキスト ボックスに、EmEditor のインストール先フォルダにある emedres.dll というファイル (通常、C:\Program Files\EmEditor\emedres.dll) を入力します。そして、[現在のアイコン] リスト ボックスから、txt のアイコンを選択します。

EmEditor が起動しなくなりました。

ウィルスバスター 2009 をインストールし、最新のセキュリティ アップデートを適用すると、EmEditor が起動しなくなることが知られています。ウィルスバスター 2009 をアンインストールするか、デスクトップにあるウィルスバスターへのショートカットを削除すれば問題は解決します。

64ビットのポータブル版の作成方法

64ビットのポータブル版を作成するには、次の手順で行うと簡単に作成することができます。

1. ダウンロード ページより、EmEditor Professional (64ビット) インストーラーをダウンロードします。

2. コマンドプロンプトまたは [ファイルを指定して実行] ダイアログで、次のコマンドを実行すると、適当な名前のサブ フォルダが作成され、インストーラーの中身のファイルがすべて解凍されます。

(パス)emed64_13.0.2.exe /extract
(インストーラーのファイル名が emed64_13.0.2.exe の場合)

3. そのフォルダの中身のファイルすべてを USB メモリなどのインストール先フォルダにコピーします。

4. 同フォルダに eeUseIni.ini というサイズが 0 ファイルを作成します。

以上で、64ビット版のポータブル版が作成できます。

クラック、Keygen、シリアル

クラック、Keygen、シリアルをご覧ください。

アンインストール

EmEditor を試用していましたが、購入しないことにしました。EmEditor をアンインストールするには、どうしたらいいですか?

現在実行中の EmEditor をすべて終了します (すると EmEditor ヘルプも閉じられますので、ヘルプからこれを読んでいる場合は、この内容はメモしておくことをおすすめします)。Windows の [スタート] メニューからコントロール パネルを開き、[プログラムの追加と削除] を選択します。[プログラムの追加と削除] ダイアログ ボックスが表示されたら、一覧から、「EmEditor」を選択し、[削除] ボタンをクリックします。すると、「EmEditor アンインストール」ダイアログ ボックスが表示されるので、画面の指示に従います。アンインストールが終了したら、Windows を再起動することをおすすめします。

EmEditor をアンインストール後、あるファイルをダブルクリックすると EmEditor を探してしまうが EmEditor は存在しないのでそのファイルを開くことができません。どうしたら、そのファイルを開くことができるでしょうか?

EmEditor の [EmEditorと関連付け] で関連付けた場合は、アンインストールで元のプログラムに関連付けを戻すようになっていますが、自分で、EmEditor をエクスプローラなどで関連付けた場合は、アンインストール後に、自分で元に戻す必要があります。この場合、Windows のエクスプローラを開き、[ツール] メニューの [フォルダ オプション] を選択し、[ファイルの種類] タブを選択し、[登録されているファイルの種類] リスト ボックスで、関連付けを解除したい拡張子を選択し、[変更] ボタンをクリックします。すると、[ファイルを開くプログラムの選択] ダイアログ ボックスが表示されるので、EmEditor 以外の関連付けたいプログラムを選択します。

EmEditor をアンインスートール後、インターネット エクスプローラのコンテキスト メニューの ソースの表示 を選択しても、メモ帳でソースコードが表示されないはなぜですか?

以前の EmEditor のバージョンで、レジストリ情報を完全にアンインストールできないものがありました。スタート メニューから [ファイル名を指定して実行] を選択し、「RegEdit.exe」 と入力し OK ボタンをクリックしてレジストリ エディタを実行します。HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerView Source Editor を検索し、このキーを削除してください。

アンインストール後、C:/Program Files/EmEditor/ のフォルダの中に emedtray.exe と emedres.dll の 2 つのファイルが残っていて、削除できないのですが、どうしたら削除できますか?

本来は、アンインストール時にこれらのファイルが削除されるはずなのですが、なんらかの原因で、削除されなかったようです。これらのファイルを削除するためには、まず、EmEditor のトレイ アイコンを起動しているショートカットを削除する必要があります。そのためには、

Q. EmEditor のトレイ アイコンを表示しないようにしたいけど、どのようにしたら、トレイ アイコンを表示しないようになりますか?

の手順にしたがって、ショートカットを削除します。

次に、タスク バーに EmEditor のトレイ アイコンがあるはずなので、それをクリックして、「トレイ アイコンを閉じる」を選択します。その後、EMEDTRAY.EXE と EMEDRES.DLL を削除することができます。

Windows のコントロール パネルのプログラムの追加と削除から、EmEditor の古いバージョンをアンインストールすることができません。どうしたらどうしたらアンインストールできますか?

EmEditor の古いバージョンをアンインストールすることができない場合、古いバージョンのインストーラーを “/L*V log.txt” オプションを付けて実行してください。すると、アンインストールのログ ファイルが作成されます。例えば、インストーラーが “emed64_14.3.1.exe” なら、次を実行します。

emed64_14.3.1.exe /L*V log.txt

log.txt ファイルは、インストーラーが停止した理由について、役に立つ情報が含まれている可能性があります。

注意: 古いバージョンのインストーラーが見つからない場合には、C:\ProgramData\Emurasoft\EmEditor\updates\update… フォルダに見つかる場合があります。または、ホーム ページのライブラリ http://www.emeditor.com/library/#toggle-id-2 からも見つかることがあります。

古いバージョンのアンインストール中に、次のいずれかのダイアログ ボックスが表示された場合:

「選択した機能は現在使用できないネットワークリソースにあります。」

または、

「The feature you are trying to use is on a CD-ROM or other removal disk that is not available. Insert the ‘EmEditor Professional (…)’ disk and click OK.」

まず、古いバージョンのインストーラーを見つけます。インストーラーを “/extract” オプションを付けて解凍します。例えば、インストーラーのファイル名が “emed64_14.3.1.exe” の場合、以下を実行します。

emed64_14.3.1.exe /extract

インストーラーを “/extract” オプションを付けて実行すると、ファイルの中身と共にサブ フォルダが作成されます。その中に、”.msi” というファイル拡張子のファイルが含まれています。この場合、”emed64_14.3.1.msi” になります。

アンインストール時に、上のダイアログ ボックスが表示された場合、参照ボタンを押して、上の .msi ファイルを指定します。アンインストールを継続すると、古いバージョンをアンインストールすることができます。

どの .msi ファイルが必要かわからない場合、log.txt ファイルを表示すると、情報が見つかることがあります。

または、GeekUninstaller (フリーウェア)、または Revo Uninstaller (フリーウェア) をダウンロードして実行すると、不要なアプリケーションの項目が削除できます。

さらにサポートが必要な場合、詳細な情報を添えて、tech@emurasoft.com 宛のサポートまで log.txt をメールでお送りください。

ファイル

名前を付けて保存で、ファイル名に拡張子の付かない名前を指定しても、.txt という拡張子が自動的に付いてしまいます。拡張子を付かないようにするにはどうしたらいいですか?

ファイル名を “file” のように “” で囲って保存すると、拡張子を付けずにファイルを保存することができます。

ファイルを開く時、日本語 (シフト JIS) のファイルなのに、西ヨーロッパ言語と間違えて検出されることがあります。

開くファイルの種類のプロパティの [ファイル] タブで、[すべて自動検出] がチェックされていると、特に小さいファイルの場合に、誤検出することがあります。このチェックをはずしてご利用ください。

すべてのウィンドウを一度に終了するには?

[Shift] を押しながら、ウィンドウ右上の × をクリックします。

次の方法でも、すべて終了することができます。

  • [Alt] + [Shift] + [F4] を押します。
  • [Alt] + [Shift] + [X] を押します。
  • [Shift] を押しながら、[ファイル] メニューの [閉じる] を選択します。
  • ツールバーをカスタマイズして [すべて終了] ボタンを加え、それをクリックします。
  • トレイアイコンをマウスで左クリックして表示されるメニューの [すべて終了] を選択します。
  • [ファイル] メニューの [すべて閉じる] を選択します (既定では EmEditor Professional のみ)。

ファイルを開くダイアログで、いつも決まったフォルダから開くようにするには?

[ツール] メニューのカスタマイズを選択し、[開く/保存フォルダを記憶] をチェックすると、次回ファイルを開くダイアログでは、前回使用したフォルダを開くようになります。

毎回、決まったフォルダから開きたい場合は、EmEditor を通常起動するショートカットのプロパティを表示し、[リンク先] テキスト ボックスに、/cd を追加します。例えば、EmEditor のインストール先が、”C:Program FilesEmEditor” だとすると、”C:Program FilesEmEditoremeditor.exe” /cd と入力します。さらに、[作業フォルダ] テキスト ボックスに、通常開くフォルダを入力しておきます。

サイズが 0 のファイルを保存するには?

プロパティの [ファイル] タブの [保存時...] ボタンをクリックし、 [保存時、空のファイルを削除] のチェックを外します。

印刷時の文字が小さいのですが?

印刷のフォントとサイズは変更できます。プロパティの [印刷] タブでフォントとサイズを変更してください。

Macintosh のテキスト ファイルを読もうとすると、いくつかの文字が文字化けしてしまいます。Macintosh のテキスト ファイルを正しく読むにはどうしたらいいでしょうか?

Macintosh は、Windows に比べて微妙に違うコードページを使用しています。Windows には、Macintosh のコードページがインストールされているので、Macintosh のテキスト ファイルを Windows のテキスト ファイルに変換することができます。まず、EmEditor の [ツール] メニューの [エンコードの定義] コマンドを選択し、[新規作成] ボタンをクリックします。[エンコードのプロパティ] ダイアログ ボックスで、[エンコード] ドロップダウン リスト ボックスから 「10001 (MAC – Japanese)」 を選択し、[フォント分類] ドロップダウン リスト ボックスは「日本語」を選択します。[OK] ボタンを 2 回クリックしてダイアログ ボックスを閉じます。

次に EmEditor の [ファイル] メニューから [開く] コマンドを選択し、[ファイルを開く] ダイアログの [エンコード] ドロップダウン リスト ボックスで、「10001 (MAC – Japanese)」を選択し、読みたい Macintosh のファイルを選択します。

ネットワークの共有フォルダで、私の開いているファイルを、他のユーザーが編集できないようにすることは可能ですか?

はい、できます。プロパティの [ファイル] タブの [外部から変更された時] コンボボックスで、[外部から書き込みを禁止する] を選択してください。それでも、他のユーザーは、まだファイルを開くことはできますが、あなたがそのファイルを閉じるまで、他のユーザーはそのファイルに変更を保存することができなくなります。

カラーまたはモノクロで印刷するにはどうしらいいですか?

設定のプロパティの [印刷] タブで [色と下線を無効にする] チェック ボックスをチェックすると、モノクロで印刷されます。また、このチェックをはずすと、カラーで印刷されます。

非常に大きなファイルを開く時の動作がもっと速くならないでしょうか?

設定によっては動作が遅くなることもあります。次の点を確認してください。

  • 設定のプロパティの [基本] タブ で、[折り返し方法] ドロップダウン リスト ボックスに「折り返さない」以外が選択されていると、行の折り返し位置を計算するために、遅くなる場合があります。特に大きなファイルを開く場合は、ここで「折り返さない」を選択するか、[折り返さない] コマンドを実行する方が動作は速くなります。

韓国語、中国語などの Word 文書を EmEditor に貼り付けてテキスト ファイルとして保存するにはどうしたらいいですか?

Windows 2000/XP/2003 が動作するコンピュータを使用する必要があります。Windows 98/Me では、Unicode 形式のクリップボードをサポートしていません。Windows が韓国語、中国語フォントを正しく表示していない場合は、コントロール パネルの [地域と言語のオプション] を選択し、[言語] タブを選択し、[東アジア言語のファイルをインストールする] をチェックする必要があります。

Word 文書を開き、コピーしたい韓国語、中国語などのテキストを選択し、CTRL + C を押してテキストをクリップボードにコピーします。

新規の EmEditor ウィンドウを起動し、CTRL + V を押してクリップボードの中身を EmEditor ウィンドウに貼り付けます。テキストが韓国語、中国語などで表示されるはずですが、もしテキストが正しく表示されない場合、[表示] メニューの [フォント分類] サブ メニューを表示し、韓国語、簡体字中国語、繁体字中国語などを選択します。それでも正しく表示されない場合、[表示] メニューの [フォントの設定] コマンドを選択し、正しいフォント、たとえば、韓国語なら GulimChe などを選択します。

文書を保存するには、[ファイル] メニューから [名前を付けて保存] コマンドを選択し、[エンコード] リストから Unicode または UTF-8 を選択します。ここで、必要なら、韓国語など言語に対応するエンコードを選択することもできます。

XML ファイルを UTF-8 ではなく日本語 (シフト JIS) として開くには?

XML ファイルが UTF-8 として開かれる場合、XML プロパティを表示し、[ファイル] タブを選択し、[開く時のエンコード] ドロップダウン リスト ボックスを確認します。[UTF-8] が選択されている場合、[システム既定] を選択します。[HTML/XMLのCharsetを検出] チェック ボックスがチェックされている場合、XML ファイル内の “encoding=” が検索され、見つかると EmEditor はそのエンコードを使用します。ファイルを開くときのエンコードはファイルを新規作成する場合のエンコードやファイルを保存する時のエンコードとは異なることに注意してください。

Java ファイルまたは XML ファイルを UTF-8 ではなく日本語 (シフト JIS) として開くには?

[JavaまたはXMLで新規作成] コマンドが選択されると、既定では Java ファイルと XML ファイルは UTF-8 で開始します。この設定を変更するには、Java のプロパティ (または XML のプロパティ) を表示し、[ファイル] タブを選択し、[新規作成時] ボタンをクリックし、[エンコード] ドロップダウン リスト ボックスから [システム既定] を選択します。ファイルを新規作成時のエンコードはファイルを新規作成する場合のエンコードやファイルを開く時のエンコードとは異なることに注意してください。

EmEditor を他のアプリケーションから起動して使っていますが、EmEditor でファイルを編集して終了しても、その内容がアプリケーションに伝わらないのはなぜですか?

メール ソフトなど、他のアプリケーションから外部エディタとして EmEditor を指定する場合で、そのアプリケーションが EmEditor のプロセスを監視している場合、EmEditor で保存した内容がそのアプリケーションに反映されなくなる場合があります。この問題に対処するには、EmEditor を起動時に、 /sp オプションを指定して別プロセスとして起動します。ただし、この場合は、タブが有効の状態であっても、別グループとして表示されます。

GB18030 のファイルを開くことはできますか?

はい、できます。まず、[ツール] メニューの [エンコードの定義] を選択します。[新規作成] ボタンをクリックして、[エンコード] ドロップダウン リストから GB18030 を選択します。ファイルをオープンする際、この新しく定義されたエンコードを選択します。

コマンド ラインでエンコードを変換するには?

次のコマンド ライン オプションを使用します。

/cp Encoding — 開く時のエンコードを指定します。
/cps Encoding — 保存時のエンコードを指定します。
/sa “DestFile” — エンコード変換後のファイル名を指定します。
/ss+ — エンコード変換後 Unicode サイン (BOM) を付けて保存します。
/ss- — エンコード変換後 Unicode サイン (BOM) を付けないで保存します。

例えば、日本語 Shift-JIS のファイルを UTF-8 に変換するには、次の構文を使用します。

emeditor.exe “shift-jis.txt” /cp 932 /cps 65001 /ss- /sa “utf8.txt”

参照
エンコード一覧
コマンドライン オプション

エクスプローラから特定の拡張子のファイルをダブルクリックして EmEditor が起動できるようにするには?

[ツール] メニューの [カスタマイズ] を選択し、[ファイル] タブで、[EmEditor と関連付け] ボタンをクリックします。[追加] ボタンをクリックして、ファイルの拡張子を指定すると、その拡張子が EmEditor に関連付けられます。

ファイルを排他制御して開くには?

[ツール] メニューから [すべての設定のプロパティ] を選択します (または、ファイルを開いた後、[ツール] メニューから [現在の設定のプロパティ] を選択します)。[ファイル] タブを選択し [外部で変更された時] ドロップダウン リストから [外部から書き込みを禁止する] を選択します。

Internet Explorer で HTML ファイルをソース表示し、編集して保存すると、Internet Explorer が終了してしまいます。

Windows XP の場合、設定のプロパティの [バックアップ] タブで、[バックアップをごみ箱の保存] がチェックされていると、この問題が再現します。この [バックアップをごみ箱の保存] のチェックを外してお使いください。

EmEditor で Java のクラスを書き、コンパイルすると、「class の前に 3 つの無効な文字があります」というエラーが発生します。エラーで指摘されているような文字は、class キーワードの前に 1 つもないのに、毎回同じエラーが出ます。

ファイルの最上部にある 3 つの文字は UTF-8 の バイト オーダー マーク (BOM)です。既定では、Java ファイルは BOM 付きの UTF-8 で作成されます。新規作成時の既定のエンコードを UTF-8 から変更するには、[現在の設定のプロパティ] からファイル ページを選択し、[新規作成時] ボタンをクリックすると、[新規作成時の詳細]ダイアログが表示されます。そのダイアログで、エンコードを [システム既定エンコード] に変更するか、[Unicodeサイン(BOM)を付ける] のチェックを外してください。

なぜ Internet Explorer で ソースの表示をクリックしたとき、EmEditor もメモ帳も現れないのでしょうか?

これは Internet Explorer の不具合です。Internet Explorer の [ツール] メニューの [インターネット オプション] から [インターネット一時ファイル] の [ファイルを削除] を選択し、インターネット一時ファイルをクリアします。

編集

キーボードで選択を開始するには?

通常のキーボード設定では、F8 を押します。Ctrl + F8 で行選択、Shift + Ctrl + F8 で箱型選択の開始となります。キーボードの設定は、[ツール] – [現在の設定のプロパティ] – [キーボード] で変更できます。

改ページなどのコントロール文字を挿入できますか?

EmEditor で、コントロール文字を入力するには、[編集] – [高度な操作] – [特殊文字を入力] を選択します。または、Ctrl (+ Shift) + 対応するキーで入力できます。ただし、そのキーが、ショートカットキーで定義されていない場合で、さらにプロパティの [基本] で [制御文字の入力を許可] がチェックされている場合に利用できます。

テキストを正しく貼り付けできません。クリップボードの中身は、Netscape Navigator など、他のアプリケーションでコピーされています。

ご使用の他のアプリケーション、たとえば Netscape Navigator では、テキストの ANSI から Unicode への変換に問題があります。通常の貼り付けコマンドを使う代わりに、[ツール] メニュー – [すべてのコマンド] を選択し、[編集] – [貼り付け] – [システム既定エンコードで貼り付け] を選択してください。または、プロパティの基本ページで [常にANSIで貼り付け] をチェックします。

特殊文字を入力するには

[編集] メニューから [高度な操作] を選択し、さらに [特殊文字を入力] を選択します。欧文拡張文字を入力するには、入力したい文字の Unicode のコード値を 16 進数で入力します。欧文文字のコード番号を調べるには、欧文文字のサンプルを参考にしてください。Windows 2000/XP/2003 の場合、[スタート] メニュー – [アクセサリ] – [システム ツール] – [文字コード表] からコード値を調べることもできます。フォントによっては正しく表示できないことがあります。

箱型のテキストを選択するにはどうしたらいいですか?

箱型で選択するには、[Alt] を押しながらマウスで選択するか、[Shift] + [Ctrl] + [F8] を押します。

Microsoft Global IME はどこからダウンロードできますか?

コントロール パネルの [地域のオプション] から他の IME を追加することができますので、Global IME は不要です。

元に戻す コマンドで、挿入した文字を 1 文字ずつ戻したいのですが?

既定では、文字列を挿入してから [元に戻す] コマンドを実行すると、挿入した文字列が一度に戻ります。例えば、「abc」と入力して、[元に戻す] コマンドを 1 回実行するだけで、「abc」の文字列がすべて削除されます。この例で、[元に戻す] コマンドを 1 回実行すると「c」だけが削除されて「ab」が残るようにし、計 3 回 [元に戻す] コマンドを実行しないと「abc」の文字列がすべて削除されないようにするには、[カスタマイズ] ダイアログの [高度] タブの [文字単位で元に戻す (EmEditorを再起動する必要あり)] チェック ボックスをチェックし、EmEditor を一旦閉じてから再度実行してください。そうすると、挿入した文字列が 1 文字ずつ元に戻ります。ただし、日本語入力システム (IME) を利用して入力した文字列やクリップボードから貼り付けた文字列は、常に挿入した文字列の単位で戻ります。

行をアルファベットまたは数字の順番に並べ替えるにはどうしたらいいですか?

[編集] メニューの [区切り値/並べ替え] サブ メニューにある [AからZへ並べ替え] コマンド、[ZからAへ並べ替え] コマンド、[小さい値から大きい値へ並べ替え] コマンド、または [大きい値から小さい値へ並べ替え] コマンドを使用することができます。

スペリングをチェックするにはどうしたらいいですか?

EmEditor Professional v10 以上では、プラグインを使わなくても EmEditor 本体でスペル チェックを行うことができます。スペル チェックを行うには、EmEditor のコンテキスト メニュー (右クリックで表示されるメニュー) のスペル チェックを選択して、スペル チェックを有効にします。このメニューでスペル チェックの項目が表示されない場合は、ツール メニューで [メニューの変更] で 一覧から [コンテキスト メニュー] を選択してから [リセット] を押してください。

既定では、英語 (米国) の辞書がインストールされています。追加の辞書は、[url=http://wiki.services.openoffice.org/wiki/Dictionaries]OpenOffice.org wiki[/url] からダウンロードして使用することができます。EmEditor インストール フォルダの中の Dictionaries というサブ フォルダ (通常、C:Program FilesEmEditorDictionaries) に *.dic と *.aff ファイルをコピーしてお使いください。

特殊文字の入力をキーボードで行うには

欧文文字の多くは、既定で入力するショートカットが割り当てられています。

また、どの文字でも、マクロを使用すれば、好きなキーに割り当てることが可能です。例えば、ä という文字を好きなショートカット キーに割り当てるには、

document.selection.Text=”ä”;

という 1 行のマクロ (この場合、JavaScript) を作成し、InsertA.jsee などというファイル名で保存します。それを、[マクロ] メニューの [選択] を選択して実行すると、この文字を挿入することができます。さらに、設定のプロパティの [キーボード] タブで、[カテゴリ] ドロップダウン リストから「マイ マクロ」を選択して、好きなキーボードに割り当てることが可能です。

対応するかっこ コマンドが動作しません。どうしたらこのコマンドを有効にできるでしょうか?

設定のプロパティの [強調(2)] タブを選択し、[対応するかっこ] の一覧ですべての項目をチェックしてください。すると、Ctrl+] を押すことにより、対応するかっこにジャンプすることができるようになります。

巨大ファイルを開くと、並べ替え (ソート) コマンドが無効になります。並べ替えコマンドが無効になる条件は何でしょうか?

並べ替えコマンドが無効になる要因は 2 つあります。

1. 並べ替えコマンドが有効になるには、[カスタマイズ] ダイアログ ([ツール] メニュー – カスタマイズ) の [高度] タブで、[一時ファイルを使う最小ファイル サイズ] テキスト ボックスに並べ替えしたいファイルのサイズよりも大きい値が指定されている必要があります。

2. 32ビット版 EmEditor を使用されている場合、レジストリ エディタで、次のキーを探します:

HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common

MaxReserveBits という REG_DWORD 値を作成し、10進数で 24 (16進数で 0×18) を設定します。既定値は 10進数で 20 (32ビット版EmEditor) または 24 (64ビット版EmEditor) です。この値は、EmEditor が並べ替えられる最大の行数を指定します。24より大きな値を指定することはできません。24が指定されていると、理論的には、最大行数は 16777216 になります。しかし、OS が巨大メモリを割り当てることができない場合、これよりも少ない行数になることがあります。この場合、Windows を再起動して、EmEditor のみを起動して再試行してみることをおすすめします。64ビット版 EmEditor を使用されている場合、既定が 24 なので、この値を設定する必要はありません。

カーソル位置の元に戻す、やり直しはできませんか?

カーソル位置の場合は、[戻る]、[進む] コマンドになります。
既定のキーボードの場合は、[戻る] (Alt + Left)、[進む] (Alt + Right) がお使いいただけます。
また、ツール バーにこれらのボタンを追加することもできます。

貼り付けコマンドが動作しない

アンチ ウィルス プログラムを確認してください。アンチ ウィルス プログラムは、クリップボードへのアクセスを阻止することがあります。その場合、EmEditor をクリップボードへのアクセスの阻止から明示的に除外する必要があります。

検索

検索ダイアログを表示するとき、カーソル位置の文字列でなく、前回検索した文字列が表示されるようにするには?

[検索する文字列] ドロップ ダウン リストボックスの右にある [>] ボタンをクリックして表示されるメニューから、[カスタム] を選択し、さらにもう一度 [>] ボタンをクリックして表示されるメニューから、[既定として保存] を選択します。

検索 ダイアログに残る過去の文字列を消去するには?

[ツール] – [カスタマイズ] の [履歴のクリア] ボタンで消去できます。

ファイルから検索で、日本語 JIS、日本語 EUC などのファイルは検索できないのでしょうか?

EmEditor Professional では、[ファイルから検索] ダイアログ ボックスで、[エンコード] ドロップダウン リスト ボックスから、日本語 JIS または日本語 EUC を選択することができます。EmEditor Standard では、エンコードを指定することができないため、日本語 JIS、日本語 EUC から検索することはできません。

検索、置換に正規表現は使用できますか?

はい、使用できます。

行頭、または行末で文字列を検索するには?

検索ダイアログで、[正規表現を使用する] をチェックすると、「^」が行頭を意味し、「$」が行末を意味します。行頭で、「xxxxx」を検索したい場合は、検索する文字列に「^xxxxx」と入力します。また、行末で「xxxxx」を検索したい場合は、検索する文字列に「xxxxx$」と入力します。

また、[エスケープ シーケンスを使用する] をチェックすると、「n」が新しい行を意味します。行頭で、「xxxxx」を検索したい場合は、検索する文字列に「nxxxxx」と入力します。また、行末で「xxxxx」を検索したい場合は、検索する文字列に「xxxxxn」と入力します。

正規表現例を教えてください。

2 重引用符に囲まれた文字列
“.*?”

[ ] で囲まれた文字列
[[^[]*?]

変数名
[a-zA-Z_][a-zA-Z_0-9]*

IP アドレス
([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3})

URL
(S+)://([^:/]+)(:(d+))?(/[^#s]*)(#(S+))?

各行のタブ以降の文字列
t.*$

ひらがな
[x{3041}-x{309e}]

全角カタカナ
[x{309b}-x{309c}x{30a1}-x{30fe}]

半角カナ
[x{ff61}-x{ff9f}]

漢字
[x{3400}-x{9fff}x{f900}-x{fa2d}]

漢字記号
[x{3000}-x{3037}]

ハングル
[x{1100}-x{11f9}x{3131}-x{318e}x{ac00}-x{d7a3}]

行頭に // を挿入する
検索: ^
置換: //

行頭の // を削除する
検索: ^//
置換:

行末の空白文字を削除する
検索: s+?$
置換:

「abc」という表記を『abc』に置換
検索: 「(.*?)」
置換: 『1』

という表記を

に置換
検索: 置換:

9/13/2003 という表記を 2003年9月13日に置換
検索: ([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4})
置換: 3年1月2日

a から z の文字を大文字に変換 (EmEditor Professional のみ)
検索: [a-z]
置換: U

単語の最初の文字を大文字に変換 (EmEditor Professional のみ)
検索: ([a-zA-Z])([a-zA-Z]*)
置換: U1L2

改行を含む文字列を検索しても、検索文字列が強調表示されません。

改行を (n) 含む文字列は、強調表示されない仕様となっており、不具合ではありません。EmEditor による文字列の強調方法は、速度を優先するために、基本的に行単位に強調する方法になっているからです。

検索/置換ダイアログが異常に大きいのですが、小さくなりませんか?

ダイアログ ボックスの右下のボーダーをマウスでドラッグすることにより、サイズを変更することができます。

検索/置換ダイアログに改行を含む複数行のテキストを入力するには?

[検索する文字列] ドロップ ダウン リストボックスの右にある [>] ボタンをクリックして表示されるメニューから [複数行] を選択します。さらに、ダイアログ ボックスの右下のボーダーをマウスでドラッグすると、テキスト ボックスの大きさを調節できます。改行を入力するには、CTRL + Enter を使用します。

置換の速度が遅いのですが。

[大文字と小文字を区別する] をチェックすると、速度は大きく改善されます。EmEditor では、内部処理を Unicode で行っていますが、Unicodeの文字列の比較では、ä と Ä など、大文字と小文字を区別しない場合にチェックする部分が多くなるため、時間がかかってしまうのです。

表示

カーソルの形状が、以前は I の形をしていたのに、現在は、のような長方形になっています。また、文字を入力したときに、上書きされてしまいます。

[挿入] モードから [上書] モードに変更されたようです。キーボードの [Insert] を押してください。

半角スペースを別の記号で表示できないでしょうか?

設定のプロパティの [記号] タブで [半角空白表示] チェック ボックスをチェックします。

既定の設定で他の言語ファイルを開くと、文字化けしていますが、表示 - フォント分類 で他の言語を選択すると、さらにわけのわからない文字化けになります。 しかし、ファイル開く時、文字コードをその言語に指定すると、正しく表示されます。 なぜでしょうか?

EmEditor は、内部処理が Unicode になっています。したがって、ファイルを開くときに、ANSI-Unicode への変換を行っています。このとき、エンコードを指定しなければならないのですが、デフォルトでは、OS に依存するエンコード、つまり日本語に変換してしまいます。他言語を開きたい場合は、ファイルを開くときに、その言語を指定しなければならないのです。開いた後に変更したい場合は、[ファイル] メニューの [定義されたエンコードで読み直し] コマンドでその言語を選択してください。

表示 - フォント分類 は、どのようなときに使うのでしょうか?

たとえば Unicode ファイルを読んだ場合、それがどの言語で作成されているかは、EmEditor が自動的に判断することはできません。そこで、[表示] – [文字セット] で指定する必要があるのです。ファイルを新規に作成する場合も、デフォルトの文字セット以外で書きたい場合は、ここで指定することができます。

ページが変わっても続いた行番号を表示するにはどうしたらいいでしょうか? 以前はこのような問題がなかったのですが、何か私の設定が変わったようです。

プロパティの [基本] タブを表示し、[ページ番号を表示] のチェックを外してください。

論理座標、表示座標とはどういう意味でしょうか? 論理行とは何でしょうか?

論理座標は使用中の折り返し方法に関係ない文書の座標を示し、行の折り返しによる改行は数えられません。論理行は文章内の改行の数に依存し、折り返し方法には関係ありません。一方、表示座標は、折り返された行も、行数の合計に含みます。

行番号を EmEditor ウィンドウの左端に表示しています。行が折り返されている時、論理行の中で行番号を増加したくありません。どのように設定したらいいでしょうか?

プロパティの [基本] タブを表示し、[行、桁の表示方法] から論理座標の 1 つを選択します。

Windows XP スタイルの新しいツールバーではなく、以前のスタイルのツールバーを使用したいのですが。

ツールメニューから [ツールバーの変更] を選択し、色の品質で [16色] を選択してください。

タスクバー上のトレイ アイコンを自分の好きなアイコンに変更できますか?

はい、できます。レジストリ エディタ(RegEdit.exe)を実行し、HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common を検索してください。TrayIconFile という値を REG_SZ で作成し、アイコンファイルのパスを指定し、TrayIconIndex という値を REG_DWORD で作成し、アイコンのインデックスを指定してください。また、みなづきさんのツール「MnzkTrayIconChanger」を使っても、アイコンを変更できます。こちらからダウンロードできます。

2 回以上過去の検索した文字列を別の色で強調表示するには?

プロパティの [表示] タブで [検索色] に強調したい検索回数を入力します。さらに、[指定する部分] リスト ボックスを一番下までスクロールし、[検索した文字列 (2), (3), ...] を選択して、[背景色] ボタンまたは [文字色] ボタンをクリックして、表示したい色を選択します。

カーソル位置の行全体に下線を表示するには?

[ツール] メニューの [現在の設定のプロパティ] を選択し、[スクロール] タブで [水平罫線] チェック ボックスをチェックします。

URL の特定の文字 (例えば、, (カンマ) など) で切れて表示されないようにするには?

プロパティの [リンク] タブを表示し、[認識する文字] に、URL として認識したい文字 (例えば , (カンマ) など) を追加します。

カーソルの縦線が細いのですが、太くできないでしょうか?

Windows Vista では、コントロール パネルの [視覚ディスプレイの最適化] を選択し、[点滅カーソルの太さを設定します] ドロップダウン リストで大きな数字を選択します。
Windows XP では、コントロール パネルの [ユーザー補助のオプション] 選択し、 [画面] タブの [カーソルのオプション] で、[幅] を広くします。

選択範囲内の単語の数を調べるには、どうしたらいいでしょうか?

WordCount プラグインを利用できます。WordCount プラグインは、エムソフト提供プラグインからダウンロードすることができます。

HTML/XML文字参照 ("&#xx") を Unicode 文字にデコードするには?

DecodeUnicode プラグインを利用できます。DecodeUnicode プラグインは、エムソフト提供プラグインからダウンロードすることができます。

各行の改行方法 (CR、LF、CR+LF) を見るには?

[カスタマイズ] ダイアログ ボックスの [ステータス] タブで、[カーソル位置の文字コード] がチェックされている場合、行の最後にカーソルがあるとき、ステータス バーに 0D+0A (CR+LF)、0D (CR のみ)、または 0A (LF のみ) と表示されます。また、プロパティの [記号] タブの [CRとLFを区別して表示] をチェックしていると、改行方法によって異なる記号が表示されます。EmEditor では、各行の改行方法が異なっていても構わないため、このようにして各行の改行方法を表示することができるわけです。

記号 ボタンをツール バーに追加するには?

ツール バー (標準のツール バー) の端をダブルクリックすると、[ツール バーの変更] ダイアログ ボックスが表示されますので、ここで一覧から [記号] ボタンを選択して、ツール バーに追加することができます。または、[ツール] メニューから [ツール バーの変更] を選択して、[ツール バー] の一覧から [ツール バー 1] ダブルクリックします。すると、[ツール バーの変更] ダイアログ ボックスが表示されますので、ここで一覧から [記号] ボタンを選択して、ツール バーに追加することができます。

行番号を表示するには?

[ツール] メニューの [現在の設定のプロパティ] を選択し、[基本] タブをクリックして、[行番号を表示] をチェックします。

HTML、XMLのカーソルのある部分と関係のある部分の背景が灰色になるのがすごく違和感を感じるので、 設定を変更して何も変わらないようにする方法はありますか?

HTML、XMLの設定のプロパティの [強調(2)] タブで、「対応するタグを強調する」のチェックを外します。

複数のファイルを開くと、いつも複数のウィンドウができてしまいます。タブに戻すにはどうしたらいいでしょうか?

[ウィンドウ] メニューの [タブを有効にする] がチェックされていることを確認します。

ユーザー インターフェイスの言語を変更するにはどうしたらいいですか?

カスタマイズ ダイアログの言語タブに行くと、ユーザー インターフェイスの言語を変更することができます。

各種設定

メールアドレスをクリックして、他のメールソフトを起動するにはどうしたらいいですか?

起動したいメール ソフトが、既定のメール ソフトに設定されている必要があります。メール ソフトにそのような設定項目がある場合は、それを設定します。もし見つからない場合、エクスプローラの [表示] メニューの [オプション] の [ファイル タイプ] タブを表示します。[URL:MailTo Protocol] を選択し、アクションの一覧から [open] をダブルクリックし、[アクションを実行するアプリケーション] に、利用するメールソフトのパスとオプションを入力します。オプションについては、メールソフトによって異なるので、メールソフトのヘルプなどをご覧ください。例えば、Winbiff の場合は、”C:PROGRAM FILESORANGESOFTWINBIFFWINBIFF.EXE” /M と入力します。メールソフトによっては、対応していない場合があります。

URL をクリックしても、表示に使用したいウェブ ブラウザが起動しないのですが。

例えば、Netscape Navigator やその他のウェブ ブラウザを利用する場合、使用するウェブ ブラウザの設定で、標準のウェブ ブラウザになるよう設定します。

EmEditor で URL をクリックすると、標準のウェブ ブラウザが起動するようになります。

日付と時刻 コマンドで挿入する日付や時刻の形式を変更するには?

コントロールパネルの [地域と言語のオプション] を選択し、[地域とオプション] タブの [標準と形式] ボックスの [時刻] と [短い形式] で設定します。これは、メモ帳と同じ仕様です。

EmEditor 起動時に、自動的にかな漢字変換を有効にするには?

[ツール] メニューの [現在の設定のプロパティ] – [基本] タブで [かな漢字変換を起動] チェック ボックスをチェックします。

他のコンピュータで、定義している設定プロパティをコピーする方法は、ありますか?

EmEditor Version 5 以上では、[ツール] メニューの [インポートとエクスポート] を選択して、現在の設定をエクスポートします。そのファイルを別のコンピュータに持っていき、そのファイルをインポートします。

以前のバージョンの EmEditor の場合は、レジストリ エディタ (Regedit.exe) で HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3 をファイルに書き出して、別のコンピュータにコピーし、そのファイルをレジストリエディタで読みます。ただし、後からプロパティのフォルダ名の部分は自分で変更する必要があるかもしれません。

ASP 用の設定はないですか?

ASP の構文は HTML の設定に含まれており、埋め込まれているスクリプト (通常、VBScript または JavaScript で書かれています) は VBScript または JavaScript の設定にしたがって強調表示されます。

プロパティの 強調(2) タブにある 特別な構文 コンボボックスの中の HTML および HTML-埋め込み とは何ですか?

[HTML] は、SCRIPT type=…で始まるスクリプトが HTML ファイルに含まれている場合や、%で始まるスクリプトを含む ASP ファイルで利用されます。これらのスクリプトには通常 VBScript、JavaScript、PerlScript、CSS を含みます。[HTML-埋め込み] は、PHP や JSP のように ? や % など #ScriptBegin で指定した文字列から始まるスクリプトを含む HTML ファイルに利用されます。

HTML、または XML ファイルを保存する際に、EmEditor はUnicode 文字を文字参照 "Numerical Character References" (NCRs - など) として、エンコードすることはできますか?

はい、できます。プロパティの [ファイル] タブにある [保存時...] ボタンをクリックし、[Unicode文字をHTML/XMLの文字参照として保存] をチェックします。© のように名前による実体参照を保存したい場合は、[名前による実体参照を使用する] もチェックします。HTML と XML の設定では、これらのチェックボックスは既定の設定として、チェックされています。しかし、現在、HTML または、XML ファイルを読み込む際、NCR を Unicode 文字としてデコードしたり、表示することはできません。

ファイル メニューの、読み直し のサブメニューには、同じエンコード、自動検出、システム既定、UTF-16LE、UTF-16BE、UTF-8、UTF-7 しか利用できるエンコードがありません。エンコードを追加するには?

EmEditor を正しくインストールせずに、他の PC から emeditor.exe をそのままコピーし、実行した場合、いくつかのシステム エンコードが利用できない場合があります。Windows 2000/XP/2003 を使用し User 権限でのみログオンして、v3.27 以前の EmEditor を使用している場合は、いくつかのエンコードが見れないバグが EmEditor にありましたので、それが原因の可能性があります。

追加のシステム エンコードをセットアップするには、Windows 2000/XP/2003 を使用している場合は、Power User か Administrator 権限でログオンし、[ツール] メニューから [エンコードの定義] コマンドを選択し、[リセット] ボタンをクリックしてください。

利用できるエンコードは、Windows にどの言語システム ファイルがインストールされているかによります。EmEditor で、特定のエンコードを見つけることができない場合、コントロール パネル-地域のオプションで追加したい言語をインストールしてください。Windows に言語システム ファイルを追加した後、EmEditor の [ツール] メニューから [エンコードの定義] コマンドを選択し、[リセット] ボタンをクリックしてください。

バージョンアップ後、新しいコマンドをメニューに追加したり、新しいキーボード ショートカットを追加する方法は?

新しいコマンドがメニューに表示されない場合は、[ツール] メニューの [メニューの変更] コマンドを選択し、[リセット] ボタンをクリックすると、メニューがすべて既定にリセットされます。また、[すべての設定のプロパティ] を選択し、[キーボード] タブで [リセット] ボタンをクリックすると、新しいコマンドのキーボード ショートカットが追加されます。

2 ストローク キーのショートカットを定義するには?

ユーザー メニューとキーボード割り当て機能の両方を使用して、2 ストローク キーのショートカットを定義することが可能です。既定では、Ctrl+K がユーザー メニュー (1) を使用する 2 ストローク キーの最初のキーとしてあらかじめ定義されています。以下は、あらかじめ定義されたショートカット一覧です。

CTRL+K, K ブックマークを設定/定義
CTRL+K, N この文書の次のブックマーク
CTRL+K, P この文書の前のブックマーク
CTRL+K, L この文書のブックマークをクリア
CTRK+K, C コメント挿入
CTRK+K, U コメント削除

この一覧で、2 番目のキーは Ctrl キーと共にでも共にでなくても、動作します。たとえば、[ブックマークを設定/定義] コマンドは、Ctrl を押しながら K を押した後、Ctrl を押しても押さなくても K を押すことにより動作します。

新しい 2 ストローク キーのショートカットを追加するには、以下の手順に従います。

1. [ヘルプ] メニューで [キーボード マップ] を選択します。
2. すべての設定で同じショートカットを使用したい場合は、ツール バーで [すべての設定] ボタンをクリックします。
3. [ユーザー メニュー (2)] まで下にスクロールしてダブルクリックします。
4. 設定のプロパティで、[追加するショートカット キー] テキスト ボックスに設定したいショートカットをタイプします。たとえば、Ctrl+; を押します。
5. [割り当て] ボタンをクリックして OK をクリックします。
6. [キーボード マップ] ウィンドウを閉じます。
7. 次に、[ツール] メニューから [メニューの変更] を選択します。
8. [変更するメニュー] リスト ボックスから [ユーザー メニュー (2)] を選択します。
9. [右に挿入] ボタンをクリックします。
10. [メニューのプロパティ] で、ショートカットを割り当てたい新しいコマンドを選択します。
11. [名称] テキスト ボックスで、「&」を使用してショートカット キーを指定します。「&」の右側の文字が 2 ストローク キーの 2 番目のショートカットの文字を指定します。

たとえば、[新規作成して貼り付け] コマンドの 2 番目のショートカット キーを「N」に設定したい場合、以下の手順に従います。

1. [分類] 一覧から [ファイル] を選択します。
2. [コマンド] 一覧から [新規作成して貼り付け] を選択します。
3. [名称] テキスト ボックスに、「新規作成して貼り付け(&N)」とタイプします。
4. OK をクリックします。

この操作を繰り返して、好きなだけコマンドを定義します。

既定では、ユーザー メニューは最初のキーを押してから 1 秒後に表示されます。2 番目のショートカット キーは、ユーザー メニューが表示される前でも動作します。[メニューの変更] ダイアログの下部の [遅延時間] スライダを調節することにより、各ユーザー メニューの遅延時間を変更することができます。

Ctrl + マウス ホイールでフォントのサイズを変更できますが、これを無効にできないでしょうか?

[カスタマイズ] ダイアログの [マウス] タブで、[Ctrl + ホイールでフォント サイズ変更] チェック ボックスをクリアしていただければ、この機能が無効になります。

タブをダブルクリックすると、別のウィンドウになってしまいます。 この動作を無効にすることはできますか?

はい。[カスタマイズ] ダイアログの [マウス] タブで、[マウスの左ボタンをダブル クリック] ドロップダウンに [新しいグループ] が選択されていたら、[未定義] を選択します。

ツール

EmEditor から現在開いているファイルをコンパイルするために、外部コンパイラを実行するには?

外部ツールの定義例を教えてください。の「Visual C++ でコンパイル」を参考にしてください。

Google でカーソル位置の単語を検索するには?

[ツール] メニューの [外部ツール] サブ メニューから [外部ツールの設定] コマンドを選択し、[外部ツール] ダイアログ ボックスを表示します。[新規作成] ボタンをクリックし、[外部ツールのプロパティ] ダイアログ ボックスを表示します。[コマンド] テキスト ボックスで、http://google.com/search?ie=Shift_JIS&q=$(CurText) と入力します。

EmEditor で編集中のファイルをコマンド プロンプトで実行するツールでコンパイルしたいのですが、コンパイル後もコマンド プロンプトのウィンドウを閉じないようにするには?

[ツール] メニューの [外部ツール] サブ メニューから [外部ツールの設定] コマンドを選択し、[外部ツール] ダイアログ ボックスを表示します。[新規作成] ボタンをクリックし、[外部ツールのプロパティ] ダイアログ ボックスを表示します。[コマンド] テキスト ボックスで cmd.exe と入力し、[引数] テキスト ボックスで /k “filename” $(Path) と入力します。

外部ツールの定義例を教えてください。

・インターネット エクスプローラを開く

[コマンド] C:Program FilesInternet Exploreriexplore.exe
[引数] $(Path)
[初期ディレクトリ] $(Dir)
[アイコン パス] C:Program FilesInternet Exploreriexplore.exe
[ファイルを保存] をチェック

・エクスプローラを開く

[コマンド] %WinDir%explorer.exe
[引数] $(Dir)
[初期ディレクトリ] $(Dir)
[アイコン パス] %WinDir%explorer.exe

・コマンド プロンプトを開く

[コマンド] %WinDir%system32cmd.exe
[引数] $(Dir)
[初期ディレクトリ] $(Dir)
[アイコン パス] %WinDir%system32cmd.exe

・Visual C++ でコンパイル

[コマンド] %WinDir%system32cmd.exe
[引数] /k “C:Program FilesVisual StudioVc7binvcvars32.bat”&&cl $(Path)
[初期ディレクトリ] $(Dir)
[アイコン パス] C:Program FilesVisual StudioCommon7IDEdevenv.exe
[ファイルを保存] をチェック

・関連付けられたファイルを実行

[コマンド] $(Path)
[引数]
[初期ディレクトリ] $(Dir)
[アイコン パス]
[ファイルを保存] をチェック

・Google でカーソル位置の単語 (または選択した文字列) を検索

[コマンド] http://google.com/search?q=$(CurText)
[引数]
[初期ディレクトリ]
[アイコン パス]

・Microsoft Visual SourceSafe からチェック アウトする

[コマンド] %WinDir%system32cmd.exe
[引数] /k C:(SourceSafe のパス)CommonVSSwin32SS.EXE checkout $/(パス)/$(Filename).$(Ext) -y(ユーザー名)
[初期ディレクトリ] $(Dir)
[アイコン パス] C:(SourceSafe のパス)CommonVSSwin32SSEXP.EXE

・Microsoft Visual SourceSafe にチェック インする

[コマンド] %WinDir%system32cmd.exe
[引数] /k C:(SourceSafe のパス)CommonVSSwin32SS.EXE checkin $/(パス)/$(Filename).$(Ext) -y(ユーザー名)
[初期ディレクトリ] $(Dir)
[アイコン パス] C:(SourceSafe のパス)CommonVSSwin32SSEXP.EXE
[ファイルを保存] をチェック

[コマンド]、[引数]、[初期ディレクトリ]、[アイコン パス] には、次のあらかじめ定義された引数を使うことができます。

$(Path) ファイルの完全パス名
$(Dir) ファイルのディレクトリ名
$(Filename) 拡張子を除くファイル名
$(Ext) ファイルの拡張子
$(CurLine) カーソル位置の論理行番号
$(CurText) テキストが選択されている場合は選択した文字列、選択されていない場合はカーソル位置の単語

その他、%WinDir% などの環境変数が利用できます。

マクロ

VBScript の MsgBox を使えないのですか?

残念ながら、MsgBox は使えません。その代わり、WshShell オブジェクトの Popup メソッドが利用できます。

この例では、「Continue?」というメッセージを表示し、[はい]、[いいえ]、および [キャンセル] の 3 個のボタンを表示します。[はい] ボタンが選択されると 6 が [いいえ] ボタンが選択されると 7 が、[キャンセル] ボタンが選択されると 2 が変数 n に代入されます。

[JavaScript]
WshShell = new ActiveXObject( “WScript.Shell” );
n = WshShell.Popup( “Continue?”, 0, “EmEditor”, 3 );

[VBScript]
Set WshShell = CreateObject( “WScript.Shell” )
n = WshShell.Popup( “Continue?”, 0, “EmEditor”, 3 )

複数のクイック マクロをファイルに保存できますか?

[マクロ] メニューの [名前を付けて保存] コマンドで、ファイルに保存することができます。

ウィンドウ

ウィンドウの 4 分割は何のために利用するのですか?

たとえば、文章の最初の部分を参考にしながら、最後の部分を書いたりするのに便利です。4 分割されたそれぞれの場所で別のファイルを編集することはできません。

EmEditor のウィンドウ サイズを保存し、いつも同じウィンドウ サイズで EmEditor を開くには?

EmEditor をお好きなサイズに変更してから、[ツール] メニューから [カスタマイズ] コマンドを選択し、[カスタマイズ] ダイアログ ボックスを表示します。そして、[ウィンドウ] タブで[現在のウィンドウ位置を保存] ボタンをクリックします。

いつも、EmEditor ウィンドウを最大化して開くには?

まず、EmEditor ウィンドウを最大化し、[ツール] メニューから [カスタマイズ] コマンドを選択し、[カスタマイズ] ダイアログ ボックスを表示します。そして、[ウィンドウ] タブで [現在のウィンドウ位置を保存] ボタンをクリックし、[起動時、ウィンドウ位置を復元] チェック ボックスをチェックします。

現在開いている EmEditor ウィンドウの位置と開いているファイル名を保存しておき、次回、一度にすべてのウィンドウを以前と同じ位置に開くには?

トレイ アイコン上でマウスの左ボタンを押してトレイ アイコン メニュー 1 を表示し、[ワークスペースを保存] コマンドを選択すると、現在開いているウィンドウの位置と開いているファイル名、さらにカーソル位置など、ワークスペースの状態を保存します。次に、すべてファイルを閉じるか別のファイルを開いた後、同じトレイ アイコン メニューの [ワークスペースを復元] コマンドを選択すると、さきほど保存したウィンドウの位置に、同じファイル名、カーソル位置でワークスペースの状態を復元します。

[ワークスペースを保存] コマンドを選択する代わりに、ワークスペースを保存してすぐにすべてのウィンドウを閉じるには、[ワークスペースを保存してすべて閉じる] コマンドを、また、ワークスペースを保存してすべてのファイルを保存して閉じるには、[ワークスペースを保存してすべて保存して閉じる] コマンドを利用することができます。

タブ付きウィンドウのように表示するには?

[ウィンドウ] メニューの [タブを有効にする] コマンドを選択し、このコマンドがチェックされた状態にします。

どうして 重ねて表示、上下に並べて表示、水平に並べて表示 を選択しても動作しないのですか?

タブが有効の状態で、[重ねて表示]、[上下に並べて表示]、[水平に並べて表示] を選択した場合、タブを無効にしません。複数のグループが存在する場合に、そのグループを重ねて、あるいは並べて表示します。したがって、1 つのグループしか存在しない場合、これらのコマンドには意味がありません。これはユーザーの皆様からの要望にお応えした仕様の変更です。従来の動作を希望される場合は、一旦、タブを無効にしてから、これらのコマンドを選択してください。[新しい水平グループ]、[新しい垂直グループ] を使用すると、1 つのグループしか存在しない場合でもウィンドウを並べて表示することができます。

タブが有効で文書が 1 個だけ開いているとき、文書を閉じても EmEditor が終了しないようにするには?

[ツール] メニューで [カスタマイズ] を選択し、[ウィンドウ] タブで、[最後の文書を閉じる時ウィンドウを閉じない] をチェックします。

左から右に順番にアクティブなタブを移動する方法はありますか?

はい。[ツール] メニューで [カスタマイズ] を選択し、[ウィンドウ] タブで、[次の文書コマンドで最後に使用した文書に切り替える] チェック ボックスのチェックを外します。チェックされていなければ、Ctrl+Tab を押すと左から右へ、Ctrl+Shift+Tab を押すと右から左へタブを切り替えることができます。チェックされていると、Ctrl+Tab と Ctrl+Shift+Tab は、アクティブな文書と最後に表示した文書とを切り替えることになります。

プラグイン

アウトライン カスタム バーを隠したままで、アウトライン ガイド (コードの折りたたみ) を有効にするには?

アウトライン プラグインのプロパティで、[カスタム バーが表示されていないとき、アウトライン ガイドを表示しない] のチェックを外します。

検索バー プラグインを閉じるには、検索バー ボタンを 2 回クリックしなければならないのはどうしてですか?

検索バーが表示されているときに、プラグイン バーの検索バー ボタンをクリックすると、キーボード フォーカスが検索バーにない場合は、検索バーにフォーカスを移動します。検索バーにフォーカスが存在するときに、プラグイン バーの検索バー ボタンをクリックすると、検索バーが非表示になります。つまり、エディタのビュー上にカーソルが点滅しているときに検索バーを閉じるには、検索バー ボタンを 2 回クリックしなければならないことになります。

以上の動作を利用して、このプラグインのコマンドにキーボード ショートカットを割り当てることにより、ショートカット キーで簡単にプラグインの [検索] ドロップダウン リストにフォーカスを移動することができます。ショートカット キーでの移動を実現するため、以上の動作を仕様としているわけです。

HTML のファイルをアクティブにしたとき、HTML ツールバーが常に表示されるようにするには?

プラグイン ツール バーの HTML バー ボタンで右クリックを行い、表示されるメニューからプロパティを選択します (または、ツール メニューの [プラグイン] – [プラグインの設定] を選択し、一覧から HTMLBar をダブルクリックします)。[設定された選択で HTML バーを自動的に表示する] をチェックします。すると、一覧でチェックされている設定の場合だけ自動的に HTML バーが表示されるようになります。

購入方法

購入したら、新しいバージョンも無料で利用できますか? それとも、新しいバージョンについて、別々に登録料を支払わなければなりませんか?

永久ライセンスを購入された場合、すべての新しいバージョンは無料で入手していただけます。

普通ライセンスを購入された場合、購入日より 1 年間は無料で最新版を入手していただけます。購入日より 1 年後は、保守プランに購読されている間に限り、最新版を入手していただけます。

現在インストールされている EmEditor のバージョンと Professional か Standard かを調べるにはどうしたらいいですか?

EmEditor の [ヘルプ] メニューの [バージョン情報] コマンドを選択すると、[EmEditor のバージョン情報] ダイアログ ボックスが表示されます。そして、ダイアログ ボックスの上部に、「EmEditor Professional」、または「EmEditor Standard」と表示されます。また、その横にバージョン番号が書かれています。

普通ライセンスを購入しようとすると、サブスクリプション条件に同意する必要がありますか?

オンラインで普通ライセンスを購入しようと、以下の「サブスクリプション条件」(購読条件)が表示されます。

subscription_jp

「はい、サブスクリプション条件に同意します。」をチェックしないと、先に進むことができませんが、ご注文の完了後すぐにサブスクリプションに請求されません。

購入後、1年後にサブスクリプションに請求されないようにするには、ご注文後、すぐにサブスクリプションをキャンセルすることができます。購入されたウェブサイト (Share-it) からサブスクリプションをキャンセルすることができます。または、Share-it のご注文番号を添えて、お問い合わせフォームより、サブスクリプションのみのキャンセルのご指示をいただければ、弊社ですぐにサブスクリプションをキャンセルいたします。

オンラインで EmEditor を購入しようとすると、「ダウンロード期間の延長」が既にカートに入っていますが、これは必要ですか?

オンラインで EmEditor を購入しようとすると、以下の「ダウンロード期間の延長」が表示されます。

download-protection-jp

「ダウンロード期間の延長」は、Share-it が独自に提供しているものであり、たとえば弊社が製品の販売を中止した場合でも、ダウンロードを12か月間保証するものであり、通常は必要ではありません。EmEditor の開発が継続する限り、EmEditor の最新版は、常に EmEditor ウェブサイトよりダウンロードしていただけます。「ダウンロード期間の延長」は、画面の右側のごみ箱のアイコンをクリックすることにより、カートから削除していただけます。

また、「バックアップ CD/DVD」も不要であれば、カートから削除していただくことができます。これらの追加物は、弊社と Share-it との売買契約上、最初から既定で追加されて販売されることになっています。お客様でご不要な場合、お手数ですが、削除してからご購入していただけますようお願い申し上げます。

請求書、見積書を発行できますか?

請求書、見積書などの書類が必要な場合は、オンライン (Share-it) の購入ではなく、エムソフトへ直接送金して購入 https://www.emurasoft.com/support/order_product.php を選択して、備考欄に必要な書類、送付先住所、御社名などをご記入の上、ご注文ください。米国からの郵送のため、書類が届くまで10日間ほどかかりますがご了承ください。さらに多くの書類が必要な場合、販売代理店 (ソフトバンク コマース&サービス、シネックスインフォテックなど) からのご購入をおすすめします。

普通ライセンスと永久ライセンスの違いは何ですか?

どちらも現在のバージョンの EmEditor は永久にお使いいただけます。ただし、アップグレードを行いたい場合、普通ライセンスでは、保守プランを購入する必要があります。永久ライセンスをお持ちですと、アップグレードも製品が存在する期間、無料で取得することができます。

更新を行おうとすると、 「お客様によっては、アップグレードの購入が必要になることがあります。」 と書かれたダイアログが表示されます。どのようにすると、購入が必要かどうかがわかりますか?

アップグレード ページを表示して、メールアドレス、または古い登録キーを入力します。すると、無料アップグレードが可能か、購入が必要かどうかを調べることができます。

トラブルシューティング

異常終了を報告するにはどうしたらいいでしょうか?

EmEditor が異常終了すると、crash- で始まる名前のファイルが、通常 C:ProgramData\Emurasoft\EmEditor\Error フォルダに作成されます。一番最近のファイルを ZIP 形式に圧縮して、tech@emurasoft.com 宛メールの添付ファイルで送っていただけると幸いです。その際、異常終了が発生する条件や再現できる手順を明記してくださいますようお願いいたします。

EmEditor を起動しようとすると、ワークスペースの非常に大きなファイルをロードしようとします。 これを無効にすることはできませんか?

EmEditor が最後に使用したワークスペースを開こうとしています。
コマンド プロンプトで、

emeditor.exe /clw

と指定して起動すると、最後に使ったワークスペースの情報を消去して、
無題の EmEditor ウィンドウを開くことができます。

ダウンロード

無料版の EmEditor (EmEditor Free) は、どこからダウンロードできますか?

EmEditor Free は、EmEditor Professional と別のプログラムではなく、同じバイナリで、両方の機能を果たします。EmEditor Free/Professional は、ダウンロード ページからダウンロードしていただけます。
EmEditor をインストールした後、[ダウングレード] コマンドを選択することにより、Free 版に変更することができます。[ダウングレード] コマンドは、クイック起動ウィンドウ (Ctrl+Q) で、「ダウングレード」と入力することにより見つけことができます。Professional 版と Free 版の切り替え方法は、EmEditor Freeをご覧ください。

古いバージョンの EmEditor は、どこからダウンロードできますか?

古いバージョンの EmEditor は、ライブラリ ページ
の「EmEditor Old Versions」フォルダよりダウンロードしていただけます。